Author: frankie
Date: 2006-08-08 16:39:04 +0000 (Tue, 08 Aug 2006)
New Revision: 509

Added:
   packages/pkg-grass/debian/grass-dev.dirs
   packages/pkg-grass/debian/grass-dev.install
Removed:
   packages/pkg-grass/debian/libgrass-dev.dirs
   packages/pkg-grass/debian/libgrass-dev.install
   packages/pkg-grass/debian/libgrass.dirs
   packages/pkg-grass/debian/libgrass.install
   packages/pkg-grass/debian/libgrass.lintian-overrides
   packages/pkg-grass/debian/libgrass.postinst
   packages/pkg-grass/debian/libgrass.postrm
Modified:
   packages/pkg-grass/debian/changelog
   packages/pkg-grass/debian/control
   packages/pkg-grass/debian/grass.install
   packages/pkg-grass/debian/rules
   packages/pkg-grass/debian/watch
Log:
Preparing for release 6.0.2-4


Modified: packages/pkg-grass/debian/changelog
===================================================================
--- packages/pkg-grass/debian/changelog 2006-08-08 12:17:54 UTC (rev 508)
+++ packages/pkg-grass/debian/changelog 2006-08-08 16:39:04 UTC (rev 509)
@@ -1,3 +1,15 @@
+grass (6.0.2-4) unstable; urgency=low
+
+  * Moved to libgdal1-1.3.2-dev build-dep, now available.
+  * Removed libgrass bin-package and introduced required 
conflicts/provides/replaces items to manage upgrades.
+    Removed all related files in debian/
+    (closes: #361962)
+  * Removed another extra license file.
+  * Watch file revised.
+  * Moved libgrass-dev to grass-dev package and changed section.
+
+ -- Francesco Paolo Lovergine <[EMAIL PROTECTED]>  Tue,  8 Aug 2006 18:24:19 
+0200
+
 grass (6.0.2-3) unstable; urgency=low
 
   * Change build-dependency on xlibmesa-gl-dev to libgl1-mesa-swx11-dev;

Modified: packages/pkg-grass/debian/control
===================================================================
--- packages/pkg-grass/debian/control   2006-08-08 12:17:54 UTC (rev 508)
+++ packages/pkg-grass/debian/control   2006-08-08 16:39:04 UTC (rev 509)
@@ -3,13 +3,16 @@
 Priority: extra
 Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
 Uploaders: Francesco Paolo Lovergine <[EMAIL PROTECTED]>, Steve Halasz <[EMAIL 
PROTECTED]>
-Build-depends: flex, bison, libreadline5-dev | libreadline-dev, 
libncurses5-dev, lesstif2-dev, debhelper (>= 4.0.2), dpatch, libtiff4-dev, 
tcl8.4-dev, tk8.4-dev, fftw3-dev, libxmu-dev, libgl1-mesa-swx11-dev;, 
libglu1-xorg-dev | xlibmesa-glu-dev, libfreetype6-dev, autoconf2.13, 
autotools-dev, libgdal1-1.3.1-dev, proj (>= 4.4.7), libjpeg62-dev, 
libpng12-dev, libpq-dev | postgresql-dev, unixodbc-dev, doxygen, fakeroot, 
libmysqlclient15-dev | libmysqlclient14-dev, graphviz
+Build-depends: flex, bison, libreadline5-dev | libreadline-dev, 
libncurses5-dev, lesstif2-dev, debhelper (>= 4.0.2), dpatch, libtiff4-dev, 
tcl8.4-dev, tk8.4-dev, fftw3-dev, libxmu-dev, libgl1-mesa-swx11-dev, 
libglu1-xorg-dev | xlibmesa-glu-dev, libfreetype6-dev, autoconf2.13, 
autotools-dev, libgdal1-1.3.2-dev, proj (>= 4.4.7), libjpeg62-dev, 
libpng12-dev, libpq-dev | postgresql-dev, unixodbc-dev, doxygen, fakeroot, 
libmysqlclient15-dev | libmysqlclient14-dev, graphviz
 Standards-Version: 3.7.2
 
 Package: grass
 Section: science
 Architecture: any
-Depends: ${shlibs:Depends}, xterm | x-terminal-emulator, libgrass (= 
${Source-Version})
+Depends: ${shlibs:Depends}, xterm | x-terminal-emulator
+Provides: libgrass
+Conflicts: libgrass
+Replaces: libgrass
 Suggests: grass-doc, gdal-bin, e00compr, avce00, gpstrans, gnuplot
 Description: Geographic Resources Analysis Support System
  Commonly referred to as GRASS, this is a Geographic Information
@@ -36,11 +39,14 @@
  .
   Homepage: http://grass.itc.it/gdp/
 
-Package: libgrass
-Section: libs
+Package: grass-dev
+Section: devel
 Architecture: any
 Depends: ${shlibs:Depends}, grass (= ${Source-Version})
-Description: GRASS GIS development libraries
+Provides: libgrass-dev
+Conflicts: libgrass-dev
+Replaces: libgrass-dev
+Description: GRASS GIS development files
  Commonly referred to as GRASS, this is a Geographic Information
  System (GIS) used for geospatial data management and analysis,
  image processing, graphics/map production, spatial modeling, and
@@ -48,25 +54,9 @@
  settings around the world, as well as by many government agencies
  and environmental consulting companies.
  .
- These libraries provide the means to access and manipulate GRASS
- data sets.
- .
-  Homepage: http://grass.itc.it
-
-Package: libgrass-dev
-Section: libdevel
-Architecture: any
-Depends: ${shlibs:Depends}, libgrass (= ${Source-Version})
-Description: GRASS GIS library development files
- Commonly referred to as GRASS, this is a Geographic Information
- System (GIS) used for geospatial data management and analysis,
- image processing, graphics/map production, spatial modeling, and
- visualization. GRASS is currently used in academic and commercial
- settings around the world, as well as by many government agencies
- and environmental consulting companies.
- .
  This package contains the header files for developing with GRASS.
  Install this package if you wish to develop software that manipulates
  GRASS data sets.
  .
   Homepage: http://grass.itc.it
+

Copied: packages/pkg-grass/debian/grass-dev.dirs (from rev 508, 
packages/pkg-grass/debian/libgrass-dev.dirs)

Copied: packages/pkg-grass/debian/grass-dev.install (from rev 508, 
packages/pkg-grass/debian/libgrass-dev.install)

Modified: packages/pkg-grass/debian/grass.install
===================================================================
--- packages/pkg-grass/debian/grass.install     2006-08-08 12:17:54 UTC (rev 
508)
+++ packages/pkg-grass/debian/grass.install     2006-08-08 16:39:04 UTC (rev 
509)
@@ -5,3 +5,4 @@
 usr/lib/grass/etc
 usr/lib/grass/fonts
 usr/lib/grass/scripts
+usr/lib/grass/lib

Deleted: packages/pkg-grass/debian/libgrass-dev.dirs
===================================================================
--- packages/pkg-grass/debian/libgrass-dev.dirs 2006-08-08 12:17:54 UTC (rev 
508)
+++ packages/pkg-grass/debian/libgrass-dev.dirs 2006-08-08 16:39:04 UTC (rev 
509)
@@ -1,2 +0,0 @@
-usr/lib/grass/include
-usr/lib/grass/include/Make

Deleted: packages/pkg-grass/debian/libgrass-dev.install
===================================================================
--- packages/pkg-grass/debian/libgrass-dev.install      2006-08-08 12:17:54 UTC 
(rev 508)
+++ packages/pkg-grass/debian/libgrass-dev.install      2006-08-08 16:39:04 UTC 
(rev 509)
@@ -1 +0,0 @@
-usr/lib/grass/include

Deleted: packages/pkg-grass/debian/libgrass.dirs
===================================================================
--- packages/pkg-grass/debian/libgrass.dirs     2006-08-08 12:17:54 UTC (rev 
508)
+++ packages/pkg-grass/debian/libgrass.dirs     2006-08-08 16:39:04 UTC (rev 
509)
@@ -1 +0,0 @@
-usr/share/lintian/overrides

Deleted: packages/pkg-grass/debian/libgrass.install
===================================================================
--- packages/pkg-grass/debian/libgrass.install  2006-08-08 12:17:54 UTC (rev 
508)
+++ packages/pkg-grass/debian/libgrass.install  2006-08-08 16:39:04 UTC (rev 
509)
@@ -1 +0,0 @@
-usr/lib/grass/lib

Deleted: packages/pkg-grass/debian/libgrass.lintian-overrides
===================================================================
--- packages/pkg-grass/debian/libgrass.lintian-overrides        2006-08-08 
12:17:54 UTC (rev 508)
+++ packages/pkg-grass/debian/libgrass.lintian-overrides        2006-08-08 
16:39:04 UTC (rev 509)
@@ -1,4 +0,0 @@
-# These are not useless calls. lintian just doesn't know that
-# /usr/lib/grass/lib is in ld.so.conf
-libgrass binary: postinst-has-useless-call-to-ldconfig
-libgrass binary: postrm-has-useless-call-to-ldconfig

Deleted: packages/pkg-grass/debian/libgrass.postinst
===================================================================
--- packages/pkg-grass/debian/libgrass.postinst 2006-08-08 12:17:54 UTC (rev 
508)
+++ packages/pkg-grass/debian/libgrass.postinst 2006-08-08 16:39:04 UTC (rev 
509)
@@ -1,21 +0,0 @@
-#!/bin/sh
-# Make sure grass libraries are picked up by ldconfig
-# Lifted from xfree86 package's shell-lib.sh script
-
-set -e
-
-dir="/usr/lib/grass/lib"
-ldsoconf="/etc/ld.so.conf"
-
-# is the line not already present?
-if ! fgrep -qsx "$dir" "$ldsoconf"; then
-  echo "$dir" >> "$ldsoconf"
-fi
-
-if [ "$1" = "configure" ]; then
-  ldconfig
-fi
-
-#DEBHELPER#
-
-exit 0

Deleted: packages/pkg-grass/debian/libgrass.postrm
===================================================================
--- packages/pkg-grass/debian/libgrass.postrm   2006-08-08 12:17:54 UTC (rev 
508)
+++ packages/pkg-grass/debian/libgrass.postrm   2006-08-08 16:39:04 UTC (rev 
509)
@@ -1,42 +0,0 @@
-#!/bin/sh
-# Make sure grass library dir is removed from ld.so.conf
-# Lifted from xfree86 package's shell-lib.sh script
-
-set -e
-
-dir="/usr/lib/grass/lib"
-ldsoconf="/etc/ld.so.conf"
-
-if [ "$1" = "remove" ]; then
-  # is the line present?
-  if fgrep -qsx "$dir" "$ldsoconf"; then
-    # rewrite the file (very carefully)
-    set +e
-    fgrep -svx "$dir" "$ldsoconf" > "$ldsoconf.dpkg-tmp"
-    fgrep_status=$?
-    set -e
-    case $fgrep_status in
-      0|1) ;; # we don't actually care if any lines matched or not
-      *) die "error reading \"$ldsoconf\"; fgrep exited with status" \
-        "$fgrep_status" ;;
-    esac
-    set +e
-    cmp -s "$ldsoconf.dpkg-tmp" "$ldsoconf"
-    cmp_status=$?
-    set -e
-    case $cmp_status in
-      0) rm "$ldsoconf.dpkg-tmp" ;; # files are identical
-      1) mv "$ldsoconf.dpkg-tmp" "$ldsoconf" ;; # files differ
-      *) die "error comparing \"$ldsoconf.dpkg-tmp\" to \"$ldsoconf\"; cmp" \
-        "exited with status $cmp_status" ;;
-    esac
-  fi
-fi
-
-if [ "$1" = "remove" ]; then
-  ldconfig
-fi
-
-#DEBHELPER#
-
-exit 0

Modified: packages/pkg-grass/debian/rules
===================================================================
--- packages/pkg-grass/debian/rules     2006-08-08 12:17:54 UTC (rev 508)
+++ packages/pkg-grass/debian/rules     2006-08-08 16:39:04 UTC (rev 509)
@@ -112,17 +112,14 @@
        # fix links
        debian/fixpaths.sh $(CURDIR)/debian/tmp debian/tmp
        
-       # delete extra license file
-       rm -f debian/tmp/usr/lib/grass/etc/license
+       # delete extra license files
+       rm -f debian/tmp/usr/lib/grass/etc/license 
debian/tmp/usr/lib/grass/bwidget/LICENSE.txt
     
        # change section from 1 to .1grass 
        mv debian/tmp/usr/lib/grass/man/man1/grass6.1 debian/grass60.1
        for m in debian/tmp/usr/lib/grass/man/man1/*.1; do n=`basename $$m .1`; 
mv $$m debian/tmp/usr/lib/grass/man/man1/$$n.1grass; done
        for m in debian/tmp/usr/lib/grass/man/man1/*.1grass; do sed -i -e 
's/^.TH \(.*\) 1/.TH \1 1grass/' $$m; done
 
-       # install lintian overrides
-       install -m 644 debian/libgrass.lintian-overrides 
debian/libgrass/usr/share/lintian/overrides/libgrass
-
        # install module makefile       
        install -m 644 include/Make/Module.make 
debian/libgrass-dev/usr/lib/grass/include/Make/Module.make
 

Modified: packages/pkg-grass/debian/watch
===================================================================
--- packages/pkg-grass/debian/watch     2006-08-08 12:17:54 UTC (rev 508)
+++ packages/pkg-grass/debian/watch     2006-08-08 16:39:04 UTC (rev 509)
@@ -1,2 +1,2 @@
 version=2
-http://grass.itc.it/grass60/source/grass-([\d.]*).tar.gz debian uupdate
+http://grass.itc.it/grass60/source/grass-([\d\.]*).tar.gz debian uupdate


_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to