Francesco P. Lovergine wrote:
> You have programs that still strictly depends on 1.3.2, try what by 
> explicitly installing libgdal1-1.4.0.

> # aptitude -s install libgdal1-1.4.0
> Reading package lists... Done
> Building dependency tree... Done
> Reading extended state information
> Initializing package states... Done
> Building tag database... Done
> The following packages are BROKEN:
>   libgdal1-1.4.0
> The following NEW packages will be automatically installed:
>   libhdf5-serial-1.6.5-0
> The following packages have been kept back:
>   gdal-bin grass qgis qgis-plugin-grass skencil
> The following NEW packages will be installed:
>   libhdf5-serial-1.6.5-0
> 0 packages upgraded, 2 newly installed, 0 to remove and 5 not upgraded.
> Need to get 2022kB/2631kB of archives. After unpacking 8209kB will be used.
> The following packages have unmet dependencies:
>   libgdal1-1.4.0: Conflicts: libgdal1-1.3.2 but 1.3.2-4 is installed.
> Resolving dependencies...
> The following actions will resolve these dependencies:
> 
> Keep the following packages at their current version:
> libgdal1-1.4.0 [Not Installed]
> 
> Score is 1
> 
> Accept this solution? [Y/n/q/?] q
> Abandoning all efforts to resolve these dependencies.
> Abort.
> #

> # apt-get -s install libgdal1-1.4.0
> Reading package lists... Done
> Building dependency tree... Done
> The following extra packages will be installed:
>   gdal-bin grass libgdal1-1.4.0-grass libhdf5-serial-1.6.5-0 libqgis1 qgis 
> qgis-plugin-grass
> The following packages will be REMOVED:
>   cgi-mapserver libgdal1-1.3.2 libgdal1-1.3.2-dev libqgis0 mapserver-bin 
> php4-mapscript php5-mapscript
> The following NEW packages will be installed:
>   libgdal1-1.4.0 libgdal1-1.4.0-grass libhdf5-serial-1.6.5-0 libqgis1
> The following packages will be upgraded:
>   gdal-bin grass qgis qgis-plugin-grass
> 4 upgraded, 4 newly installed, 7 to remove and 1 not upgraded.
> Remv cgi-mapserver [4.10.0-6+b1]
> Inst libhdf5-serial-1.6.5-0 (1.6.5-3 Debian:unstable)
> Inst gdal-bin [1.3.2-4] (1.4.1-4 Debian:unstable) []
> Inst grass [6.2~beta1-1] (6.2.1-3 Debian:unstable) []
> Remv libgdal1-1.3.2-dev [1.3.2-4] []
> Inst qgis-plugin-grass [0.7.9+svn-20060901] (0.8.0-3 Debian:unstable) []
> Inst qgis [0.7.9+svn-20060901] (0.8.0-3 Debian:unstable) []
> Remv libqgis0 [0.7.9+svn-20060901] []
> Remv php5-mapscript [4.10.0-6+b1] []
> Remv php4-mapscript [4.10.0-6+b1] []
> Remv mapserver-bin [4.10.0-6+b1] []
> Remv libgdal1-1.3.2 [1.3.2-4] []
> Inst libgdal1-1.4.0 (1.4.1-4 Debian:unstable) []
> Inst libgdal1-1.4.0-grass (1.4.1-1 Debian:unstable) []
> Inst libqgis1 (0.8.0-3 Debian:unstable)
> Conf libhdf5-serial-1.6.5-0 (1.6.5-3 Debian:unstable)
> Conf libgdal1-1.4.0 (1.4.1-4 Debian:unstable)
> Conf gdal-bin (1.4.1-4 Debian:unstable)
> Conf grass (6.2.1-3 Debian:unstable)
> Conf libqgis1 (0.8.0-3 Debian:unstable)
> Conf qgis (0.8.0-3 Debian:unstable)
> Conf libgdal1-1.4.0-grass (1.4.1-1 Debian:unstable)
> Conf qgis-plugin-grass (0.8.0-3 Debian:unstable)
> #

I am not inclined to do this.

Perhaps the "Conflicts" between 1.3.2 and 1.4.0 could be removed to prevent
this breakage.
-- 
regards
Mark Robinson


_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to