Package: php5-mapscript
Version: 5.0.0-2
Severity: normal
Tags: patch

Hi,

The postinst script contains a small error. 

Here is the error message : 

Setting up php5-mapscript (5.0.0-2) ...
/var/lib/dpkg/info/php5-mapscript.postinst: line 18: [: missing `]'
/var/lib/dpkg/info/php5-mapscript.postinst: line 18: [: missing `]'


The patch is easy. Just a missing space in one of the check of line 18. I've
attached it to the report

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (1, 
'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.22-2-686 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages php5-mapscript depends on:
ii  debconf [debconf-2.0] 1.5.14             Debian configuration management sy
ii  libapache2-mod-php5 [ 5.2.4-1+b1         server-side, HTML-embedded scripti
ii  libc6                 2.6.1-5            GNU C Library: Shared libraries
ii  libcurl3-gnutls       7.17.0-1           Multi-protocol file transfer libra
ii  libfreetype6          2.3.5-1+b1         FreeType 2 font engine, shared lib
ii  libgcc1               1:4.2.2-3          GCC support library
ii  libgd2-xpm            2.0.35.dfsg-3      GD Graphics Library version 2
ii  libgdal1-1.4.0        1.4.2-1            Geospatial Data Abstraction Librar
ii  libgeos-c1            2.2.3-3            Geometry engine for Geographic Inf
ii  libjpeg62             6b-14              The Independent JPEG Group's JPEG 
ii  libkrb53              1.6.dfsg.3~beta1-1 MIT Kerberos runtime libraries
ii  libpng12-0            1.2.15~beta5-3     PNG library - runtime
ii  libpq5                8.2.5-1            PostgreSQL C client library
ii  libstdc++6            4.2.2-3            The GNU Standard C++ Library v3
ii  libx11-6              2:1.0.3-7          X11 client-side library
ii  libxpm4               1:3.5.7-1          X11 pixmap library
ii  php5-cli [phpapi-2006 5.2.4-1+b1         command-line interpreter for the p
ii  proj                  4.5.0-2            Cartographic projection filter and
ii  zlib1g                1:1.2.3.3.dfsg-6   compression library - runtime

php5-mapscript recommends no packages.

-- debconf information:
  php5/extension_mapscript_apache2: true
  php5/extension_mapscript_apache: true
  php5-mapscript/add_extension: true
  php5-mapscript/remove_extension: true
--- /var/lib/dpkg/info/php5-mapscript.postinst  2007-10-17 09:45:29.000000000 
+0200
+++ php5-mapscript.postinst-dp  2007-10-17 09:45:21.000000000 +0200
@@ -15,7 +15,7 @@
 
 for SAPI in apache apache2
 do
-       if [ -f /etc/$phpver/$SAPI/php.ini ] && [ -e 
/etc/$phpver/$SAPI/conf.d]; then
+       if [ -f /etc/$phpver/$SAPI/php.ini ] && [ -e /etc/$phpver/$SAPI/conf.d 
]; then
                db_get $phpver/extension_mapscript_$SAPI
                if [ "$RET" = "true" ] && ! -f 
/etc/$phpver/$SAPI/conf.d/mapscript.ini
                then
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to