Package: gdal
Version: 1.5.0-3
Severity: important
Usertags: perl-5.10-transition

Your package is failing to build with Perl 5.10 (currently in experimental).
This is a known issue with SWIG bindings and C++; see


for a suggested fix.

Excerpt from the build log:

make[4]: Entering directory `/build/niko/gdal-1.5.0/swig/perl'
cp lib/Geo/GDAL/ blib/lib/Geo/GDAL/
cp lib/Geo/GDAL.dox blib/lib/Geo/GDAL.dox
cp lib/Geo/GDAL/Const.dox blib/lib/Geo/GDAL/Const.dox
cp lib/Geo/ blib/lib/Geo/
cp lib/Geo/ blib/lib/Geo/
cp lib/Geo/OSR.dox blib/lib/Geo/OSR.dox
cp lib/Geo/OGR.dox blib/lib/Geo/OGR.dox
cp lib/Geo/ blib/lib/Geo/
cc -c  -I../../gcore -I../../alg -I../../ogr -I../../port -D_REENTRANT 
-D_GNU_SOURCE -DDEBIAN -fno-strict-aliasing -pipe -I/usr/local/include 
-DXS_VERSION=\"0.21\" -fPIC "-I/usr/lib/perl/5.10/CORE"   gdal_wrap.cpp
gdal_wrap.cpp:1232: error: expected unqualified-id before string constant
gdal_wrap.cpp:1233: error: expected initializer before '*' token
gdal_wrap.cpp:1238: error: 'SwigPerlWrapperPtr' does not name a type
gdal_wrap.cpp:15361: error: too many initializers for 'swig_command_info'
gdal_wrap.cpp:15361: error: too many initializers for 'swig_command_info'
gdal_wrap.cpp: In function 'void boot_Geo__GDAL(PerlInterpreter*, CV*)':
gdal_wrap.cpp:15604: error: 'struct swig_command_info' has no member named 
make[4]: *** [gdal_wrap.o] Error 1
make[4]: Leaving directory `/build/niko/gdal-1.5.0/swig/perl'
make[3]: *** [build] Error 2
make[3]: Leaving directory `/build/niko/gdal-1.5.0/swig/perl'
make[2]: *** [build] Error 2
make[2]: Leaving directory `/build/niko/gdal-1.5.0/swig'
make[1]: *** [swig-modules] Error 2
make[1]: Leaving directory `/build/niko/gdal-1.5.0'
make: *** [build-stamp] Error 2


Pkg-grass-devel mailing list

Reply via email to