Package: josm
Version: 0.0.0.20080330-1
Severity: serious

Hi,

Your package has a Depends on: java-gcj-compat | java2-runtime
but those dependencies are not enough.  It complains with:
No valid JVM found to run JOSM.
Please install one of those mentioned in README.Debian
or set the JAVACMD environment variable prior running josm.

And README.Debian says:
Josm should work using one of the following as /usr/bin/java:

    * /usr/bin/gij-4.1
    * /usr/bin/jamvm
    * any of SUN's java (non-free)

But it doesn't even try to use /usr/bin/java.

I have java-gcj-compat installed. java2-runtime is provided by those
packages:
  gij-4.2 4.2.1-5
  gij-4.1 4.1.2-16
  gij 4:4.3-1

Of those, gij-4.1 is the only one I don't have installed.

If it only works with jamvm (which is java1-runtime) and gij-4.1,
then use those as depends instead of something that you're not even
using.


Kurt




_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to