Author: frankie
Date: 2008-06-07 09:06:09 +0000 (Sat, 07 Jun 2008)
New Revision: 1602

Modified:
   packages/postgis/trunk/debian/README.Debian
   packages/postgis/trunk/debian/changelog
   packages/postgis/trunk/debian/control
   packages/postgis/trunk/debian/rules
Log:
Removing postgres 8.2 support.


Modified: packages/postgis/trunk/debian/README.Debian
===================================================================
--- packages/postgis/trunk/debian/README.Debian 2008-06-07 07:31:58 UTC (rev 
1601)
+++ packages/postgis/trunk/debian/README.Debian 2008-06-07 09:06:09 UTC (rev 
1602)
@@ -4,7 +4,7 @@
 These are the PostGIS packages for Debian. PostGIS is split into three
 Debian packages:
 
-postgresql-8.2-postgis
+postgresql-8.3-postgis
   This is the PostGIS module for the PostgreSQL server itself.  It contains
   the library which is loaded by the server (liblwgeom.so.1.1), the SQL script
   for creating the SQL functions in a given database (lwpostgis.sql), and an 
@@ -21,7 +21,7 @@
   so it is recommended that the spatial_ref_sys.sql also be run in each
   database you have PostGIS installed in.
 
-  These scripts can be found in the /usr/share/postgresql-8.2/postgis
+  These scripts can be found in the /usr/share/postgresql-8.3/postgis
   directory.
 
 postgis
@@ -59,8 +59,8 @@
   createlang plpgsql -d <databasename>
 
   # Finally, load the functions and reference system tables
-  psql <databasename> -f /usr/share/postgresql-8.2-postgis/lwpostgis.sql
-  psql <databasename> -f /usr/share/postgresql-8.2-postgis/spatial_ref_sys.sql
+  psql <databasename> -f /usr/share/postgresql-8.3-postgis/lwpostgis.sql
+  psql <databasename> -f /usr/share/postgresql-8.3-postgis/spatial_ref_sys.sql
 
   # login in new database (still as superuser postgres)
   psql <databasename>
@@ -104,8 +104,8 @@
   createlang plpgsql -d template_gis
 
   # Finally, load the functions and reference system tables
-  psql template_gis -f /usr/share/postgresql-8.2-postgis/lwpostgis.sql
-  psql template_gis -f /usr/share/postgresql-8.2-postgis/spatial_ref_sys.sql
+  psql template_gis -f /usr/share/postgresql-8.3-postgis/lwpostgis.sql
+  psql template_gis -f /usr/share/postgresql-8.3-postgis/spatial_ref_sys.sql
 
   # login in new database (still as superuser postgres)
   psql template_gis

Modified: packages/postgis/trunk/debian/changelog
===================================================================
--- packages/postgis/trunk/debian/changelog     2008-06-07 07:31:58 UTC (rev 
1601)
+++ packages/postgis/trunk/debian/changelog     2008-06-07 09:06:09 UTC (rev 
1602)
@@ -1,3 +1,10 @@
+postgis (1.3.3-2) unstable; urgency=low
+
+  * Dropped postgresql 8.2 support due to removal in Lenny.
+    (closes: #474287)
+
+ -- Francesco Paolo Lovergine <[EMAIL PROTECTED]>  Fri, 06 Jun 2008 23:57:45 
+0200
+
 postgis (1.3.3-1) unstable; urgency=low
 
   * New upstream release.

Modified: packages/postgis/trunk/debian/control
===================================================================
--- packages/postgis/trunk/debian/control       2008-06-07 07:31:58 UTC (rev 
1601)
+++ packages/postgis/trunk/debian/control       2008-06-07 09:06:09 UTC (rev 
1602)
@@ -3,23 +3,10 @@
 Priority: optional
 Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
 Uploaders: Stephen Frost <[EMAIL PROTECTED]>, Fabio Tranchitella <[EMAIL 
PROTECTED]>, Francesco Paolo Lovergine <[EMAIL PROTECTED]>
-Build-Depends: debhelper (>= 5.0.0), autotools-dev, flex, bison, 
postgresql-server-dev-8.2, postgresql-server-dev-8.3, libgeos-dev, proj, 
libssl-dev, xsltproc, docbook, docbook-xsl, libpg-java, jikes-classpath, 
fastjar, libjts-java (>=1.7)
+Build-Depends: debhelper (>= 5.0.0), autotools-dev, flex, bison, 
postgresql-server-dev-8.3, libgeos-dev, proj, libssl-dev, xsltproc, docbook, 
docbook-xsl, libpg-java, jikes-classpath, fastjar, libjts-java (>=1.7)
 Standards-Version: 3.7.3
 Homepage: http://postgis.refractions.net/
 
-Package: postgresql-8.2-postgis
-Architecture: any
-Depends: ${shlibs:Depends}, postgis, postgresql-8.2
-Conflicts: postgis (<< 1.2.1)
-Description: geographic objects support for PostgreSQL 8.2
- PostGIS adds support for geographic objects to the PostgreSQL 
object-relational
- database. In effect, PostGIS "spatially enables" the PostgreSQL server, 
- allowing it to be used as a backend spatial database for geographic 
information
- systems (GIS), much like ESRI's SDE or Oracle's Spatial extension. PostGIS
- follows the OpenGIS "Simple Features Specification for SQL".
- .
- This package supports PostgreSQL 8.2.
-
 Package: postgresql-8.3-postgis
 Architecture: any
 Depends: ${shlibs:Depends}, postgis, postgresql-8.3
@@ -34,7 +21,7 @@
  This package supports PostgreSQL 8.3.
 
 Package: postgis
-Suggests: postgresql-8.3-postgis | postgresql-8.2-postgis
+Suggests: postgresql-8.3-postgis
 Depends: ${shlibs:Depends}
 Architecture: any
 Description: geographic objects support for PostgreSQL -- common files
@@ -51,7 +38,7 @@
 Architecture: all
 Section: science
 Depends: libpg-java
-Suggests: postgresql-8.3-postgis | postgresql-8.2-postgis
+Suggests: postgresql-8.3-postgis
 Conflicts: libpostgis-jdbc, libpostgisjava, postgresql-postgis-java
 Replaces: libpostgis-jdbc, libpostgisjava, postgresql-postgis-java
 Description: geographic objects support for PostgreSQL -- JDBC support

Modified: packages/postgis/trunk/debian/rules
===================================================================
--- packages/postgis/trunk/debian/rules 2008-06-07 07:31:58 UTC (rev 1601)
+++ packages/postgis/trunk/debian/rules 2008-06-07 09:06:09 UTC (rev 1602)
@@ -76,25 +76,6 @@
        # Documentation and common files for PostGIS
        [ ! -f doc/html/postgis.html.prev ] && cp doc/html/postgis.html 
doc/html/postgis.html.prev || true
 
-       # PostGIS for PostgreSQL 8.2
-       CFLAGS="$(CFLAGS) -Wl,-z,defs" ./configure \
-               --host=$(DEB_HOST_GNU_TYPE) \
-               --build=$(DEB_BUILD_GNU_TYPE) \
-               --prefix=/usr \
-               --with-docdir=$(CURDIR)/debian/postgis/usr/share/doc \
-               --exec-prefix=\$${prefix}/lib/postgresql/8.2 \
-               --datadir=\$${prefix}/share/postgresql-8.2-postgis \
-               --mandir=\$${prefix}/share/man \
-               --infodir=\$${prefix}/share/info \
-               --with-pgsql=/usr/lib/postgresql/8.2/bin/pg_config \
-               --with-geos \
-               --with-proj
-       $(MAKE)
-       $(MAKE) -C doc
-       $(MAKE) install prefix=$(CURDIR)/debian/postgresql-8.2-postgis/usr
-       rm -r $(CURDIR)/debian/postgresql-8.2-postgis/usr/lib/postgresql/8.2/bin
-       $(MAKE) distclean
-
        # PostGIS for PostgreSQL 8.3
        CFLAGS="$(CFLAGS) -Wl,-z,defs" ./configure \
                --host=$(DEB_HOST_GNU_TYPE) \


_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to