tags 496436 patch confirmed
thanks

Dmitry E. Oboukhov wrote:
> Package: gpsdrive-scripts
> Severity: grave
> 
> Hi, maintainer!
> 
> This message about the error concerns a few packages  at  once.   I've
> tested all the packages (for Lenny) on my Debian mirror.  All  scripts
> of packages (marked as executable) were tested.

The attached (untested) patch should fix this issue.

Cheers,
        Moritz
diff -aur gpsdrive-2.10~pre4.orig/scripts/geo-code gpsdrive-2.10~pre4/scripts/geo-code
--- gpsdrive-2.10~pre4.orig/scripts/geo-code	2007-09-14 23:47:07.000000000 +0200
+++ gpsdrive-2.10~pre4/scripts/geo-code	2008-08-23 22:35:24.000000000 +0200
@@ -248,7 +248,7 @@
 #
 #	Main Program
 #
-TMP=/tmp/geo$$
+TMP=`mktemp`
 STYLE=${TMP}.style
 COORDS=${TMP}.coords
 OUTWAY=${TMP}.way
@@ -269,7 +269,7 @@
 		| head -n1 \
 		`
 	if [ "$URL" = "" ]; then
-		cp $COORDS /tmp/geo.google
+		cp -d $COORDS /tmp/geo.google
 		error "Unable to lookup telephone number or name with Google"
 	else
 		URL="http://maps.yahoo.com/$URL";
@@ -295,7 +295,7 @@
 fi
 
 if [ $DEBUG -gt 0 ]; then
-    filter="tee /tmp/geo.yahoo"
+    filter="tee `mktemp`"
 else
     filter=cat
 fi
Nur in gpsdrive-2.10~pre4/scripts: geo-code~.
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to