I tried doing this simply by backporting the Lenny packages to Etch
(with the needed modifications to build postgresql 8.1 compatible
binaries and such). This fails because the new package removes
/usr/lib/postgresql/8.1/lib/liblwgeom.so.1.1, which makes the existing
database fail entirely.

Is there a known process which allows this to work?

If not, I see two options: 

1. Create new package that can be installed together with the old
postgresql-8.1-postgis (say postgresql-8.1-postgis13)

2. Create a symlink from liblwgeom.so.1.1 to liblwgeom.so.1.3

The gotcha for option 1 is the existing symlinks (liblwgeom.so and
liblwgeom.so.1). If something on the system uses these, there may be
unexpected trouble.

With option 2 the problem is simpler. Is it even supposed to work?

Any help would be appreciated, no need to cc me on replies, I am on
the list.

Arto Jantunen

Pkg-grass-devel mailing list

Reply via email to