Author: frankie
Date: 2009-05-11 18:10:12 +0000 (Mon, 11 May 2009)
New Revision: 2198

Added:
   packages/spatialite/trunk/debian/TODO
Modified:
   packages/spatialite/trunk/debian/changelog
   packages/spatialite/trunk/debian/copyright
   packages/spatialite/trunk/debian/rules
Log:
Some more fixes.


Added: packages/spatialite/trunk/debian/TODO
===================================================================
--- packages/spatialite/trunk/debian/TODO                               (rev 0)
+++ packages/spatialite/trunk/debian/TODO       2009-05-11 18:10:12 UTC (rev 
2198)
@@ -0,0 +1,2 @@
+Upstream asked to merge suitable patches in the unamalgameted sources in order 
to work
+in Debian way (unembedded libraries and so on). This is must.

Modified: packages/spatialite/trunk/debian/changelog
===================================================================
--- packages/spatialite/trunk/debian/changelog  2009-05-10 21:41:08 UTC (rev 
2197)
+++ packages/spatialite/trunk/debian/changelog  2009-05-11 18:10:12 UTC (rev 
2198)
@@ -1,9 +1,9 @@
 spatialite (2.3.0-1) unstable; urgency=low
 
-  * NOT RELEASED.
-  * New upstream release.
+  * New upstream release with partial repackaing to cope with upstream changes.
   * New upstream packaging: now this package includes all spatialite-related 
-    tarballs to provide the whole set of binary packages.
+    tarballs to provide the whole set of binary packages, based on the 
+    amalgameted sources.
   * Added quilt support. Now the upstream tarball is included as a compressed 
archive
     to facilitate interactive cleanaups and patching.
   * [PATCH] split.diff removes embedded sqlite3 and uses system library.
@@ -14,12 +14,14 @@
   * Removed init SQL file, initialization is now embedded in the library.
   * Removed README installation: it documents purely installation.
   * Currently still does not build spatialite-gui.
+  * Now the library is distributed under MPL 1.1, tools under GPL-3: changed
+    debian/copyright to explain that.
+    (closes: #519251)
 
  -- Francesco Paolo Lovergine <fran...@debian.org>  Tue, 31 Mar 2009 09:53:03 
+0200
 
-spatialite (2.3~beta1-1) unstable; urgency=low
+spatialite (2.3~beta1-1) UNRELEASED; urgency=low
 
   * Initial release.
-    (closes: #519251)
 
  -- Francesco Paolo Lovergine <fran...@debian.org>  Fri, 13 Mar 2009 16:01:40 
+0100

Modified: packages/spatialite/trunk/debian/copyright
===================================================================
--- packages/spatialite/trunk/debian/copyright  2009-05-10 21:41:08 UTC (rev 
2197)
+++ packages/spatialite/trunk/debian/copyright  2009-05-11 18:10:12 UTC (rev 
2198)
@@ -11,19 +11,21 @@
 
 Copyright:
 
-    Copyright (C) 2008 Alessandro Furieri
+    Copyright (C) 2008-2009 Alessandro Furieri
 
 License:
 
-    This software is distributed under one of three different license at user
-    option:
+    This software is distributed under those licenses:
 
         * Mozilla Public License, version 1.1 or later
-       * GNU General Public License, version 2.0 or later
-       * GNU Lesser General Public License, version 2.1 or later
+       * GNU General Public License, version 3.0 
 
+    Specifically the library is distributed under MPL 1.1, while
+    additional tools and GUI are distributed under GPL-3.
+
     The text of those licenses on Debian system is included as
-    `/usr/share/common-licenses/{GPL-2,LGPL-2}'. 
+    `/usr/share/common-licenses/GPL-3'. 
+
     The text of the MPL 1.1 follows:
 
                           MOZILLA PUBLIC LICENSE

Modified: packages/spatialite/trunk/debian/rules
===================================================================
--- packages/spatialite/trunk/debian/rules      2009-05-10 21:41:08 UTC (rev 
2197)
+++ packages/spatialite/trunk/debian/rules      2009-05-11 18:10:12 UTC (rev 
2198)
@@ -99,7 +99,7 @@
 #      dh_installdirs -i
 #      dh_install -i
 
-install-arch:
+install-arch: build-arch
        dh_testdir
        dh_testroot
        dh_prep -a 
@@ -136,7 +136,7 @@
 # Build architecture independant packages using the common target.
 # Currently there are no packages to build.
 binary-indep: build-indep install-indep
-#      $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
+       $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
 
 # Build architecture dependant packages using the common target.
 binary-arch: build-arch install-arch


_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to