Package: josm
Version: 0.0.svn1529-1
Severity: important

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi,

I am trying to start josm, and I get:

$ josm
Using /usr/lib/jvm/java-6-openjdk/bin/java to execute josm.
Exception in thread "main" java.lang.UnsatisfiedLinkError: Can't load library: 
/usr/lib/jvm/java-6-openjdk/jre/lib/amd64/motif21/libmawt.so
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1666)
        at java.lang.Runtime.load0(Runtime.java:787)
        at java.lang.System.load(System.java:1022)
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1767)
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1684)
        at java.lang.Runtime.loadLibrary0(Runtime.java:840)
        at java.lang.System.loadLibrary(System.java:1047)
        at sun.security.action.LoadLibraryAction.run(LoadLibraryAction.java:67)
        at sun.security.action.LoadLibraryAction.run(LoadLibraryAction.java:47)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.awt.Toolkit.loadLibraries(Toolkit.java:1614)
        at java.awt.Toolkit.<clinit>(Toolkit.java:1636)
        at java.awt.Component.<clinit>(Component.java:568)
        at org.openstreetmap.josm.Main.<clinit>(Main.java:233)
Could not find the main class: JOSM. Program will exit.

There are libmawt.so files around, but not in a path containing motif:

$ dpkg -S libmawt.so
openjdk-6-jre: /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/xawt/libmawt.so
openjdk-6-jre-headless: 
/usr/lib/jvm/java-6-openjdk/jre/lib/amd64/headless/libmawt.so

According to
http://packages.debian.org/search?mode=path&suite=sid&section=all&arch=any&searchon=contents&keywords=libmawt.so
only the sun-java?-bin packages provide a motif21/libmawt.do.

Greetings,
Joachim

- -- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.30-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages josm depends on:
ii  libgettext-commons-ja 0.9-1              Java classes for internationalizat
ii  libmetadata-extractor 2.3.1+dfsg-1       JPEG metadata extraction framework
ii  openjdk-6-jre         6b16-4             OpenJDK Java runtime, using Hotspo
ii  openstreetmap-map-ico 1:0.0.0.20080713-1 Collection of map icons

Versions of packages josm recommends:
ii  josm-plugins            0.0.0.20080413-2 Plugins for JOSM

josm suggests no packages.

- -- no debconf information

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkqB5H8ACgkQ9ijrk0dDIGyD4wCgiD9W9MTROJLDLbz8m9ZzPl+7
y30Anj7WHBuPGLpjPFayt5YjL/cMUnCM
=2cOd
-----END PGP SIGNATURE-----



_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to