Francesco P. Lovergine a écrit :
On Fri, Oct 09, 2009 at 10:55:35AM +0200, Guy Roussin wrote:
Package: grass
Version: 6.4.0~rc5-3
Severity: normal

Hi,

I run grass in gui mode. I select an empty "GIS data Directory"
(i create it before). And i click on <Projection values> button
and i get this error :

=================================================================
If you wish to resize the X monitor, do so now. Window size is
locked while interactive modules are running.
=================================================================

/usr/lib/grass64/etc/set_data: error while loading shared libraries: 
libgrass_edit.so: cannot open shared object file: No such file or directory

Would you please check what's your ld.so.conf (and subdirs) contents?
At least with current grass in sid it works perfectly.
Yes grass works fine in sid.

In my student config (debian lenny) the file /etc/ld.so.conf.d/grass.conf
is missing. Now i add it, reboot and all is fine with grass.
I don't know why this file is missing ...

echo "/usr/lib/grass64/lib" > /etc/ld.so.conf.d/grass.conf
and reboot

Thank you Francesco,


That's wrong. You don't need /usr/lib/grass64/lib to run grass. If you need that
that's something definitively wrong with your setup. This is at least as strange
as the X monitor warning at startup. This is not an official backports for 
lenny,
isn't it?


Yes, there is something wrong with my setup. I notice that now, with /etc/ld.so.conf.d/grass.conf, sometimes it run fines, sometimes
there is a segmentation fault :
=================================================================
If you wish to resize the X monitor, do so now. Window size is
locked while interactive modules are running.
=================================================================

/usr/lib/grass64/etc/set_data
/usr/lib/grass64/etc/grass-run.sh: line 30: 4464 Erreur de segmentation "$@"

ERROR: /usr/lib/grass64/etc/set_data exited abnormally. Press <enter> to continue.



# apt-cache policy grass
grass:
 Installé : 6.4.0~rc4-3
 Candidat : 6.4.0~rc4-3
Table de version :
*** 6.4.0~rc4-3 0
       501 http://debian.gfoss.it lenny/main Packages
       100 /var/lib/dpkg/status
    6.3.0.1~gfossit20090217-1 0
       501 http://debian.gfoss.it lenny/main Packages
    6.2.3-2.1 0
       500 http://ftp.fr.debian.org lenny/main Packages

I use gfoss.it because i need qgis (1.3.0) with grass plugin from gfoss.it
and there is no official backports for lenny.

Note that I compile grass on lenny from sid source and i get the same
problem.

I think you can close the bug because it is not related to debian official.

Thank again,

Guy



_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to