Package: josm
Version: 0.0.svn2255-1
Severity: normal

JOSM started complaining about not being able to access the API server
some time ago.  I initially suspected a temporary brokenness on that
server, but since it persisted I eventually tried to debug it with
Wireshark.  I found out that even though the DNS queries were sent and
got answered, JOSM didn't attempt to open a socket to the server.  What
attracted my attention was that the A query did get answers, but the
answer section for the AAAA query is empty (apparently the API servers
are not available over IPv6).  Then I remembered about a recent thread
in debian-devel about changing a default value for an IPv6-related
kernel parameter, and tried that out: 
,----
| echo 0 > /proc/sys/net/ipv6/bindv6only
`----
(The previous value was 1).  This change “fixed” JOSM, and I can now
connect to the API servers again.

  I seem to remember the conclusion of the thread was that applications
that are broken by the new default value should be signalled and fixed,
so here's my report for JOSM :-)

  Thanks,

Roland.

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-trunk-686 (SMP w/1 CPU core)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages josm depends on:
ii  libgettext-commons-java 0.9.6-1          Java classes for internationalizat
ii  libmetadata-extractor-j 2.3.1+dfsg-1     JPEG metadata extraction framework
ii  openjdk-6-jre           6b17~pre3-1      OpenJDK Java runtime, using Hotspo
ii  openstreetmap-map-icons 1:0.0.svn18468-1 Collection of map icons (classic s

Versions of packages josm recommends:
ii  josm-plugins              0.0.svn18009-1 Plugins for JOSM

josm suggests no packages.

-- no debconf information

-- 
Roland Mas

'And what would humans be without love?'
RARE, said Death.  -- in Sourcery (Terry Pratchett)



_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to