Hi Alexandre,

Alexandre Fayolle ha scritto:
> I tried Timo Lindfors' fix, and here's what I get:
> 
> 
> a...@lacapelle:~$ su
> Mot de passe : 
> lacapelle:/home/alf# echo 0 >  /proc/sys/net/ipv6/bindv6only
> lacapelle:/home/alf# exit
> a...@lacapelle:~$ josm
> Using /usr/lib/jvm/java-6-sun/bin/java to execute josm.
> Revision: Manifest-Version: 1.0
> Ant-Version: Apache Ant 1.7.1
> Created-By: 14.0-b16 (Sun Microsystems Inc.)
> Main-class: JOSM
> Main-Version: 2255 SVN
> Main-Date: 2009-10-07T19:25:15.114514Z
> Debian-Release: 0.0.svn2255-1
> Class-Path: /usr/share/java/gettext-commons.jar /usr/share/java/metadata-
> extractor.jar
> Fatal: failed to locate image 'styles/standard/shop/rental/library.png'. This 
> is a serious configuration problem. JOSM will stop working.
> Could not get presets icon styles/standard/shop/rental/library.png

Did the JOSM splash screen show up? The program just died, or you killed
it? Have you tried deleting (or moving elsewhere) the ~/.josm dir?

> So there seems to be another issue (as the MOTD reading was not the fatal 
> error preventing the start). 
> 
> I've searched my disk for  rental/library.png and found 
> /usr/share/icons/openstreetmap/classic.small/shop/rental/library.png  
> provided 
> by package openstreetmap-map-icons-classic which is a dependency of josm. 
> I've 
> checked the version of that package in debian stable and the file layout 
> seems 
> similar enough (at least the path to rental/library.png is the same). 

The error marked as fatal is really not fatal: I get it every time, but
JOSM works nice for me.

Anyway, also the ipv6 issue is not fatal here, because I can start josm
even with the bindv6only option set (even if then it cannot connect with
the API).

Giovanni.
-- 
Giovanni Mascellani <mascell...@poisson.phc.unipi.it>
Pisa, Italy

Web: http://poisson.phc.unipi.it/~mascellani
Jabber: g.mascell...@jabber.org / giova...@elabor.homelinux.org

Attachment: signature.asc
Description: OpenPGP digital signature

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to