Dear David,

First of all thanks for contacting me.

As you can guess I have absolutly no issue to avoid propagating such
delta, that is clearly useless and is a result of a mistake I did..
I would rather avoid another upload to fix it, and thus I think it
would be better to simply override it in the next upload, that might
be the 0.7.1 if it is accepted before the Ubuntu release. Otherwise I
will personnaly take care of merging with the debian version in lucid
+1

Regarding sending patches upstream (which means debian as you stated)
it is clearly my way of doing stuffs, since the 0.7.0 inclusion in
debian was, I think (and I can clearly be wrong), a bit provocated by
a discussion I have raised on  the pkg-grass-devel mailing list a few
weeks ago.
       Christophe

PS: just for the record I am also subscribed to the debian team since
I'd like to participate a bit more on the debian side to improve the
general state of GIS packages.


---
Christophe Sauthier   -  06 16 98 63 96
Objectif Libre  www.objectif-libre.com
Services et Formations Open Source



On Sat, Mar 20, 2010 at 4:17 PM, David Paleino <da...@debian.org> wrote:
> Hello,
> I'm the maintainer of mapnik in Debian (team CCed, please keep it in the
> loop).
> I saw you did an upload of mapnik with the following changelog:
>
> mapnik (0.7.0-2ubuntu1) lucid; urgency=low
>
>  * Merge from debian testing (LP: #526070), remaining changes:
>    - Bump boost build-dep and libmapnik-dev depends to boost1.40
>  -- Christophe Sauthier <christophe.sauth...@objectif-libre.com>   Thu, 18 Mar
> 2010 01:07:40 +0100
>
> I'd like to discuss this change to you, as it seems an useless delta from
> Debian, which will interfere with automatic syncing.
>
> This is what you changed:
>
> - libboost-thread-dev          >  libboost-thread1.40-dev
> - libboost-filesystem-dev      >  libboost-filesystem1.40-dev
> - libboost-regex-dev           >  libboost-regex1.40-dev
> - libboost-python-dev          >  libboost-python1.40-dev
> - libboost-system-dev          >  libboost-system1.40-dev
> - libboost-iostreams-dev       >  libboost-iostreams1.40-dev
> - libboost-program-options-dev >  libboost-program-options1.40-dev
>
> At the current time of writing, those packages already depend on 1.40
> versions, both in Debian and Ubuntu. I used the unversioned dependencies to
> make it easier to handle Boost transitions, just doing binNMUs instead of
> sourceful uploads.
>
> I think that the only reason to hardcode those dependencies is to correctly
> build this package under Karmic.
> As I understand it, though, this is a marginal problem, as Karmic users
> already have mapnik (0.6) in their repositories, and it requires boost 1.38
> (which is the default version there, too). And, if they want to build Lucid
> packages into Karmic, they should be on their own.
>
> What's your rationale for this change?
>
> If possible, I'd like it to be reverted with the next upload in Ubuntu (and
> maybe patches forwarded to your upstream, i.e. Debian, if any -- but maybe
> this is asking too much), or ignored in the next sync from Debian.
>
> Thank you for collaborating,
> David
>
> --
>  . ''`.   Debian developer | http://wiki.debian.org/DavidPaleino
>  : :'  : Linuxer #334216 --|-- http://www.hanskalabs.net/
>  `. `'`  GPG: 1392B174 ----|----
>   `-   2BAB C625 4E66 E7B8 450A C3E1 E6AA 9017 1392 B174
>

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to