Your message dated Tue, 18 May 2010 09:47:32 +0000
with message-id <e1oejoe-0006li...@ries.debian.org>
and subject line Bug#579989: fixed in gdal 1.6.3-4
has caused the Debian Bug report #579989,
regarding Tries to dlopen libproj.so instead of libproj.so.0
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
579989: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=579989
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: libgdal1-1.6.0
Version: 1.6.3-3+b2
Severity: normal
Tags: patch

I'm getting the following error:

ERROR 6: Unable to load PROJ.4 library (libproj.so), creation of
OGRCoordinateTransformation failed.

This is because GDAL tries to dlopen libproj.so, but it should dlopen
libproj.so.0. I tested the attached patch and that fixes the error.

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-3-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libgdal1-1.6.0 depends on:
ii  libc6                   2.10.2-6         Embedded GNU C Library: Shared lib
ii  libcurl3-gnutls         7.20.0-3+b1      Multi-protocol file transfer libra
ii  libexpat1               2.0.1-7          XML parsing C library - runtime li
ii  libgcc1                 1:4.4.2-9        GCC support library
ii  libgeos-c1              3.2.0-1          Geometry engine for Geographic Inf
ii  libgif4                 4.1.6-9          library for GIF images (library)
ii  libhdf4-0-alt           4.2r4-10         The Hierarchical Data Format libra
ii  libhdf5-serial-1.8.4 [l 1.8.4-patch1-1   Hierarchical Data Format 5 (HDF5) 
ii  libjasper1              1.900.1-7        The JasPer JPEG-2000 runtime libra
ii  libjpeg62               6b-16.1          The Independent JPEG Group's JPEG 
ii  libmysqlclient16        5.1.45-1         MySQL database client library
ii  libnetcdf4              1:3.6.3-1        An interface for scientific data a
ii  libogdi3.2              3.2.0~beta2-6    Open Geographic Datastore Interfac
ii  libpng12-0              1.2.43-1         PNG library - runtime
ii  libpq5                  8.4.3-1          PostgreSQL C client library
ii  libsqlite3-0            3.6.23.1-1       SQLite 3 shared library
ii  libstdc++6              4.4.2-9          The GNU Standard C++ Library v3
ii  libxerces-c28           2.8.0+deb1-2     validating XML parser library for 
ii  odbcinst1debian2        2.2.14p2-1       Support library for accessing odbc
ii  unixodbc                2.2.14p2-1       ODBC tools libraries
ii  zlib1g                  1:1.2.3.4.dfsg-3 compression library - runtime

Versions of packages libgdal1-1.6.0 recommends:
pn  proj-bin                      <none>     (no description available)

libgdal1-1.6.0 suggests no packages.

-- no debconf information
#! /bin/sh /usr/share/dpatch/dpatch-run
## libproj.dpatch by  <jer...@dekkers.ch>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Dlopen libproj.so.0 instead of libproj.so

@DPATCH@
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' gdal-1.6.3~/ogr/ogrct.cpp gdal-1.6.3/ogr/ogrct.cpp
--- gdal-1.6.3~/ogr/ogrct.cpp	2008-09-16 10:32:39.000000000 +0200
+++ gdal-1.6.3/ogr/ogrct.cpp	2010-05-02 21:24:39.087609517 +0200
@@ -80,7 +80,7 @@
 #elif defined(__APPLE__)
 #  define LIBNAME      "libproj.dylib"
 #else
-#  define LIBNAME      "libproj.so"
+#  define LIBNAME      "libproj.so.0"
 #endif
 
 /************************************************************************/

--- End Message ---
--- Begin Message ---
Source: gdal
Source-Version: 1.6.3-4

We believe that the bug you reported is fixed in the latest version of
gdal, which is due to be installed in the Debian FTP archive:

gdal-bin_1.6.3-4_i386.deb
  to main/g/gdal/gdal-bin_1.6.3-4_i386.deb
gdal_1.6.3-4.diff.gz
  to main/g/gdal/gdal_1.6.3-4.diff.gz
gdal_1.6.3-4.dsc
  to main/g/gdal/gdal_1.6.3-4.dsc
libgdal-doc_1.6.3-4_all.deb
  to main/g/gdal/libgdal-doc_1.6.3-4_all.deb
libgdal-perl_1.6.3-4_i386.deb
  to main/g/gdal/libgdal-perl_1.6.3-4_i386.deb
libgdal-ruby1.8_1.6.3-4_i386.deb
  to main/g/gdal/libgdal-ruby1.8_1.6.3-4_i386.deb
libgdal-ruby_1.6.3-4_i386.deb
  to main/g/gdal/libgdal-ruby_1.6.3-4_i386.deb
libgdal1-1.6.0_1.6.3-4_i386.deb
  to main/g/gdal/libgdal1-1.6.0_1.6.3-4_i386.deb
libgdal1-dev_1.6.3-4_i386.deb
  to main/g/gdal/libgdal1-dev_1.6.3-4_i386.deb
python-gdal_1.6.3-4_i386.deb
  to main/g/gdal/python-gdal_1.6.3-4_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 579...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Francesco Paolo Lovergine <fran...@debian.org> (supplier of updated gdal 
package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Tue, 18 May 2010 09:34:59 +0200
Source: gdal
Binary: libgdal1-1.6.0 libgdal1-dev libgdal-doc gdal-bin python-gdal 
libgdal-perl libgdal-ruby1.8 libgdal-ruby
Architecture: source i386 all
Version: 1.6.3-4
Distribution: unstable
Urgency: high
Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
Changed-By: Francesco Paolo Lovergine <fran...@debian.org>
Description: 
 gdal-bin   - Geospatial Data Abstraction Library - Utility programs
 libgdal-doc - Documentation for the Geospatial Data Abstraction Library
 libgdal-perl - Perl bindings to the Geospatial Data Abstraction Library
 libgdal-ruby - Ruby bindings to the Geospatial Data Abstraction Library
 libgdal-ruby1.8 - Ruby 1.8 bindings to the Geospatial Data Abstraction Library
 libgdal1-1.6.0 - Geospatial Data Abstraction Library
 libgdal1-dev - Geospatial Data Abstraction Library - Development files
 python-gdal - Python bindings to the Geospatial Data Abstraction Library
Closes: 579989
Changes: 
 gdal (1.6.3-4) unstable; urgency=high
 .
   * Backported from 1.7.2: enable static linking for proj at configuration 
time.
     This problems prevented programs such as gdal_warp to work properly
     without the -dev package installed.
     (closes: #579989)
   * Policy bumped to 3.8.4, no changes.
Checksums-Sha1: 
 7b91f90ba74ce56212bf9624e6c028e1cc05a136 1775 gdal_1.6.3-4.dsc
 e473c10fd1a86b135090edb390b4d36635188419 87781 gdal_1.6.3-4.diff.gz
 8bc621efe1ed920a2c057ebbb8e87b9df0675692 2919440 
libgdal1-1.6.0_1.6.3-4_i386.deb
 c608f61a4514a19e933cb7588594016a1dd7d852 3618604 libgdal1-dev_1.6.3-4_i386.deb
 b1ea5f0541abadf912239200791ef3546f535e67 193474 gdal-bin_1.6.3-4_i386.deb
 914411b46e3c870e3fd04937896ea6ae25f95d4e 524440 python-gdal_1.6.3-4_i386.deb
 2a78c1f3dc0ff33acc9215877836e632b7377998 359202 libgdal-perl_1.6.3-4_i386.deb
 c3de298095f5ef8e944a87a01b9d129eaffb02b3 185078 
libgdal-ruby1.8_1.6.3-4_i386.deb
 521635988803455e7d1b8a9a325b1316dd99e8f1 52624 libgdal-ruby_1.6.3-4_i386.deb
 fc94070faec48ae076c272e138981dd4da11cb41 1813646 libgdal-doc_1.6.3-4_all.deb
Checksums-Sha256: 
 d08b27e76c620fb274bd1422a9243dec6f2fda23aa1604824fa460c72b54d18b 1775 
gdal_1.6.3-4.dsc
 82344c105d47cb7dea561312c46567d0b1813262d3e7b5dba79da1e4e32fbb44 87781 
gdal_1.6.3-4.diff.gz
 17faf8c5b185865daf4315e272d82c9e3d5ad38a33f2395b75778c760119fc9a 2919440 
libgdal1-1.6.0_1.6.3-4_i386.deb
 2e97acd684be15e43d01d58184140b5c6d8ed40439f2ee5f4081893ba88398a9 3618604 
libgdal1-dev_1.6.3-4_i386.deb
 12a9685b9c85040b12da84eaa4dfab7aece9d99261879ed79abcc964b4bc0f55 193474 
gdal-bin_1.6.3-4_i386.deb
 b1ccb02a9b0d45ddb9a42f5ea5aca88ffaaaee30a8ffd1b68b408109c68be614 524440 
python-gdal_1.6.3-4_i386.deb
 0e7783ac669eff647b01a7a0962ed14771067da086656617c968b40f61bb6fc0 359202 
libgdal-perl_1.6.3-4_i386.deb
 41cd9e5639ed3f605a88b094ddd6f65aa3f4b5168fdbe14ee3fe83ce38442f36 185078 
libgdal-ruby1.8_1.6.3-4_i386.deb
 0ccb9ab198fda948b7f2fe3c64eea77efd146ebf7742df968fa6583616519321 52624 
libgdal-ruby_1.6.3-4_i386.deb
 791b30f6c79d30ebde2e593633cc214a538a0cd056f78700cf3b5ec1e33a4a8c 1813646 
libgdal-doc_1.6.3-4_all.deb
Files: 
 b26d1480a641d5fc29643a0ae2137205 1775 science extra gdal_1.6.3-4.dsc
 c7b4189bf3d005aa796154d4c532b2fe 87781 science extra gdal_1.6.3-4.diff.gz
 3c74cb5aaa5292b9b25b0f3c1f96af96 2919440 libs extra 
libgdal1-1.6.0_1.6.3-4_i386.deb
 55377c549e400493b8bae26c4aacce44 3618604 libdevel extra 
libgdal1-dev_1.6.3-4_i386.deb
 36ab41c7f64841c1f20cdfa807d00302 193474 science extra gdal-bin_1.6.3-4_i386.deb
 a1558c8d571ae7cfadda95ecd10b5490 524440 python extra 
python-gdal_1.6.3-4_i386.deb
 8cc516ddfe71ac2000c37a3fbf54f25f 359202 perl extra 
libgdal-perl_1.6.3-4_i386.deb
 95ad421e4cdef30156deb6099262e095 185078 ruby extra 
libgdal-ruby1.8_1.6.3-4_i386.deb
 cb8d403b6ecaf51bae10f4ace558dcad 52624 ruby extra libgdal-ruby_1.6.3-4_i386.deb
 8d3b6c07d85e38a0d1e7573bf8eca0df 1813646 doc extra libgdal-doc_1.6.3-4_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkvyYDoACgkQpFNRmenyx0cc6gCfZWirvK2xI0PIJmKg/r3dNhLv
BdEAn3xIQ/yVTBV84WQgG5iFpCGO8dCB
=i/Yj
-----END PGP SIGNATURE-----



--- End Message ---
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to