Stephen,

I took a quick look and there is effectively an error in the rules_lenny file. The sed commands executed are simply deprecated. Check the rules file from the svn: http://svn.debian.org/wsvn/pkg-grass/packages/postgis/trunk/debian/rules . In the "# Create custom main scripts" section, replace the sed commands in the rules_lenny file by those from the rules file. I'm going to take care to apply those changes in svn this week.


Thanks,
Alan

Stephen Woodbridge wrote:
Alan,

One step forward 2 steps back :)

wood...@mappy:/u/local/src$ sudo apt-get -t lenny-backports install libpq5 libpq-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  postgresql-doc-8.4
The following packages will be upgraded:
  libpq-dev libpq5
2 upgraded, 0 newly installed, 0 to remove and 91 not upgraded.
Need to get 363kB of archives.
After this operation, 578kB disk space will be freed.
Get:1 http://www.backports.org lenny-backports/main libpq-dev 8.4.3-1~bpo50+1 [228kB] Get:2 http://www.backports.org lenny-backports/main libpq5 8.4.3-1~bpo50+1 [134kB]
Fetched 363kB in 1s (201kB/s)
(Reading database ... 75002 files and directories currently installed.)
Preparing to replace libpq-dev 8.3.9-0lenny1 (using .../libpq-dev_8.4.3-1~bpo50+1_amd64.deb) ...
Unpacking replacement libpq-dev ...
Preparing to replace libpq5 8.3.9-0lenny1 (using .../libpq5_8.4.3-1~bpo50+1_amd64.deb) ...
Unpacking replacement libpq5 ...
Processing triggers for man-db ...
Setting up libpq5 (8.4.3-1~bpo50+1) ...
Setting up libpq-dev (8.4.3-1~bpo50+1) ...

So this part ran ok, and it allowed me to do:

wood...@mappy:/u/local/src$ sudo dpkg -i postgis_1.5.1-1_amd64.deb
Selecting previously deselected package postgis.
(Reading database ... 74995 files and directories currently installed.)
Unpacking postgis (from postgis_1.5.1-1_amd64.deb) ...
Setting up postgis (1.5.1-1) ...
Processing triggers for man-db ...

But this step bombs:

wood...@mappy:/u/local/src$ sudo dpkg -i postgresql-8.3-postgis_1.5.1-1_amd64.deb
Selecting previously deselected package postgresql-8.3-postgis.
(Reading database ... 75006 files and directories currently installed.)
Unpacking postgresql-8.3-postgis (from postgresql-8.3-postgis_1.5.1-1_amd64.deb) ...
Setting up postgresql-8.3-postgis (1.5.1-1) ...
Postgis extension not found, something wrong did probably happen

Which comes from:

wood...@mappy:/u/local/src/$ cat debian/postgresql-8.3-postgis.postinst
#!/bin/sh

set -e

# Creates a link for the shared lib in the postgres area
if [ "$1" = "configure" ]; then
if [ -f /usr/lib/postgis/1.5.1/postgres/8.3/lib/postgis-1.4.so ]; then ln -f /usr/lib/postgis/1.5.1/postgres/8.3/lib/postgis-1.4.so \
                      /usr/lib/postgresql/8.3/lib/postgis-1.4.so
        else
echo "Postgis extension not found, something wrong did probably happen"
        fi
fi

#DEBHELPER#

exit 0

But we installed:

wood...@mappy:/u/local/src/postgis-1.5.1$ ls /usr/lib/postgis/1.5.1/postgres/8.3/lib/
postgis-1.5.so

So, I'm looking for where @SOVERSION@ is getting defined, which appears to be in rules_lenny (which is what I'm using). Using the svn rules it builds postgis-1.5.so but still fails on the above script.

It looks like I can probably do the link by hand, then try to upgrade the databases, but I have to run out the door for the weekend, so I'll tackle this on monday some more.

Thank you all for you help and suggestions.

-Steve

Alan Boudreault wrote:
Hi Stephen,

Just a quick thing you could try: "apt-get install -f" , this should install the missing dependency and continue the postgis package installation normally. Be sure you have lenny-backports in you sources.list because the libpq5 version 8.4 is there. Note that dpkg will never download and install missing dependencies, it's not its job. It's the apt-get job. That's why you have to call apt-get to fix things and continue what dpkg started before. You can also take a look at the "gdebi" utility. It's a tool to install a .deb file and it *should* (never used it much) call apt-get itself to solve missing dependencies.

see also my comments below....

Stephen Woodbridge wrote:
Hi all,

I have just found pbuilder and I'm using it with the pkg-grass debian package definitions for geos-3.2.0 and postgis-1.5.1 building packages for lenny. This is all very cool and makes things soo much easier. I am also using some packages backports.org.

So, I have gotten things setup and have been able to build packages, but postgis and postgresql-8.3-postgis will not install giving the following error:

wood...@mappy:/u/local/src$ sudo dpkg -i postgis_1.5.1-1_amd64.deb
[sudo] password for woodbri:
(Reading database ... 75044 files and directories currently installed.)
Preparing to replace postgis 1.5.1-1 (using postgis_1.5.1-1_amd64.deb) ...
Unpacking replacement postgis ...
dpkg: dependency problems prevent configuration of postgis:
 postgis depends on libpq5 (>= 8.4~0cvs20090328); however:
  Version of libpq5 on system is 8.3.9-0lenny1.
dpkg: error processing postgis (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db ...
Errors were encountered while processing:
 postgis

I have attached the postgis_1.5.1-1_amd64.build.gz from the pdebuild.

I think this might be because the control_lenny file has BOTH
   postgresql-server-dev-8.3, postgresql-server-dev-8.4
as Build-Depends for postgis.


That is ok, the package is made to build the postgis extension for both versions.

Would this not then require BOTH

libpq5 8.4~0cvs20090328 from postgresql-8.4
libpq5 8.3.9-0lenny1    from postgresql-8.3

to be part of the dependencies, probably with the later one winning or whatever?


No. libpq5 is the library that allows user programs to communicate with a postgresql server. The version of libpq5 >=8.4 is compatible to communicate with servers from PostgreSQL 8.2 or later. So it's all right that the postgis package has libpq5 >=8.4.x as dependency.

Any ideas how to fix this? Does the control file need to be split into two files one for postgresql-8.3 and one for postgresql-8.4? would the rules file need to changes also or instead of the control file?


As I said, the control and rule files are ok and build the extension for postgresql 8.3 and 8.4.

I've put a lot of time and effort into trying to resolve this, but I just don't know that much about building debian packages. Reall need to guidance and help on this one.

Best regards,
  -Steve
------------------------------------------------------------------------

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Hope this help,

regards,
Alan




--
Alan Boudreault
Mapgears
http://www.mapgears.com/

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to