On Wed, Jun 30, 2010 at 08:28:09AM +0800, YunQiang Su wrote:
> Is the 1.3.0 version of libgeotiff working?
> 
> On Wed, Jun 30, 2010 at 1:24 AM, Francesco P. Lovergine
> <fran...@debian.org> wrote:
> > On Mon, Jun 28, 2010 at 10:33:09AM +0800, YunQiang Su wrote:
> >> Opticks is an expandable remote sensing and imagery analysis software
> >> platform that is free and open source.
> >>
> >> Is somebody here working on packaging it in Debian?
> >>
> >
> > Still not.
> >
> >> If there is no,I will try to do this job.
> >
> > Note that there's at least some criticities for linking current
> > libgeotiff. The other dependency on ossim is currently available.
> > I'm available for sponsoring and cooperating.
> >

The problem is http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=558733
AFAIK it does not depend on version. A definitive solution could be
adopting versioned symbols in gdal, which would render the library
not binary-compatible with third parties binaries. A work around
is fixing linking order in Opticks (i.e. linking geotiff *before* gdal).
Anyway some specific tests should be conducted about that.
That said, at least the first solution should go in squeeze+1.

-- 
Francesco P. Lovergine

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to