Package: gpsdrive
Version: 2.10~pre4-6.dfsg-5+b2
Severity: important

gpsd is correctly running with a navilock NL-402u. Although gpsdrive 
gives a "gps status" of "no gps". I tested gpsd with "tangogps" which 
works correctly, connecting to gpsd and gives out the correct position. 
Also "xgps" does show me the position of the satelites. "gpscat 
/dev/ttyACM0" also produces a constant data stream. So far I am sure the 
driver and device is working correctly. Only gpsdrive does not connect 
to the gpsd. Trying manually to allow with the option '-t' to connect to 
a device directly seems also not to work. I guess the problem could be 
in gpsdrive itself, but more is beyond my skills. strace gives finally a 
repeating message of:

gettimeofday({1280321706, 774830}, NULL) = 0
read(3, 0x8dd8dd0, 4096)                = -1 EAGAIN (Resource temporarily 
gettimeofday({1280321706, 775175}, NULL) = 0
poll([{fd=4, events=POLLIN}, {fd=3, events=POLLIN}, {fd=8, events=POLLIN}], 3, 
24) = 1 ([{fd=3, revents=POLLIN}])
read(3, "\6\0\364#k\36P\6\23\1\0\0.\0\0\3\0\0\0\0a\4Q\0\202\3 \0\20\0\1\0", 
4096) = 32
read(3, 0x8dd8dd0, 4096)                = -1 EAGAIN (Resource temporarily 
gettimeofday({1280321706, 781789}, NULL) = 0
poll([{fd=3, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"&\4\2\0.\0\0\3", 8}, {NULL, 0}, {"", 0}], 3) = 8
poll([{fd=3, events=POLLIN}], 1, -1)    = 1 ([{fd=3, revents=POLLIN}])

For more information, please let me know what you need to fix it.


-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-3-686 (SMP w/2 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages gpsdrive depends on:
ii  gpsdrive-data         2.10~pre4-6.dfsg-5 Car navigation system
ii  libart-2.0-2          2.3.21-1           Library of functions for 2D graphi
ii  libatk1.0-0           1.30.0-1           The ATK accessibility toolkit
ii  libboost-filesystem1. 1.42.0-3           filesystem operations (portable pa
ii  libboost-system1.42.0 1.42.0-3           Operating system (e.g. diagnostics
ii  libc6                 2.11.2-2           Embedded GNU C Library: Shared lib
ii  libcairo2             1.8.10-4           The Cairo 2D vector graphics libra
ii  libfontconfig1        2.8.0-2.1          generic font configuration library
ii  libfreetype6          2.4.0-2            FreeType 2 font engine, shared lib
ii  libgcc1               1:4.4.4-7          GCC support library
ii  libglib2.0-0          2.24.1-1           The GLib library of C routines
ii  libgtk2.0-0           2.20.1-1           The GTK+ graphical user interface 
ii  libmapnik0.7          0.7.1-1+b1         C++/Python toolkit for developing 
ii  libpango1.0-0         1.28.1-1           Layout and rendering of internatio
ii  libpcre3              7.8-3              Perl 5 Compatible Regular Expressi
ii  libstdc++6            4.4.4-7            The GNU Standard C++ Library v3
ii  libxml2               2.7.7.dfsg-4       GNOME XML library
ii  openstreetmap-map-ico 1:0.0.svn20783-1   Collection of map icons (classic s
ii  openstreetmap-map-ico 1:0.0.svn20783-1   Collection of map icons (square se

Versions of packages gpsdrive recommends:
ii  gpsd                  2.95-3             Global Positioning System - daemon
ii  gpsdrive-scripts      2.10~pre4-6.dfsg-5 Various scripts for gpsdrive

Versions of packages gpsdrive suggests:
ii  festival                   1.96~beta-10  General multi-lingual speech synth
ii  flite                      1.4-release-2 A small run-time speech synthesis 
ii  mysql-server               5.1.48-1      MySQL database server (metapackage
ii  mysql-server-5.1 [mysql-se 5.1.48-1      MySQL database server binaries and
ii  osm2pgsql                  0.69+r20104-1 Openstreetmap data to PostgreSQL c
pn  postgresql-8.4-postgis     <none>        (no description available)

-- no debconf information

Pkg-grass-devel mailing list

Reply via email to