Package: grass
Version: 6.4.0~rc6+42329-1+b1
Severity: normal

To replicate:

Open a workspace file under wxpython. Change a map layer name on the "map 
layers for each display" and include a non-ascii letter, like 'รค'. Exit gui. 
asked to save changes to workspace, answer 'Yes'. result:

Writing current settings to workspace file failed ('ascii' codec can't encode 
character u'\xe4' in position 39: ordinal not in range(128)).

What should happen: the user is brought back to the layers display, and the 
error message should be somewhat more clear: "non-ascii / Unicode characters in 
layer names cannot be used."

What happens: gui closes anyway, and leaves a corrupted workspace file behind. 
Causes lots of irritation in case of a complex workspace setting.


Harri K.

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (990, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-3-686 (SMP w/1 CPU core)
Locale: LANG=en_IE.UTF-8, LC_CTYPE=en_IE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages grass depends on:
ii  eterm [x-terminal-emula 0.9.5-2          Enlightened Terminal Emulator
ii  gnome-terminal [x-termi 2.30.2-1         The GNOME terminal emulator applic
ii  lesstif2                1:0.95.2-1       OSF/Motif 2.1 implementation relea
ii  libc6                   2.11.2-2         Embedded GNU C Library: Shared lib
ii  libcairo2               1.8.10-5         The Cairo 2D vector graphics libra
ii  libfftw3-3              3.2.2-1          library for computing Fast Fourier
ii  libfontconfig1          2.8.0-2.1        generic font configuration library
ii  libfreetype6            2.4.2-1          FreeType 2 font engine, shared lib
ii  libgcc1                 1:4.4.4-8        GCC support library
ii  libgdal1-1.6.0          1.6.3-4          Geospatial Data Abstraction Librar
ii  libgl1-mesa-glx [libgl1 7.7.1-4          A free implementation of the OpenG
ii  libglu1-mesa [libglu1]  7.7.1-4          The OpenGL utility library (GLU)
ii  libice6                 2:1.0.6-1        X11 Inter-Client Exchange library
ii  libmysqlclient16        5.1.49-1         MySQL database client library
ii  libncurses5             5.7+20100313-2   shared libraries for terminal hand
ii  libpng12-0              1.2.44-1         PNG library - runtime
ii  libpq5                  8.4.4-2          PostgreSQL C client library
ii  libproj0                4.7.0-1          Cartographic projection library
ii  libpython2.6            2.6.6~rc1-1      Shared Python runtime library (ver
ii  libreadline6            6.1-3            GNU readline and history libraries
ii  libsm6                  2:1.1.1-1        X11 Session Management library
ii  libsqlite3-0            3.7.2-1          SQLite 3 shared library
ii  libstdc++6              4.4.4-8          The GNU Standard C++ Library v3
ii  libtiff4                3.9.4-3          Tag Image File Format (TIFF) libra
ii  libwxbase2.8-0       wxBase library (runtime) - non-GUI
ii  libwxgtk2.8-0        wxWidgets Cross-platform C++ GUI t
ii  libx11-6                2:1.3.3-3        X11 client-side library
ii  libxext6                2:1.1.2-1        X11 miscellaneous extension librar
ii  libxmu6                 2:1.0.5-1        X11 miscellaneous utility library
ii  libxrender1             1:0.9.6-1        X Rendering Extension client libra
ii  libxt6                  1:1.0.7-1        X11 toolkit intrinsics library
ii  rxvt-unicode [x-termina 9.07-2           RXVT-like terminal emulator with U
ii  tcl8.4                  8.4.19-4         Tcl (the Tool Command Language) v8
ii  tk8.4                   8.4.19-4         Tk toolkit for Tcl and X11, v8.4 -
ii  unixodbc                2.2.14p2-1       ODBC tools libraries
ii  xterm [x-terminal-emula 261-1            X terminal emulator
ii  zlib1g                  1: compression library - runtime

Versions of packages grass recommends:
ii  ghostscript                 8.71~dfsg2-6 The GPL Ghostscript PostScript/PDF
ii  python                      2.6.5-13     interactive high-level object-orie
ii  python-numpy                1:1.4.1-4    Numerical Python adds a fast array

Versions of packages grass suggests:
ii  avce00                 2.0.0-2           Tools for conversion of ESRI Arcin
ii  curl                   7.21.0-1          Get a file from an HTTP, HTTPS or 
ii  e00compr               1.0.1-1           a program to read/write Arc/Info c
ii  gdal-bin               1.6.3-4           Geospatial Data Abstraction Librar
ii  gnuplot                4.4.0-1           A command-line driven interactive 
pn  gpsbabel               <none>            (no description available)
pn  gpstrans               <none>            (no description available)
ii  grass-doc [grass-doc]  6.4.0~rc6+42329-1 Geographic Resources Analysis Supp
ii  netpbm                 2:10.0-12.2       Graphics conversion tools between 
ii  proj-bin               4.7.0-1           Cartographic projection library (t
ii  python-opengl          3.0.1~b2-1        Python bindings to OpenGL
ii  python-wxgtk2.8        wxWidgets Cross-platform C++ GUI t
ii  wget                   1.12-2            retrieves files from the web
ii  xml2                   0.4-3             Convert between XML, HTML, CSV and

-- no debconf information

Pkg-grass-devel mailing list

Reply via email to