On Martes 23 Noviembre 2010 23:40:05 usted escribió:
> Il 18/11/2010 17:02, Noel David Torres Taño ha scritto:
> > Package: josm
> > Version: 0.0.svn3376-1
> > Severity: important
> > 
> > 
> > Package should depend on openjdk-6-jre which provides libmawt.so
> > 
> > $ josm
> > Using /usr/lib/jvm/java-6-openjdk/bin/java to execute josm.
> > Exception in thread "main" java.lang.UnsatisfiedLinkError: Can't load
> > library: /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/xawt/libmawt.so
> 
> I'm somewhat puzzled: josm already depends on openjdk-6-jre |
> sun-java5-jre | sun-java6-jre: any of these should work. Moreover, I
> already have openjdk-6-jre installed, because you're using to execute josm.

>From what you can see in the bug report, I do not have openjdk-6-jre 
installed. Since the dependencie is ORed, I have installed only sun-java6-jre.
> 
> Anyway, you also appear to have Java 6 from SUN. Could you try to use
> it, for example with:
> 
> JAVACMD=/usr/lib/jvm/java-6-sun/bin/java josm

This works ok. Maybe the problem is that you need to have installed the same 
jre than the java you'll use by default, and not just to have a jre. I have 
openjdk-6-jre-headless installed (which provides /usr/lib/jvm/java-6-
openjdk/bin/java ) but not openjdk-6-jre, because of this dependency chain:

i   openoffice.org  Depende liblucene2-java (>= 2.3.2)                     
i A liblucene2-java Depende openjdk-6-jre-headless | java5-runtime-headless

That is, the dependencies of your package must take into account which java is 
to be used.
> 
> BTW, are you experiencing problems with other Java graphical applications?

I'm sorry, but have no other java apps installed.
> 
> Ciao, Giovanni.

Thanks

Noel
er Envite



_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to