The following commit has been merged in the master branch:
commit 8113bb714442244e53b4c2c87f0f8de68835e5ac
Author: Youhei SASAKI <uwab...@gfd-dennou.org>
Date:   Sun Jan 24 04:35:48 2010 +0900

    Imported Debian patch 0.6.4-1

diff --git a/debian/README.Debian b/debian/README.Debian
new file mode 100644
index 0000000..784b825
--- /dev/null
+++ b/debian/README.Debian
@@ -0,0 +1,8 @@
+netcdf-ruby for Debian
+=======================
+
+This package build without opendap support, beacuse of netcdf 4.1
+package is in experimental.
+
+ -- Youhei SASAKI <uwab...@gfd-dennou.org>, Thu, 18 Mar 2010 23:41:22 +0900
+
diff --git a/debian/changelog b/debian/changelog
index 13e95fd..b30f3a7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,11 @@
 ruby-netcdf (0.6.4-1) unstable; urgency=low
 
   * Initial Release (Closes: #542144)
+<<<<<<< HEAD
 
  -- Youhei SASAKI <uwab...@gfd-dennou.org>  Sun, 22 Aug 2010 10:27:54 +0900
+=======
+  * Build without opendap(nc-dap) support.
+
+ -- Youhei SASAKI <uwab...@gfd-dennou.org>  Sun, 24 Jan 2010 04:35:48 +0900
+>>>>>>> 6617e11... Imported Debian patch 0.6.4-1
diff --git a/debian/compat b/debian/compat
index 7f8f011..2e9e2e6 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1,5 @@
+<<<<<<< HEAD
 7
+=======
+5
+>>>>>>> 6617e11... Imported Debian patch 0.6.4-1
diff --git a/debian/control b/debian/control
index 0d33778..c209165 100644
--- a/debian/control
+++ b/debian/control
@@ -2,10 +2,18 @@ Source: ruby-netcdf
 Section: ruby
 Priority: optional
 Maintainer: Youhei SASAKI <uwab...@gfd-dennou.org>
+<<<<<<< HEAD
 Build-Depends: cdbs, debhelper (>= 7.0.50~ ), ruby-pkg-tools, quilt,
   libnetcdf-dev (>= 4.1.1-5 ), libdap-dev, libcurl4-gnutls-dev,
   libnarray-ruby1.8, ruby1.8-dev, libnarray-ruby1.9.1, ruby1.9.1-dev
 Standards-Version: 3.9.1
+=======
+Build-Depends: cdbs, debhelper (>> 7), ruby-pkg-tools, quilt,
+  libnetcdf-dev, 
+  libnarray-ruby1.8, ruby1.8-dev, libnarray-ruby1.9.1, ruby1.9.1-dev
+#libdap-dev, libnc-dap-dev, libcurl4-gnutls-dev, libxml2-dev,
+Standards-Version: 3.8.3
+>>>>>>> 6617e11... Imported Debian patch 0.6.4-1
 Homepage: http://ruby.gfd-dennou.org/products/ruby-netcdf
 
 Package: netcdf-ruby
@@ -15,8 +23,12 @@ Description: Ruby interface of netCDF library
  RubyNetCDF is a Ruby interface of netCDF library built on the NArray library,
  which is an efficient multi-dimensional numeric array class for Ruby.
  .
+<<<<<<< HEAD
  This package is dependency package, which depends on Debian's default
  Ruby version(currently 1.8.x).
+=======
+ This package is build for Ruby 1.8.
+>>>>>>> 6617e11... Imported Debian patch 0.6.4-1
 
 Package: netcdf-ruby1.8
 Architecture: any
@@ -69,6 +81,7 @@ Description: Ruby interface of netCDF library
  in a debugger, this makes it somewhat easier to interpret core
  dumps.  Most people will not need this package.
 
+<<<<<<< HEAD
 
 Package: netcdf-ruby-doc
 Section: doc
@@ -79,3 +92,5 @@ Description: Documents and example scripts of netcdf-ruby
  which is an efficient multi-dimensional numeric array class for Ruby.
  .
  This package provides all API documents and example scripts 
+=======
+>>>>>>> 6617e11... Imported Debian patch 0.6.4-1
diff --git a/debian/patches/modified-extconf-rb.patch 
b/debian/patches/modified-extconf-rb.patch
new file mode 100644
index 0000000..354a4d9
--- /dev/null
+++ b/debian/patches/modified-extconf-rb.patch
@@ -0,0 +1,38 @@
+--- ruby-netcdf-0.6.4.orig/extconf.rb
++++ ruby-netcdf-0.6.4/extconf.rb
+@@ -1,7 +1,7 @@
+ require "mkmf"
+ 
+-dir_config('narray',$sitearchdir,$sitearchdir)
+-dir_config('netcdf','/usr/local')
++dir_config('narray',$archdir,$archdir)
++dir_config('netcdf','/usr')
+ 
+ if ( ! ( have_header("narray.h") && have_header("narray_config.h") ) ) then
+ print <<EOS
+@@ -15,7 +15,12 @@
+    exit(-1)
+ end
+ 
+-if xsystem("ncdap-config --libs")
++if xsystem("pkg-config libnc-dap --libs")
++  libncdods = "nc-dap"
++  cflags = `pkg-config libnc-dap --cflags`.gsub(/\n/, " ")
++  libs = `pkg-config libnc-dap --libs`.gsub(/\n/," ")
++  prefix_dods = `pkg-config libnc-dap --variable=prefix`.gsub(/\n/," ")
++elsif xsystem("ncdap-config --libs")
+   libncdods = "nc-dap"
+   cflags = `ncdap-config --cflags`.gsub(/\n/, " ")
+   libs = `ncdap-config --libs`.gsub(/\n/, " ")
+@@ -27,8 +32,9 @@
+   prefix_dods = `opendap-config --prefix`.gsub(/\n/, "")
+ end
+ 
+-if (enable_config('opendap',true) && ( xsystem("opendap-config --libs")) ||
+-                                       xsystem("ncdap-config --libs") )
++if (enable_config('opendap',true) && ( xsystem("pkg-config libnc-dap --libs") 
||
++                                       xsystem("opendap-config --libs")  ||
++                                       xsystem("ncdap-config --libs") ))
+ 
+   dir_config(libncdods,prefix_dods)
+ 
diff --git a/debian/patches/series b/debian/patches/series
index 362fddc..47850ad 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,5 @@
+<<<<<<< HEAD
 ChangeExtconf
+=======
+modified-extconf-rb.patch
+>>>>>>> 6617e11... Imported Debian patch 0.6.4-1
diff --git a/debian/rules b/debian/rules
index 0d7861c..39891a4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,4 +9,10 @@ include /usr/share/ruby-pkg-tools/1/class/ruby-extconf-rb.mk
 
 DEB_INSTALL_CHANGELOGS_ALL := ChangeLog
 DEB_COMPRESS_EXCLUDE := .rd .html
+<<<<<<< HEAD
 DEB_INSTALL_DOCS_netcdf-ruby-doc := doc/*.rd doc/*.html
+=======
+DEB_RUBY_SETUP_ARGS := --disable-opendap
+install_docs := doc/*.rd doc/*.html
+DEB_INSTALL_DOCS_netcdf-ruby1.8:= $(install_docs)
+>>>>>>> 6617e11... Imported Debian patch 0.6.4-1

-- 
Ruby interface of NetCDF library

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to