Your message dated Tue, 08 Feb 2011 15:17:36 +0000
with message-id <e1pmpjw-0000su...@franck.debian.org>
and subject line Bug#579987: fixed in gdal 1.7.3-1
has caused the Debian Bug report #579987,
regarding FTBFS when python-setuptools is installed
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
579987: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=579987
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: libgdal1-1.6.0
Version: 1.6.3-3+b2
Severity: normal

GDAL fails to build when python-setuptools is installed. When I
uninstall python-setuptools it builds fine. The error I get is:

make[1]: Entering directory `/home/jeroen/src/debian/gdal-1.6.3/swig/python'
/usr/bin/python2.6 setup.py install
numpy include /usr/lib/python2.6/dist-packages/numpy/core/include
setup.py:78: DeprecationWarning: The popen2 module is deprecated.  Use the 
subprocess module.
  import popen2
running install
error: can't create or remove files in install directory

The following error occurred while trying to add or remove files in the
installation directory:

    [Errno 13] Permission denied: 
'/usr/local/lib/python2.6/dist-packages/test-easy-install-13219.write-test'

The installation directory you specified (via --install-dir, --prefix, or
the distutils default setting) was:

    /usr/local/lib/python2.6/dist-packages/

Perhaps your account does not have write access to this directory?  If the
installation directory is a system-owned directory, you may need to sign in
as the administrator or "root" account.  If you do not have administrative
access to this machine, you may wish to choose a different installation
directory, preferably one that is listed in your PYTHONPATH environment
variable.

For information on other options, you may wish to consult the
documentation at:
  
  http://peak.telecommunity.com/EasyInstall.html

Please make the appropriate changes for your system and try again.

make[1]: *** [install] Error 1
make[1]: Leaving directory `/home/jeroen/src/debian/gdal-1.6.3/swig/python'
make: *** [build-stamp] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2


-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-3-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libgdal1-1.6.0 depends on:
ii  libc6                   2.10.2-6         Embedded GNU C Library: Shared lib
ii  libcurl3-gnutls         7.20.0-3+b1      Multi-protocol file transfer libra
ii  libexpat1               2.0.1-7          XML parsing C library - runtime li
ii  libgcc1                 1:4.4.2-9        GCC support library
ii  libgeos-c1              3.2.0-1          Geometry engine for Geographic Inf
ii  libgif4                 4.1.6-9          library for GIF images (library)
ii  libhdf4-0-alt           4.2r4-10         The Hierarchical Data Format libra
ii  libhdf5-serial-1.8.4 [l 1.8.4-patch1-1   Hierarchical Data Format 5 (HDF5) 
ii  libjasper1              1.900.1-7        The JasPer JPEG-2000 runtime libra
ii  libjpeg62               6b-16.1          The Independent JPEG Group's JPEG 
ii  libmysqlclient16        5.1.45-1         MySQL database client library
ii  libnetcdf4              1:3.6.3-1        An interface for scientific data a
ii  libogdi3.2              3.2.0~beta2-6    Open Geographic Datastore Interfac
ii  libpng12-0              1.2.43-1         PNG library - runtime
ii  libpq5                  8.4.3-1          PostgreSQL C client library
ii  libsqlite3-0            3.6.23.1-1       SQLite 3 shared library
ii  libstdc++6              4.4.2-9          The GNU Standard C++ Library v3
ii  libxerces-c28           2.8.0+deb1-2     validating XML parser library for 
ii  odbcinst1debian2        2.2.14p2-1       Support library for accessing odbc
ii  unixodbc                2.2.14p2-1       ODBC tools libraries
ii  zlib1g                  1:1.2.3.4.dfsg-3 compression library - runtime

Versions of packages libgdal1-1.6.0 recommends:
pn  proj-bin                      <none>     (no description available)

libgdal1-1.6.0 suggests no packages.

-- no debconf information



--- End Message ---
--- Begin Message ---
Source: gdal
Source-Version: 1.7.3-1

We believe that the bug you reported is fixed in the latest version of
gdal, which is due to be installed in the Debian FTP archive:

gdal-bin_1.7.3-1_i386.deb
  to main/g/gdal/gdal-bin_1.7.3-1_i386.deb
gdal_1.7.3-1.diff.gz
  to main/g/gdal/gdal_1.7.3-1.diff.gz
gdal_1.7.3-1.dsc
  to main/g/gdal/gdal_1.7.3-1.dsc
gdal_1.7.3.orig.tar.gz
  to main/g/gdal/gdal_1.7.3.orig.tar.gz
libgdal-doc_1.7.3-1_all.deb
  to main/g/gdal/libgdal-doc_1.7.3-1_all.deb
libgdal-perl_1.7.3-1_i386.deb
  to main/g/gdal/libgdal-perl_1.7.3-1_i386.deb
libgdal-ruby1.8_1.7.3-1_i386.deb
  to main/g/gdal/libgdal-ruby1.8_1.7.3-1_i386.deb
libgdal-ruby_1.7.3-1_i386.deb
  to main/g/gdal/libgdal-ruby_1.7.3-1_i386.deb
libgdal1-1.7.0_1.7.3-1_i386.deb
  to main/g/gdal/libgdal1-1.7.0_1.7.3-1_i386.deb
libgdal1-dev_1.7.3-1_i386.deb
  to main/g/gdal/libgdal1-dev_1.7.3-1_i386.deb
python-gdal_1.7.3-1_i386.deb
  to main/g/gdal/python-gdal_1.7.3-1_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 579...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Francesco Paolo Lovergine <fran...@debian.org> (supplier of updated gdal 
package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Tue, 08 Feb 2011 15:05:36 +0100
Source: gdal
Binary: libgdal1-1.7.0 libgdal1-dev libgdal-doc gdal-bin python-gdal 
libgdal-perl libgdal-ruby1.8 libgdal-ruby
Architecture: source i386 all
Version: 1.7.3-1
Distribution: unstable
Urgency: low
Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
Changed-By: Francesco Paolo Lovergine <fran...@debian.org>
Description: 
 gdal-bin   - Geospatial Data Abstraction Library - Utility programs
 libgdal-doc - Documentation for the Geospatial Data Abstraction Library
 libgdal-perl - Perl bindings to the Geospatial Data Abstraction Library
 libgdal-ruby - Ruby bindings to the Geospatial Data Abstraction Library
 libgdal-ruby1.8 - Ruby 1.8 bindings to the Geospatial Data Abstraction Library
 libgdal1-1.7.0 - Geospatial Data Abstraction Library
 libgdal1-dev - Geospatial Data Abstraction Library - Development files
 python-gdal - Python bindings to the Geospatial Data Abstraction Library
Closes: 579987 580172 598346 598643
Changes: 
 gdal (1.7.3-1) unstable; urgency=low
 .
   [ Alan Boudreault ]
   * New upstream release with many fixes.
   * Added libspatialite-dev dependency for libgdal1-dev.
 .
   [ Francesco Paolo Lovergine ]
   * Added sample programs to python-gdal documentation.
   * Merged changelog to be ready for true unstable upload.
   * Policy bumped to 3.9.1, without changes.
   * Added Build-Conflicts against python-setuptools, because it still
     has problems at building time.
     (closes: #579987)
   * Removed unuseful strict versioning in libgdal-doc suggest for 
libgdal1-1.7.0.
     (closes: #580172)
   * Added libdap-dev dependency for libgdal1-dev.
     (closes: #598346)
   * Man pages garbling seems now fixed.
     (closes: #598643)
Checksums-Sha1: 
 a482538852f0a12d0f9ed6a2e3d2b2386d0e0f42 1884 gdal_1.7.3-1.dsc
 58d4355fe792ad618bb74605dc1a084a0aeb7cb1 7757684 gdal_1.7.3.orig.tar.gz
 4d222b0ddfdba50f3ec7e89a241cbfa98add3454 88890 gdal_1.7.3-1.diff.gz
 9ad222700971cdebd7b4bdd5fcd6c65212b379a5 3342434 
libgdal1-1.7.0_1.7.3-1_i386.deb
 1aae4216f5ab6a6311e475e8cf081589a3fab22b 4226002 libgdal1-dev_1.7.3-1_i386.deb
 f2f57079ca53c5f5fe45a1d82acbfeba5343bcd5 230714 gdal-bin_1.7.3-1_i386.deb
 226ebe3695de00548545b93acf937a7c91acea9b 587774 python-gdal_1.7.3-1_i386.deb
 96d157511aa257274d5bf57a860d75cb9487fd59 387502 libgdal-perl_1.7.3-1_i386.deb
 ed204adaa9896cc975a51c1929fbdaaa69231e4d 168542 
libgdal-ruby1.8_1.7.3-1_i386.deb
 60a88d45ed48435b6b550635168cef2589a27fa8 64602 libgdal-ruby_1.7.3-1_i386.deb
 fa2d8f3296daf8598a62f7baa7fe4f4e59b80fe3 2148280 libgdal-doc_1.7.3-1_all.deb
Checksums-Sha256: 
 557e035293d72240ec84920b998c291be741a9b8f9da9150d786d4fb3e723b62 1884 
gdal_1.7.3-1.dsc
 fbdb89356abad4e27894ebfbc865afb8b89cdb796f3a19d9b0347f9dd6e4cf4a 7757684 
gdal_1.7.3.orig.tar.gz
 0706b4ddaf5c771e578abac605de713e493929d8bfff10f3c77b3499369dfe25 88890 
gdal_1.7.3-1.diff.gz
 ffd881d23bca9d4548c3b053794ed7328186f96138510860ff25f20586e104ab 3342434 
libgdal1-1.7.0_1.7.3-1_i386.deb
 d50503570cd884baf0182e2bf250f03471fe47d129619818f291dbfb73bf8c48 4226002 
libgdal1-dev_1.7.3-1_i386.deb
 de24c13bb70f92e4f22ac1ccce4cf9336e7cd512a38f54e4f15a99ea7f40cfa1 230714 
gdal-bin_1.7.3-1_i386.deb
 7b1542b08a1d2f2227552ed604002324b246056669dc89436dc81e4e6e167838 587774 
python-gdal_1.7.3-1_i386.deb
 bd0b948e4ccfbbd8f2f9d9192f9162e689f875a68c4a883a67460d7271290815 387502 
libgdal-perl_1.7.3-1_i386.deb
 1397371f9a74d926f92d895f803034588bb3646278ce9da47cd9dce2ba8ae29b 168542 
libgdal-ruby1.8_1.7.3-1_i386.deb
 cde805cfeb2e4f7eba28aa1449bac257271103b4e2974cda89bd9f459f1fc6e1 64602 
libgdal-ruby_1.7.3-1_i386.deb
 787e092ea37d0bd1304d91f1d67909f81121b31af245a42fb39858c1c079403e 2148280 
libgdal-doc_1.7.3-1_all.deb
Files: 
 c6aedaf36d9e4c1a94167b2cfd40421e 1884 science extra gdal_1.7.3-1.dsc
 c4673970bd2285032de9ae9bbd82754a 7757684 science extra gdal_1.7.3.orig.tar.gz
 28eadd463729e8e0106a00518f0b8deb 88890 science extra gdal_1.7.3-1.diff.gz
 22a4eb41675092c6772f704a408383d8 3342434 libs extra 
libgdal1-1.7.0_1.7.3-1_i386.deb
 71090136ec2890399af94452a0643391 4226002 libdevel extra 
libgdal1-dev_1.7.3-1_i386.deb
 0cafee1fd39c8e37601928083824e5d8 230714 science extra gdal-bin_1.7.3-1_i386.deb
 2b9cf555c0783f0c30ed30fada8a5e9c 587774 python extra 
python-gdal_1.7.3-1_i386.deb
 36882b8d22fe76e14871f70b201612e0 387502 perl extra 
libgdal-perl_1.7.3-1_i386.deb
 75eaf80efc54118edcf1539f2b6fd707 168542 ruby extra 
libgdal-ruby1.8_1.7.3-1_i386.deb
 fffc3c6988d74f2c5997a7cdb27d8512 64602 ruby extra libgdal-ruby_1.7.3-1_i386.deb
 d8d5f92aff571d0fd4c0df3d86d21a13 2148280 doc extra libgdal-doc_1.7.3-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAk1RVrcACgkQpFNRmenyx0cyWgCgoimp05kzn67mK+mU39xcrfoc
fSAAoNnXKtC3JjzdRpChQ5Djf1n1fkdZ
=2aMN
-----END PGP SIGNATURE-----



--- End Message ---
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to