FYI, it impacts a few packages. Note also that current gdal and tcltk 
transitions impact as well a few packages. I'm expecting long times
before most of our core packages will enter testing and also simply
being installable all together.

Please DON'T open superfluous reports about uninstallable stuff, it is
is perfectly known and expected. They will only take time to developers
for closing and create confusion. This is unstable, not squeeze.

----- Forwarded message from Sylvestre Ledru <sylves...@debian.org> -----

Date: Sun, 27 Feb 2011 21:15:04 +0100
From: Sylvestre Ledru <sylves...@debian.org>
To: debian-rele...@lists.debian.org
Cc: fran...@debian.org
Subject: HDF5 Transition
X-Mailer: Evolution 2.30.3

Hello guys,

Just to let you know that we are planning to upload a new upstream
release of the hdf5 libraries (1.8.4 => 1.8.6). 
We will switch the API to the version 1.8 (from the 1.6). 
It might break some packages but the fix is easy (just a #define).
We will also change the package name because it is very likely that the
API/ABI changed...
We are not in an hurry but it is a pretty important package [1] [2].

How do you want to processed ?

Cheers,
Sylvestre
[1] 
$ apt-cache rdepends libhdf5-serial-1.8.4
libhdf5-serial-1.8.4
Reverse Depends:
 |code-saturne-bin
 |udav
 |paraview
 |octave-ann
 |libmgl5
 |libjhdf5-jni
 |python-h5py
 |grads
 |dynare
 |cdo
 |shogun-r
 |shogun-python
 |shogun-python-modular
 |shogun-octave
 |shogun-octave-modular
 |shogun-elwms
 |shogun-cmdline
 |libshogunui6
 |libshogun9
 |scilab-minimal-bin
 |scilab-full-bin
 |octave-communications
 |libmgl5
 |libcgns2
 |cgns-convert
 |gnudatalanguage
 |libgdal1-1.7.0
 |libgdal-ruby1.8
 |libgdal-perl
 |yorick-hdf5
 |udav
 |tessa
 |tessa-mpi
 |python-silo
 |libsilo0
 |libsilo-bin
 |shogun-r
 |shogun-python
 |shogun-python-modular
 |shogun-octave
 |shogun-octave-modular
 |shogun-elwms
 |shogun-cmdline
 |libshogunui5
 |libshogun8
 |octave-sp
 |sdpam
 |scilab-minimal-bin
 |scilab-full-bin
 |r-cran-hdf5
 |python-tables
 |python-gpiv
 |octave-plplot
 |octave-pfstools
 |paraview
 |octave3.2
 |octave-xraylib
 |octave-symband
 |octave-sockets
 |octave-secs2d
 |octave-secs1d
 |octave-pdb
 |octave-optiminterp
 |octave-octgpr
 |octave-nlwing2
 |octave-multicore
 |octave-miscellaneous
 |octave-linear-algebra
 |octave-gsl
 |octave-ftp
 |octave-fixed
 |octave-econometrics
 |octave-communications
 |octave-combinatorics
 |octave-audio
 |octave-ad
 |netcdf-bin
 |libnetcdf6
 |mpb
 |mpb-mpi
 |meep
 |meep-mpi
 |libmeep6
 |libmeep-mpi6
 |libmgl5
 |python-mapscript
 |php5-mapscript
 |perl-mapscript
 |mapserver-bin
 |libmapscript-ruby1.9.1
 |libmapscript-ruby1.8
 |cgi-mapserver
 |python-vigra
 |libvigraimpex2
 |libpdl-io-hdf5-perl
 |libgpiv3
 |libgpiv-mpi3
 |libcgns2
 |cgns-convert
 |labplot
 |libjhdf5-jni
  libhdf5-serial-dev
 |hdf5-tools
 |libhe5-hdfeos0
 |h5utils
 |python-h5py
 |grads
 |gnudatalanguage
 |libgdal1-1.6.0
 |libgdal-ruby1.8
 |libgdal-perl
 |dynare
 |cdo
[2]
$ apt-cache rdepends libhdf5-openmpi-1.8.4
libhdf5-openmpi-1.8.4
Reverse Depends:
  libmedc1
  libmed1
  libslepc3.0.0
  minc-tools
  libminc2-1
  libluminate7
  illuminator-demo
  libslepc3.1
  salome
  salome-test
  salome-extras
  salome-examples
  libpetsc3.1
  getdp
  ecs
  code-saturne-bin
  libslepc3.0.0
  python-petsc4py
  libpetsc3.1
  minc-tools
  libminc2-1
  meep-openmpi
  libmeep-openmpi6
  meep-mpich
  libmeep-mpich6
  libmedimportcxx0
  libmedimport0
  libmedc1
  libmed1
  libmed-tools
  libluminate7
  illuminator-demo
  libhdf5-openmpi-dev
  getdp
  ecs
  python-dolfin
  libdolfin0
  code-sat

----- End forwarded message -----

-- 
Francesco P. Lovergine



_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to