Compiles and works as far as i can seen.

This workaround has to be removed if not usefull anymore, or ported to the new libtool (2.4-2):


--- rules.b     2011-04-16 11:25:25.000000000 +0000
+++ rules       2011-04-16 11:25:42.000000000 +0000
@@ -87,20 +87,6 @@
                mv GDALmake.opt GDALmake.opt-$$V; \
        done

-       # Overrides the generated libtool with official one, due to
-       # breakage in upstream version.
-       cp /usr/bin/libtool $(CURDIR)/libtool
-
-       # Patch the generated libtool to avoid passing -rpath when linking,
-       # and to explicitly link libraries against the libraries they
-       # depend on.
-       sed < libtool > libtool-2 \
- -e 's/^hardcode_libdir_flag_spec.*$$/hardcode_libdir_flag_spec=" -D__LIBTOOL_IS_A_FOOL__ "/' \
-       -e '/^archive_cmds="/s/"$$/ \\$$deplibs"/' \
-       -e 's/^hardcode_into_libs.*$$/hardcode_into_libs=no/'
-       mv libtool-2 libtool
-       chmod 755 libtool
-
        touch $@

 build: configure-stamp build-stamp



_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to