Package: grass
Version: 6.4.1-1
Severity: normal

On all my Debian testing based systems (all three of them 64-bit, LinuxMint
Debian Edition, but all the packages possibly related come from Debian), when
starting grass in GUI mode: after the GUI starts, there is an error message
window with text (translation from Czech):

Not possible to get current geographic region. wxGUI is exiting. Please run
g.region manually to solve the problem.

In the terminal, there is this at this time:

GRASS 6.4.1 (cr-jtsk):~ > /usr/share/themes/Shiki-Wise/gtk-2.0/gtkrc:126:
Murrine configuration option "gradients" is no longer supported and will be
g.list: relocation error: /usr/lib/ symbol
__cxa_pure_virtual, version libmysqlclient_16 not defined in file with link time reference
g.list: relocation error: /usr/lib/ symbol
__cxa_pure_virtual, version libmysqlclient_16 not defined in file with link time reference

(the first line not relevant for the problem). When I click OK in the error
message window, the GUI disappears and the messages in the terminal window
continue like this:

Traceback (most recent call last):
  File "/usr/lib/grass64/etc/wxpython/", line 1611, in <module>
  File "/usr/lib/grass64/etc/wxpython/", line 1604, in main
    app = GMApp(workspaceFile)
  File "/usr/lib/grass64/etc/wxpython/", line 1514, in __init__
    wx.App.__init__(self, False)
  File "/usr/lib64/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/",
line 7978, in __init__
  File "/usr/lib64/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/",
line 7552, in _BootstrapApp
    return _core_.PyApp__BootstrapApp(*args, **kwargs)
  File "/usr/lib/grass64/etc/wxpython/", line 1547, in OnInit
    workspace = self.workspaceFile)
  File "/usr/lib/grass64/etc/wxpython/", line 177, in __init__
    self.NewDisplay(show = False)
  File "/usr/lib/grass64/etc/wxpython/", line 1147, in NewDisplay
    auimgr = self._auimgr, showMapDisplay = show)
  File "/usr/lib/grass64/etc/wxpython/gui_modules/", line 119, in
    Map=self.Map, auimgr=self.auimgr)
  File "/usr/lib/grass64/etc/wxpython/gui_modules/", line 285, in
KeyError: 'n'

The prompt does not returns, I have to press Enter to get it. When I try the
g.region command, (even with commandline parameters), it does no work either:

GRASS 6.4.1 (cr-jtsk):~ > g.region
g.region: relocation error: /usr/lib/ symbol
__cxa_pure_virtual, version libmysqlclient_16 not defined in file with link time reference

Also some other commands give the same:

GRASS 6.4.1 (cr-jtsk):~ > g.list type=rast
g.list: relocation error: /usr/lib/ symbol
__cxa_pure_virtual, version libmysqlclient_16 not defined in file with link time reference

Some other commands seem to work. The problem is not limited to wxGUI, TCL GUI
is also not working. I tried to install and uninstall libgdal1-1.7.0-grass, but
it does not have any influence on it.
I also tried to install Grass binary snapshots from Grass website, but since
they depend on libgdal1-1.5.0 and many other libraries no longer available in
Wheezy, I was not able to satisfy the dependencies. As I was never able to
compile anything as complicated as Grass, I am left without Grass (and since
QGIS is also broken, without any decent analytical GIS package at all).

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.38-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=cs_CZ.utf8, LC_CTYPE=cs_CZ.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages grass depends on:
ii  gnome-terminal [x-termi 2.30.2-1         The GNOME terminal emulator applic
ii  lesstif2                1:0.95.2-1       OSF/Motif 2.1 implementation relea
ii  libc6                   2.13-4           Embedded GNU C Library: Shared lib
ii  libcairo2               1.10.0-1ubuntu2  The Cairo 2D vector graphics libra
ii  libfftw3-3              3.2.2-1          library for computing Fast Fourier
ii  libfreetype6            2.4.4-1          FreeType 2 font engine, shared lib
ii  libgcc1                 1:4.6.0-2        GCC support library
ii  libgdal1-1.7.0          1.7.3-4          Geospatial Data Abstraction Librar
ii  libgl1-mesa-glx [libgl1 7.10.2-2         free implementation of the OpenGL 
ii  libglu1-mesa [libglu1]  7.10.2-2         The OpenGL utility library (GLU)
ii  libice6                 2:1.0.7-1        X11 Inter-Client Exchange library
ii  libmysqlclient16        5.1.49-3         MySQL database client library
ii  libncurses5             5.9-1            shared libraries for terminal hand
ii  libpng12-0              1.2.44-2         PNG library - runtime
ii  libpq5                  9.0.4-1+b1       PostgreSQL C client library
ii  libproj0                4.7.0-1          Cartographic projection library
ii  libreadline6            6.1-3            GNU readline and history libraries
ii  libsm6                  2:1.2.0-1        X11 Session Management library
ii  libsqlite3-0          SQLite 3 shared library
ii  libstdc++6              4.6.0-2          The GNU Standard C++ Library v3
ii  libtiff4                3.9.5-1          Tag Image File Format (TIFF) libra
ii  libx11-6                2:1.4.3-1        X11 client-side library
ii  libxext6                2:1.2.0-2        X11 miscellaneous extension librar
ii  libxmu6                 2:1.1.0-2        X11 miscellaneous utility library
ii  libxrender1             1:0.9.6-1        X Rendering Extension client libra
ii  libxt6                  1:1.1.1-1        X11 toolkit intrinsics library
ii  python                  2.6.6-14         interactive high-level object-orie
ii  python-numpy            1:1.5.1-2+b1     Numerical Python adds a fast array
ii  python-opengl           3.0.1~b2-1       Python bindings to OpenGL
ii  python-wxgtk2.8     wxWidgets Cross-platform C++ GUI t
ii  tcl8.5                  8.5.8-2          Tcl (the Tool Command Language) v8
ii  tk8.5                   8.5.9-2          Tk toolkit for Tcl and X11, v8.5 -
ii  unixodbc                2.2.14p2-2       ODBC tools libraries
ii  xfce4-terminal [x-termi 0.4.7-1          Xfce terminal emulator
ii  xterm [x-terminal-emula 269-1            X terminal emulator
ii  zlib1g                  1: compression library - runtime

Versions of packages grass recommends:
ii  ghostscript                  9.02~dfsg-2 interpreter for the PostScript lan

Versions of packages grass suggests:
ii  avce00                    2.0.0-2        Tools for conversion of ESRI Arcin
ii  curl                      7.21.6-1       Get a file from an HTTP, HTTPS or 
ii  e00compr                  1.0.1-2        A program to read/write Arcinfo co
ii  gdal-bin                  1.7.3-4        Geospatial Data Abstraction Librar
pn  gnuplot                   <none>         (no description available)
pn  gpsbabel                  <none>         (no description available)
pn  gpstrans                  <none>         (no description available)
ii  grass-doc                 6.4.1-1        Geographic Resources Analysis Supp
ii  netpbm                    2:10.0-12.2+b1 Graphics conversion tools between 
ii  proj-bin                  4.7.0-1        Cartographic projection library (t
ii  wget                      1.12-3.1       retrieves files from the web
pn  xml2                      <none>         (no description available)

-- no debconf information

Pkg-grass-devel mailing list

Reply via email to