The following commit has been merged in the master branch:
commit 785d6a755cc50918183a42b1183419d359457f2e
Author: Youhei SASAKI <uwab...@gfd-dennou.org>
Date:   Wed May 11 17:22:30 2011 +0900

    rename package: transition RubyInWheezy

diff --git a/debian/changelog b/debian/changelog
index 8ba5a2d..d59a1c7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,21 @@
+ruby-narray-miss (1.2.2-1) unstable; urgency=low
+
+  * Bump standard-version: 3.9.2
+  * Update with files generated by dh-make-ruby:
+    - debian/rules
+    - debian/watch
+  * Updating the package as for the new Ruby practices
+    - Renaming binary/source packages to ruby-narray-miss
+    - Migrate to gem2deb
+      - removed build dependency on cdbs and ruby-pkg-tools
+    - Added XS-Ruby-Versions field to debian/control
+  * Added transitional packages in debian/control to allow smooth upgrades
+    from Squeeze.
+    - ruby-narray-miss Provides, Replaces and Conflicts with past packages
+      - libnarray-miss-ruby, libnarray-miss-ruby1.8, libnarray-miss-ruby1.9.1
+
+ -- Youhei SASAKI <uwab...@gfd-dennou.org>  Fri, 06 May 2011 03:10:06 +0900
+
 narray-miss (1.2.1-1) unstable; urgency=low
 
   * New Upstream version: 1.2.1
diff --git a/debian/control b/debian/control
index 48233f0..bb3a95c 100644
--- a/debian/control
+++ b/debian/control
@@ -1,41 +1,50 @@
-Source: narray-miss
+Source: ruby-narray-miss
 Section: ruby
 Priority: optional
 Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
 Uploaders: Youhei SASAKI <uwab...@gfd-dennou.org>
 DM-Upload-Allowed: yes
-Build-Depends: cdbs, debhelper (>= 7), ruby-pkg-tools, ruby1.8, ruby1.9.1, 
quilt
-Standards-Version: 3.9.1
+Build-Depends: debhelper (>= 7), gem2deb
+Standards-Version: 3.9.2
 Homepage: http://ruby.gfd-dennou.org/products/narray_miss/index.html
 Vcs-Git: git://git.debian.org/git/pkg-grass/narray-miss.git
 Vcs-Browser: http://git.debian.org/?p=pkg-grass/narray-miss.git
+XS-Ruby-Versions: all
 
-Package: libnarray-miss-ruby
+Package: ruby-narray-miss
 Architecture: all
-Depends: libnarray-miss-ruby1.8, ${misc:Depends}
+XB-Ruby-Versions: ${ruby:Versions}
+Depends: ${misc:Depends}
+Replaces: libnarray-miss-ruby (<< 1.2.1-1~), libnarray-miss-ruby1.8 (<< 
1.2.1-1~), libnarray-miss-ruby1.9.1 (<< 1.2.1-1~)
+Conflicts: libnarray-miss-ruby (<< 1.2.1-1~), libnarray-miss-ruby1.8 (<< 
1.2.1-1~), libnarray-miss-ruby1.9.1 (<< 1.2.1-1~)
+Provides: libnarray-miss-ruby, libnarray-miss-ruby1.8, libnarray-miss-ruby1.9.1
 Description: Additional class with processing of missing value to NArray
- NArrayMiss is a additional class with processing of missing value to 
+ NArrayMiss is a additional class with processing of missing value to
  NArray which is a numeric multi-dimensional array class.
- .
- This is a dependency package which depends on Debian's default Ruby version
- (currently 1.8.x).
 
+Package: libnarray-miss-ruby
+Architecture: all
+Section: oldlibs
+Priority: extra
+Depends: ruby-narray-miss, ${misc:Depends}
+Description: Transitional package for ruby-narray-miss
+ This is a transitional package to ease upgrades to the ruby-narray-miss
+ package. It can safely be removed.
 
 Package: libnarray-miss-ruby1.8
 Architecture: all
-Depends: libnarray-ruby1.8, ${misc:Depends}
-Description: Additional class with processing of missing value to NArray
- NArrayMiss is a additional class with processing of missing value to 
- NArray which is a numeric multi-dimensional array class.
- .
- This package provides library for Ruby 1.8.
-
+Section: oldlibs
+Priority: extra
+Depends: ruby-narray-miss, ${misc:Depends}
+Description: Transitional package for ruby-narray-miss
+ This is a transitional package to ease upgrades to the ruby-narray-miss
+ package. It can safely be removed.
 
 Package: libnarray-miss-ruby1.9.1
 Architecture: all
-Depends: libnarray-ruby1.9.1, ${misc:Depends}
-Description: Additional class with processing of missing value to NArray
- NArrayMiss is a additional class with processing of missing value to 
- NArray which is a numeric multi-dimensional array class.
- .
- This package provides library for Ruby 1.9.1
+Section: oldlibs
+Priority: extra
+Depends: ruby-narray-miss, ${misc:Depends}
+Description: Transitional package for ruby-narray-miss
+ This is a transitional package to ease upgrades to the ruby-narray-miss
+ package. It can safely be removed.
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..5bb61f2
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1,2 @@
+README
+doc/narray_miss.html
diff --git a/debian/rules b/debian/rules
index f06c6a8..a613c77 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,10 +1,4 @@
 #!/usr/bin/make -f
-DEB_AUTO_CLEANUP_RCS := yes
-NARRAY_MISS_RUBY_VERSIONS = 1.8 1.9.1
-LIB_PACKAGE_FILTER = %-ruby $(patsubst %,\%-ruby%,$(NARRAY_MISS_RUBY_VERSIONS))
-DEB_INSTALL_DOCS_ALL := doc/narray_miss.html
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-include /usr/share/ruby-pkg-tools/1/class/ruby-setup-rb.mk
 
+%:
+       dh $@ --buildsystem ruby --with ruby

-- 
Additional Ruby Class handling missing value

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to