The following commit has been merged in the master branch:
commit 7fcf90a9a4ccd701ab77926075b4da7acbb6fa65
Author: Francesco Paolo Lovergine <fran...@debian.org>
Date:   Fri Jul 8 17:16:26 2011 +0200

    Now supporting (again) multiple versions of PostgreSQL.

diff --git a/debian/README.Debian b/debian/README.Debian
index 6a4618e..d1cfb02 100644
--- a/debian/README.Debian
+++ b/debian/README.Debian
@@ -4,7 +4,7 @@ Debian README for Postgis
 These are the PostGIS packages for Debian. PostGIS is split into three
 Debian packages:
 
-postgresql-8.4-postgis
+postgresql-N.M-postgis
   This is the PostGIS module for the PostgreSQL server itself.  It contains
   the library which is loaded by the server (postgis.so), the SQL script
   for creating the SQL functions in a given database (postgis.sql), and an 
@@ -31,7 +31,7 @@ postgresql-8.4-postgis
 
        psql -d [yourdatabase] -f postgis_comments.sql 
 
-  These scripts can be found in the 
/usr/share/postgresql/8.4/contrib/postgisX.Y
+  These scripts can be found in the 
/usr/share/postgresql/N.M/contrib/postgisX.Y
   directory.
 
 postgis
diff --git a/debian/changelog b/debian/changelog
index 2a27046..f58542a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,7 +2,7 @@ postgis (1.5.2-2) unstable; urgency=low
 
   * Repository moved to git and changed Vcs-* fields in debian/control.
   * Removed obsolete debian/*_lenny.
-  * Policy bumped to 3.9.1. No changes.
+  * Policy bumped to 3.9.2. No changes.
   * Moved to source format 3.0 with quilt support.
   * Dehelper compatibility level set to 8.
   * Updated README to reflect current location of template SQL files.
@@ -11,8 +11,10 @@ postgis (1.5.2-2) unstable; urgency=low
     unexpected behavior on purging. Now each purge of postgresql-*-postgis will
     cause extension removal.
     (closes: #596663)
+  * Added PostgreSQL 9.0 support.
+    (closes: #633111)
 
- -- Francesco Paolo Lovergine <fran...@debian.org>  Thu, 24 Mar 2011 18:05:46 
+0100
+ -- Francesco Paolo Lovergine <fran...@debian.org>  Fri, 08 Jul 2011 17:16:12 
+0200
 
 postgis (1.5.2-1) unstable; urgency=low
 
diff --git a/debian/control b/debian/control
index 35cbeb5..f14b691 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,7 @@ Build-Depends: debhelper (>= 8), autotools-dev, flex, bison, 
postgresql-server-d
  libgeos-dev (>= 3.1.1), libproj-dev (>= 4.5.0), libssl-dev, xsltproc, 
docbook, docbook-xsl, libpg-java, 
  default-jdk, fastjar, libjts-java (>= 1.7), imagemagick, libcunit1-dev, 
dblatex, libxml2-dev,
  libgtk2.0-dev
-Standards-Version: 3.9.1
+Standards-Version: 3.9.2
 Homepage: http://postgis.refractions.net/
 Vcs-Browser: http://git.debian.org/?p=pkg-grass/postgis.git
 Vcs-Git: git://git.debian.org/git/pkg-grass/postgis.git
@@ -25,8 +25,21 @@ Description: Geographic objects support for PostgreSQL 8.4
  .
  This package supports PostgreSQL 8.4.
 
+Package: postgresql-9.0-postgis
+Architecture: any
+Depends: ${shlibs:Depends}, postgis, postgresql-9.0, ${misc:Depends}
+Conflicts: postgis (<< 1.2.1)
+Description: Geographic objects support for PostgreSQL 9.0
+ PostGIS adds support for geographic objects to the PostgreSQL 
object-relational
+ database. In effect, PostGIS "spatially enables" the PostgreSQL server, 
+ allowing it to be used as a backend spatial database for geographic 
information
+ systems (GIS), much like ESRI's SDE or Oracle's Spatial extension. PostGIS
+ follows the OpenGIS "Simple Features Specification for SQL".
+ .
+ This package supports PostgreSQL 9.0.
+
 Package: postgis
-Suggests: postgresql-8.4-postgis
+Suggests: postgresql-8.4-postgis | postgresql-9.0-postgis
 Depends: ${shlibs:Depends}, ${misc:Depends}
 Architecture: any
 Description: Geographic objects support for PostgreSQL -- common files
@@ -43,7 +56,7 @@ Package: libpostgis-java
 Architecture: all
 Section: java
 Depends: libpg-java
-Suggests: postgresql-8.4-postgis, ${misc:Depends}
+Suggests: postgresql-8.4-postgis | postgresql-9.0-postgis, ${misc:Depends}
 Conflicts: libpostgis-jdbc, libpostgisjava, postgresql-postgis-java
 Replaces: libpostgis-jdbc, libpostgisjava, postgresql-postgis-java
 Description: Geographic objects support for PostgreSQL -- JDBC support
diff --git a/debian/rules b/debian/rules
index 0296611..1a2aeaf 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,8 +12,6 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-include /usr/share/dpatch/dpatch.make
-
 # This has to be exported to make some magic below work.
 export DH_OPTIONS
 
@@ -40,16 +38,15 @@ endif
 
 build: build-arch build-indep
 
-build-arch: patch-stamp build-arch-stamp
+build-arch: build-arch-stamp
 build-arch-stamp:
        touch $@
 
-build-indep: patch-stamp build-indep-stamp
+build-indep: build-indep-stamp
 build-indep-stamp:
        touch $@
 
-clean: clean-patched unpatch
-clean-patched:
+clean: 
        dh_testdir
        dh_testroot
        [ -f doc/html/postgis.html.prev ] && mv doc/html/postgis.html.prev 
doc/html/postgis.html || true
@@ -112,23 +109,65 @@ install-arch: build-arch
        mv 
$(CURDIR)/debian/postgresql-8.4-postgis/usr/lib/postgresql/8.4/lib/postgis-$(MAJOR_VERSION).$(MINOR_VERSION).so
 \
           
$(CURDIR)/debian/postgresql-8.4-postgis/usr/lib/postgis/$(VERSION)/postgres/8.4/lib/.
        mv $(CURDIR)/debian/postgresql-8.4-postgis/usr/lib/postgresql/8.4/bin 
$(CURDIR)/debian/postgis/usr
+       $(MAKE) distclean
+       
+       # PostGIS for PostgreSQL 9.0
+       ./configure \
+               --host=$(DEB_HOST_GNU_TYPE) \
+               --build=$(DEB_BUILD_GNU_TYPE) \
+               --prefix=/usr \
+               --with-docdir=$(CURDIR)/debian/postgis/usr/share/doc \
+               --exec-prefix=\$${prefix}/lib/postgresql/9.0 \
+               --datadir=\$${prefix}/share/postgresql-9.0-postgis \
+               --mandir=\$${prefix}/share/man \
+               --infodir=\$${prefix}/share/info \
+               --with-pgconfig=/usr/lib/postgresql/9.0/bin/pg_config \
+               --with-gui
+       $(MAKE)
+       $(MAKE) -C doc
+       $(MAKE) install DESTDIR=$(CURDIR)/debian/postgresql-9.0-postgis
+       $(MAKE) -C doc install \
+                       
PGSQL_DOCDIR=$(CURDIR)/debian/postgis/usr/share/doc/postgis \
+                       PGSQL_MANDIR=$(CURDIR)/debian/postgis/usr/share/man \
+                       
PGSQL_SHAREDIR=$(CURDIR)/debian/postgis/usr/share/postgresql/9.0
+       install -o root -g root doc/postgis_comments.sql \
+               
$(CURDIR)/debian/postgresql-9.0-postgis/usr/share/postgresql/9.0/contrib/.
+       install -o root -g root -d 
$(CURDIR)/debian/postgresql-9.0-postgis/usr/lib/postgis/$(VERSION)/postgres/9.0/lib
+       mv 
$(CURDIR)/debian/postgresql-9.0-postgis/usr/lib/postgresql/9.0/lib/postgis-$(MAJOR_VERSION).$(MINOR_VERSION).so
 \
+          
$(CURDIR)/debian/postgresql-9.0-postgis/usr/lib/postgis/$(VERSION)/postgres/9.0/lib/.
+       mv $(CURDIR)/debian/postgresql-9.0-postgis/usr/lib/postgresql/9.0/bin 
$(CURDIR)/debian/postgis/usr
        
-       # Create custom maint scripts
+       # Create custom maint scripts: 8.4
        
        sed -e 's/@POSTGIS_VERSION@/$(VERSION)/' \
            -e 's/@POSTGRES_VERSION@/8.4/' \
            -e 's/@SOVERSION@/$(MAJOR_VERSION).$(MINOR_VERSION)/' \
-           $(CURDIR)/debian/postgis-postgresql-generic.postinst.in 
>$(CURDIR)/debian/.postinst
+           $(CURDIR)/debian/postgis-postgresql-generic.postinst.in 
>$(CURDIR)/debian/postgresql-8.4-postgis.postinst
        
        sed -e 's/@POSTGRES_VERSIONS@/8.4/' \
            -e 's/@SOVERSION@/$(MAJOR_VERSION).$(MINOR_VERSION)/' \
            $(CURDIR)/debian/postgis-generic.postrm.in 
>$(CURDIR)/debian/postgresql-8.4-postgis.postrm
        
+       # Create custom maint scripts: 9.0
+       #
+       sed -e 's/@POSTGIS_VERSION@/$(VERSION)/' \
+           -e 's/@POSTGRES_VERSION@/9.0/' \
+           -e 's/@SOVERSION@/$(MAJOR_VERSION).$(MINOR_VERSION)/' \
+           $(CURDIR)/debian/postgis-postgresql-generic.postinst.in 
>$(CURDIR)/debian/postgresql-9.0-postgis.postinst
+       
+       sed -e 's/@POSTGRES_VERSIONS@/9.0/' \
+           -e 's/@SOVERSION@/$(MAJOR_VERSION).$(MINOR_VERSION)/' \
+           $(CURDIR)/debian/postgis-generic.postrm.in 
>$(CURDIR)/debian/postgresql-9.0-postgis.postrm
+       
        dh_install -s
        
-       # copy utils
+       # copy utils for 8.4
        mkdir -p 
$(CURDIR)/debian/postgresql-8.4-postgis/usr/share/postgresql-8.4-postgis/utils
        cp utils/*.pl utils/README 
$(CURDIR)/debian/postgresql-8.4-postgis/usr/share/postgresql-8.4-postgis/utils
+       
+       # copy utils for 9.0
+       mkdir -p 
$(CURDIR)/debian/postgresql-9.0-postgis/usr/share/postgresql-9.0-postgis/utils
+       cp utils/*.pl utils/README 
$(CURDIR)/debian/postgresql-9.0-postgis/usr/share/postgresql-9.0-postgis/utils
 
 check: install-arch
        $(MAKE) check

-- 
PostGIS for PostgreSQL

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to