The following commit has been merged in the master branch:
commit da08466f9419c75ef381c231d04d97eb465cc848
Author: Francesco Paolo Lovergine <fran...@debian.org>
Date:   Tue Jul 26 11:09:12 2011 +0200

    Fixed missin swig binding generation.

diff --git a/debian/changelog b/debian/changelog
index 66fa3e2..7dbe8c0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+libkml (1.3.0~r863-3) unstable; urgency=low
+
+  * Added swig patch to remove a wrong swig version test.
+    (closes: #634528)
+
+ -- Francesco Paolo Lovergine <fran...@debian.org>  Tue, 26 Jul 2011 11:07:30 
+0200
+
 libkml (1.3.0~r863-2) unstable; urgency=low
 
   * New patch geometry_test.diff to remove another failing test.
diff --git a/debian/patches/series b/debian/patches/series
index f0c5fa5..8033dd2 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -5,3 +5,4 @@ clone.diff
 ld-as-needed.diff
 feature_view_test.diff
 geometry_test.diff
+swig
diff --git a/debian/patches/swig b/debian/patches/swig
new file mode 100644
index 0000000..06ab0c6
--- /dev/null
+++ b/debian/patches/swig
@@ -0,0 +1,27 @@
+Index: git/configure
+===================================================================
+--- git.orig/configure 2011-07-26 11:04:20.000000000 +0200
++++ git/configure      2011-07-26 11:07:16.000000000 +0200
+@@ -15039,14 +15039,14 @@
+ fi
+ 
+ 
+-      if test "x$SWIG" != x; then
+-              SWIG_VERSION=`swig -version 2>&1|grep Version|cut -d" " -f3`
+-              if test ${SWIG_VERSION:4} -lt 35; then
+-                      { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: You 
have SWIG $SWIG_VERSION installed, but libkml requires at least SWIG 1.3.35. 
The bindings will not be built." >&5
+-$as_echo "$as_me: WARNING: You have SWIG $SWIG_VERSION installed, but libkml 
requires at least SWIG 1.3.35. The bindings will not be built." >&2;}
+-                      SWIG=
+-              fi
+-      fi
++#     if test "x$SWIG" != x; then
++#             SWIG_VERSION=`swig -version 2>&1|grep Version|cut -d" " -f3`
++#             if test ${SWIG_VERSION:4} -lt 35; then
++#                     { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: You 
have SWIG $SWIG_VERSION installed, but libkml requires at least SWIG 1.3.35. 
The bindings will not be built." >&5
++#$as_echo "$as_me: WARNING: You have SWIG $SWIG_VERSION installed, but libkml 
requires at least SWIG 1.3.35. The bindings will not be built." >&2;}
++#                     SWIG=
++#             fi
++#     fi
+ fi
+  if test "x$SWIG" != x; then
+   WITH_SWIG_TRUE=

-- 
A library to manipulate KML 2.2 OGC standard files

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to