Package: hdf5
Version: 1.8.4-patch1-3
Severity: normal
Tags: patch
User: debian-s...@lists.debian.org
Usertags: s390x

hdf5 build depends on libopenmpi-dev on s390x, while this package is
not available (like on s390). Therefore the package is not buildable
here. Could you please disable MPI support on s390x in the next upload?
The patch below should do it. Thanks in advance.


diff -u hdf5-1.8.4-patch1/debian/control hdf5-1.8.4-patch1/debian/control
--- hdf5-1.8.4-patch1/debian/control
+++ hdf5-1.8.4-patch1/debian/control
@@ -4,8 +4,8 @@
 Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
 Uploaders: Francesco Paolo Lovergine <fran...@debian.org>
 Build-Depends: libmpich1.0-dev (>= 1.2.7-1), zlib1g-dev, lam4-dev (>= 
7.1.1-3.2), quilt,
- libopenmpi-dev [!arm !armel !hppa !mips !mipsel !s390 !sh4 !m68k], 
libjpeg-dev, debhelper (>> 7), sed (>=4.1.5), 
- gfortran, libibverbs-dev [!arm !armel !hppa !mips !mipsel !s390 
!kfreebsd-i386 !kfreebsd-amd64 !hurd-i386 !sh4],
+ libopenmpi-dev [!arm !armel !hppa !mips !mipsel !s390 !s390x !sh4 !m68k], 
libjpeg-dev, debhelper (>> 7), sed (>=4.1.5), 
+ gfortran, libibverbs-dev [!arm !armel !hppa !mips !mipsel !s390 !s390x 
!kfreebsd-i386 !kfreebsd-amd64 !hurd-i386 !sh4],
  sharutils, mpi-default-dev
 Standards-Version: 3.9.2
 Homepage: http://hdfgroup.org/HDF5/
diff -u hdf5-1.8.4-patch1/debian/rules hdf5-1.8.4-patch1/debian/rules
--- hdf5-1.8.4-patch1/debian/rules
+++ hdf5-1.8.4-patch1/debian/rules
@@ -51,6 +51,8 @@
 build_openmpi = no
 else ifeq ($(DEB_BUILD_ARCH),s390)
 build_openmpi = no
+else ifeq ($(DEB_BUILD_ARCH),s390x)
+build_openmpi = no
 else ifeq ($(DEB_BUILD_ARCH),sh4)
 build_openmpi = no
 else
diff -u hdf5-1.8.4-patch1/debian/control.in hdf5-1.8.4-patch1/debian/control.in
--- hdf5-1.8.4-patch1/debian/control.in
+++ hdf5-1.8.4-patch1/debian/control.in
@@ -4,8 +4,8 @@
 Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
 Uploaders: Francesco Paolo Lovergine <fran...@debian.org>
 Build-Depends: libmpich1.0-dev (>= 1.2.7-1), zlib1g-dev, lam4-dev (>= 
7.1.1-3.2), quilt,
- libopenmpi-dev [!arm !armel !hppa !mips !mipsel !s390 !sh4 !m68k], 
libjpeg-dev, debhelper (>> 7), sed (>=4.1.5), 
- gfortran, libibverbs-dev [!arm !armel !hppa !mips !mipsel !s390 
!kfreebsd-i386 !kfreebsd-amd64 !hurd-i386 !sh4],
+ libopenmpi-dev [!arm !armel !hppa !mips !mipsel !s390 !s390x !sh4 !m68k], 
libjpeg-dev, debhelper (>> 7), sed (>=4.1.5), 
+ gfortran, libibverbs-dev [!arm !armel !hppa !mips !mipsel !s390 !s390x 
!kfreebsd-i386 !kfreebsd-amd64 !hurd-i386 !sh4],
  sharutils, mpi-default-dev
 Standards-Version: 3.9.2
 Homepage: http://hdfgroup.org/HDF5/


-- System Information:
Debian Release: wheezy/sid
  APT prefers unreleased
  APT policy: (500, 'unreleased'), (500, 'unstable')
Architecture: s390x

Kernel: Linux 3.0.0-1-s390x (SMP w/2 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash



_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to