Package: python-saga
Version: 2.0.7+dfsg-1
Severity: serious
Justification: Policy 3.5
Tags: patch

python-saga doesn't depend on python. The attached patch fixed this bug. (The "--no-guessing-versions" hunk is necessary, because otherwise dh_python2 insists on having Python extensions modules available for all supported Python versions. The better solution would be to actually build them for all versions, but I don't have time to implement this.)

--
Jakub Wilk
diff -Nru saga-2.0.7+dfsg/debian/control saga-2.0.7+dfsg/debian/control
--- saga-2.0.7+dfsg/debian/control	2011-09-01 10:28:51.000000000 +0200
+++ saga-2.0.7+dfsg/debian/control	2011-09-23 23:20:43.000000000 +0200
@@ -53,7 +53,7 @@
 Package: python-saga
 Section: science
 Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, libsaga (= ${binary:Version})
+Depends: ${shlibs:Depends}, ${misc:Depends}, ${python:Depends}, libsaga (= ${binary:Version})
 Suggests: saga (= ${binary:Version})
 Description: SAGA GIS python bindings
  SAGA GIS (System for Automated Geoscientific Analyses) is a geographic
diff -Nru saga-2.0.7+dfsg/debian/rules saga-2.0.7+dfsg/debian/rules
--- saga-2.0.7+dfsg/debian/rules	2011-09-01 10:28:51.000000000 +0200
+++ saga-2.0.7+dfsg/debian/rules	2011-09-24 00:07:23.000000000 +0200
@@ -1,6 +1,6 @@
 #!/usr/bin/make -f
 %:
-	dh $@ --with-python2
+	dh $@ --with python2
 
 override_dh_auto_configure:
 	dh_auto_configure -- --enable-unicode --prefix=/usr --enable-python
@@ -13,6 +13,9 @@
 debian/% :: debian/%.in
 	sed -e 's/@VERSION@/$(VERSION)/' $< >$@
 
+override_dh_python2:
+	dh_python2 --no-guessing-versions
+
 get-orig-source:
 	wget $(UPSTREAM_URL)
 	gunzip *.tar.gz
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to