Package: libmapnik2-2.0
Version: 2.0.0+ds1-3+b1
Severity: normal

Dear Maintainer,

Running the mapnik2 package now in testing, 2.0.0+ds1-3, and also the newer
2.0.0+ds1-3+b1 now in unstable, through generate_image.py, generate_tiles.py or
renderd, produces the following error message:

Problem loading plugin library: /usr/lib/mapnik/2.0/input/rasterlite.input
(dlopen failed - plugin likely has an unsatisfied dependency or incompatible
ABI)

Here is the output of:
ldd /usr/lib/mapnik/2.0/input/rasterlite.input
        linux-gate.so.1 =>  (0xb7793000)
        librasterlite.so.1 => /usr/local/lib/librasterlite.so.1 (0xb7759000)
        libmapnik2.so.2.0 => /usr/lib/libmapnik2.so.2.0 (0xb730a000)
        libicuuc.so.48 => /usr/lib/libicuuc.so.48 (0xb71a1000)
        libboost_system.so.1.46.1 => /usr/lib/libboost_system.so.1.46.1
(0xb719e000)
        libboost_filesystem.so.1.46.1 => /usr/lib/libboost_filesystem.so.1.46.1
(0xb7181000)
        libstdc++.so.6 => /usr/lib/i386-linux-gnu/libstdc++.so.6 (0xb7098000)
        libm.so.6 => /lib/i386-linux-gnu/i686/cmov/libm.so.6 (0xb7072000)
        libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xb7054000)
        libc.so.6 => /lib/i386-linux-gnu/i686/cmov/libc.so.6 (0xb6efa000)
        libgeotiff.so.1.2 => /usr/lib/libgeotiff.so.1.2 (0xb6ed7000)
        libtiff.so.4 => /usr/lib/i386-linux-gnu/libtiff.so.4 (0xb6e73000)
        libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0xb6e4f000)
        libpng12.so.0 => /lib/i386-linux-gnu/libpng12.so.0 (0xb6e25000)
        libspatialite.so.1 => /usr/local/lib/libspatialite.so.1 (0xb6d6e000)
        libproj.so.0 => /usr/lib/libproj.so.0 (0xb6d3a000)
        libfreetype.so.6 => /usr/lib/i386-linux-gnu/libfreetype.so.6
(0xb6c9f000)
        libltdl.so.7 => /usr/lib/i386-linux-gnu/libltdl.so.7 (0xb6c95000)
        libz.so.1 => /usr/lib/libz.so.1 (0xb6c80000)
        libjpeg.so.8 => /usr/lib/libjpeg.so.8 (0xb6c47000)
        libboost_regex.so.1.46.1 => /usr/lib/libboost_regex.so.1.46.1
(0xb6b53000)
        libxml2.so.2 => /usr/lib/libxml2.so.2 (0xb6a04000)
        libboost_thread.so.1.46.1 => /usr/lib/libboost_thread.so.1.46.1
(0xb69ed000)
        libcairomm-1.0.so.1 => /usr/lib/libcairomm-1.0.so.1 (0xb69c7000)
        libcairo.so.2 => /usr/lib/libcairo.so.2 (0xb68f8000)
        libsigc-2.0.so.0 => /usr/lib/libsigc-2.0.so.0 (0xb68f3000)
        libicudata.so.48 => /usr/lib/libicudata.so.48 (0xb5784000)
        libdl.so.2 => /lib/i386-linux-gnu/i686/cmov/libdl.so.2 (0xb5780000)
        librt.so.1 => /lib/i386-linux-gnu/i686/cmov/librt.so.1 (0xb5776000)
        libpthread.so.0 => /lib/i386-linux-gnu/i686/cmov/libpthread.so.0
(0xb575d000)
        /lib/ld-linux.so.2 (0xb7794000)
        libgeos_c.so.1 => /usr/lib/libgeos_c.so.1 (0xb5740000)
        libgeos-3.1.0.so => not found
        libicuuc.so.44 => /usr/lib/libicuuc.so.44 (0xb5605000)
        libicui18n.so.44 => /usr/lib/libicui18n.so.44 (0xb5429000)
        libicudata.so.44 => /usr/lib/libicudata.so.44 (0xb45e8000)
        libXrender.so.1 => /usr/lib/i386-linux-gnu/libXrender.so.1 (0xb45de000)
        libX11.so.6 => /usr/lib/i386-linux-gnu/libX11.so.6 (0xb44a4000)
        libpixman-1.so.0 => /usr/lib/i386-linux-gnu/libpixman-1.so.0
(0xb4420000)
        libfontconfig.so.1 => /usr/lib/i386-linux-gnu/libfontconfig.so.1
(0xb43ed000)
        libxcb-shm.so.0 => /usr/lib/i386-linux-gnu/libxcb-shm.so.0 (0xb43ea000)
        libxcb-render.so.0 => /usr/lib/i386-linux-gnu/libxcb-render.so.0
(0xb43e1000)
        libxcb.so.1 => /usr/lib/i386-linux-gnu/libxcb.so.1 (0xb43c2000)
        libgeos-3.2.2.so => /usr/lib/libgeos-3.2.2.so (0xb4264000)
        libexpat.so.1 => /lib/i386-linux-gnu/libexpat.so.1 (0xb423c000)
        libXau.so.6 => /usr/lib/i386-linux-gnu/libXau.so.6 (0xb4239000)
        libXdmcp.so.6 => /usr/lib/i386-linux-gnu/libXdmcp.so.6 (0xb4233000)

libgeos-3.1.0.so is not found, but does not seem to be currently available in
Debian standard versions.

This bug seems harmless as long as rasterlite datasources are not used (and I
do not currently plan to use any).

Best regards,



-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (500, 'stable'), (1, 
'experimental')
Architecture: i386 (i686)

Kernel: Linux 3.0.0-1-686-pae (SMP w/2 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages libmapnik2-2.0 depends on:
ii  libboost-filesystem1.46.1  1.46.1-7        
ii  libboost-regex1.46.1       1.46.1-7        
ii  libboost-system1.46.1      1.46.1-7        
ii  libboost-thread1.46.1      1.46.1-7        
ii  libc6                      2.13-21         
ii  libcairo2                  1.10.2-6.1      
ii  libcairomm-1.0-1           1.10.0-1        
ii  libcurl3-gnutls            7.21.7-3        
ii  libfreetype6               2.4.7-2         
ii  libgcc1                    1:4.6.1-15      
ii  libgdal1-1.7.0             1.7.3-6+b1      
ii  libgeos-c1                 3.2.2-3         
ii  libicu48                   4.8.1.1-1       
ii  libjpeg8                   8c-2            
ii  libltdl7                   2.4.2-1         
ii  libpng12-0                 1.2.46-3        
ii  libpq5                     9.1.1-3         
ii  libproj0                   4.7.0-1         
ii  librasterlite1             1.1~svn11-1     
ii  libsigc++-2.0-0c2a         2.2.9-1         
ii  libsqlite3-0               3.7.7-2         
ii  libstdc++6                 4.6.1-15        
ii  libtiff4                   3.9.5-2         
ii  libxml2                    2.7.8.dfsg-5    
ii  ttf-dejavu                 2.33-2          
ii  zlib1g                     1:1.2.3.4.dfsg-3

libmapnik2-2.0 recommends no packages.

Versions of packages libmapnik2-2.0 suggests:
ii  postgis  1.5.3-1

-- no debconf information



_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to