Package: hdf5
Version: 1.8.4-patch1-3
Severity: normal

Hi,

Could you please add mpi support for armel/armhf? Some packages
build-depend on hdf5-openmpi-dev which is not available on these
platrofms. Now that openmpi builds on armel/armhf, building of the
hdf5-*mpi* packages is possielb with the patch. Tested to work on both
armel/armhf.

Thanks

Konstantinos
diff -ruN hdf5-1.8.4-patch1/debian/control hdf5-1.8.4-patch1.mpi/debian/control
--- hdf5-1.8.4-patch1/debian/control	2012-01-06 10:49:55.000000000 +0000
+++ hdf5-1.8.4-patch1.mpi/debian/control	2012-01-06 10:50:41.170540889 +0000
@@ -4,8 +4,8 @@
 Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
 Uploaders: Francesco Paolo Lovergine <fran...@debian.org>
 Build-Depends: libmpich1.0-dev (>= 1.2.7-1), zlib1g-dev, lam4-dev (>= 7.1.1-3.2), quilt,
- libopenmpi-dev [!arm !armel !hppa !mips !mipsel !s390 !sh4 !m68k], libjpeg-dev, debhelper (>> 7), sed (>=4.1.5), 
- gfortran, libibverbs-dev [!arm !armel !hppa !mips !mipsel !s390 !kfreebsd-i386 !kfreebsd-amd64 !hurd-i386 !sh4],
+ libopenmpi-dev [!arm !hppa !mips !mipsel !s390 !sh4 !m68k], libjpeg-dev, debhelper (>> 7), sed (>=4.1.5), 
+ gfortran, libibverbs-dev [!arm !hppa !mips !mipsel !s390 !kfreebsd-i386 !kfreebsd-amd64 !hurd-i386 !sh4],
  sharutils, mpi-default-dev
 Standards-Version: 3.9.2
 Homepage: http://hdfgroup.org/HDF5/
@@ -77,7 +77,7 @@
 Package: libhdf5-openmpi-1.8.4
 Section: libs
 Priority: extra
-Architecture: alpha amd64 i386 ia64 powerpc sparc kfreebsd-i386 kfreebsd-amd64
+Architecture: alpha armel armhf amd64 i386 ia64 powerpc sparc kfreebsd-i386 kfreebsd-amd64
 Depends: ${shlibs:Depends}
 Conflicts: libhdf5-1.8.4, libhdf5-1.8, libhdf5-1.8.3
 Provides: libhdf5-1.8.4, libhdf5-1.8
@@ -93,7 +93,7 @@
 Package: libhdf5-openmpi-dev
 Section: libdevel
 Priority: extra
-Architecture: alpha amd64 i386 ia64 powerpc sparc kfreebsd-i386 kfreebsd-amd64
+Architecture: alpha armel armhf amd64 i386 ia64 powerpc sparc kfreebsd-i386 kfreebsd-amd64
 Depends: libhdf5-openmpi-1.8.4 (= ${binary:Version}), zlib1g-dev, libjpeg-dev, libopenmpi-dev
 Conflicts: libhdf5-dev
 Provides: libhdf5-dev
diff -ruN hdf5-1.8.4-patch1/debian/control.in hdf5-1.8.4-patch1.mpi/debian/control.in
--- hdf5-1.8.4-patch1/debian/control.in	2012-01-06 10:49:55.000000000 +0000
+++ hdf5-1.8.4-patch1.mpi/debian/control.in	2012-01-04 17:35:01.117504026 +0000
@@ -4,8 +4,8 @@
 Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
 Uploaders: Francesco Paolo Lovergine <fran...@debian.org>
 Build-Depends: libmpich1.0-dev (>= 1.2.7-1), zlib1g-dev, lam4-dev (>= 7.1.1-3.2), quilt,
- libopenmpi-dev [!arm !armel !hppa !mips !mipsel !s390 !sh4 !m68k], libjpeg-dev, debhelper (>> 7), sed (>=4.1.5), 
- gfortran, libibverbs-dev [!arm !armel !hppa !mips !mipsel !s390 !kfreebsd-i386 !kfreebsd-amd64 !hurd-i386 !sh4],
+ libopenmpi-dev [!arm !hppa !mips !mipsel !s390 !sh4 !m68k], libjpeg-dev, debhelper (>> 7), sed (>=4.1.5), 
+ gfortran, libibverbs-dev [!arm !hppa !mips !mipsel !s390 !kfreebsd-i386 !kfreebsd-amd64 !hurd-i386 !sh4],
  sharutils, mpi-default-dev
 Standards-Version: 3.9.2
 Homepage: http://hdfgroup.org/HDF5/
diff -ruN hdf5-1.8.4-patch1/debian/rules hdf5-1.8.4-patch1.mpi/debian/rules
--- hdf5-1.8.4-patch1/debian/rules	2012-01-06 10:49:55.000000000 +0000
+++ hdf5-1.8.4-patch1.mpi/debian/rules	2012-01-04 17:33:59.318141857 +0000
@@ -37,12 +37,10 @@
 #ARCH_FLAG=-a
 #ARCHS=any
 ARCH_FLAG=-s
-ARCHS=alpha amd64 i386 ia64 powerpc sparc kfreebsd-i386 kfreebsd-amd64
+ARCHS=alpha armel armhf amd64 i386 ia64 powerpc sparc kfreebsd-i386 kfreebsd-amd64
 
 ifeq ($(DEB_BUILD_ARCH),arm)
 build_openmpi = no
-else ifeq ($(DEB_BUILD_ARCH),armel)
-build_openmpi = no
 else ifeq ($(DEB_BUILD_ARCH),hppa)
 build_openmpi = no
 else ifeq ($(DEB_BUILD_ARCH),mips)
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to