Your message dated Fri, 20 Jan 2012 14:49:00 +0000
with message-id <e1rofm0-0005zc...@franck.debian.org>
and subject line Bug#655799: fixed in grass 6.4.1-2
has caused the Debian Bug report #655799,
regarding grass: FTBFS: configure: error: wxWidgets is required.
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
655799: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=655799
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Source: grass
Version: 6.4.1-1
Severity: serious
Tags: wheezy sid
User: debian...@lists.debian.org
Usertags: qa-ftbfs-20120112 qa-ftbfs
Justification: FTBFS on amd64

Hi,

During a rebuild of all packages in sid, your package failed to build on
amd64.

Relevant part:
>  debian/rules build
> dh_testdir
> cp -f config.sub config.sub.original
> cp -f /usr/share/misc/config.sub config.sub
> cp -f config.guess config.guess.original
> cp -f /usr/share/misc/config.guess config.guess
> # Add here commands to configure the package.
> CFLAGS="-Wall -g -O" ./configure --host=x86_64-linux-gnu 
> --build=x86_64-linux-gnu \
>                     --prefix=/usr/lib \
>                     --sysconfdir=/etc \
>                     --sharedstatedir=/var \
>                     --enable-socket \
>                     --enable-shared \
>                     --with-postgres \
>                     --with-mysql \
>                     --with-cxx \
>                     --with-x \
>                     --with-gdal \
>                     --with-freetype \
>                     --with-motif \
>                     --with-readline \
>                     --with-nls \
>                     --with-odbc \
>                   --with-sqlite \
>                   --enable-largefile \
>                     --with-freetype-includes=/usr/include/freetype2 \
>                     --with-tcltk-includes=/usr/include/tcl \
>                     --with-postgres-includes=/usr/include/postgresql \
>                     --with-mysql-includes=/usr/include/mysql \
>                   --with-proj-share=/usr/share/proj \
>                   
> --with-wxwidgets=/usr/lib/wx/config/gtk2-unicode-release-2.8 \
>                   --with-python=/usr/bin/python-config \
>                   --with-cairo
> checking host system type... x86_64-pc-linux-gnu
> checking for gcc... gcc
> checking whether the C compiler (gcc -Wall -g -O ) works... yes
> checking whether the C compiler (gcc -Wall -g -O ) is a cross-compiler... no
> checking whether we are using GNU C... yes
> checking whether gcc accepts -g... yes
> checking for Cygwin environment... no
> checking for mingw32 environment... no
> checking for executable suffix... no
> checking for full floating-point support... yes
> checking for pwd... /bin/pwd
> checking for source directory... /build/grass-9tcH5c/grass-6.4.1
> checking for build directory... /build/grass-9tcH5c/grass-6.4.1
> checking for MacOSX App... no
> checking for MacOSX architectures... no
> checking for MacOSX SDK... no
> checking how to build libraries... shared
> checking for ranlib... ranlib
> checking how to run the C preprocessor... gcc -E
> checking if 64bit support is requested... no
> checking if 64bit Sparc VIS support is requested... no
> checking system version (for dynamic loading)... Linux-2.6.32-5-amd64
> checking for dlopen in -ldl... yes
> checking for ar... ar
> checking for additional include dirs... 
> checking for additional library dirs... 
> checking for a BSD compatible install... /usr/bin/install -c
> checking for flex... flex
> checking for yywrap in -lfl... yes
> checking for bison... bison -y
> checking for ranlib... ranlib
> checking for ar... ar
> checking for env... env
> checking for perl... /usr/bin/perl
> checking for ANSI C header files... yes
> checking for limits.h... yes
> checking for termio.h... yes
> checking for termios.h... yes
> checking for unistd.h... yes
> checking for values.h... yes
> checking for f2c.h... no
> checking for g2c.h... no
> checking for sys/ioctl.h... yes
> checking for sys/mtio.h... yes
> checking for sys/resource.h... yes
> checking for sys/time.h... yes
> checking for sys/timeb.h... yes
> checking for sys/types.h... yes
> checking for sys/utsname.h... yes
> checking for libintl.h... yes
> checking for iconv.h... yes
> checking for langinfo.h... yes
> checking whether time.h and sys/time.h may both be included... yes
> checking for off_t... yes
> checking for uid_t in sys/types.h... yes
> checking return type of signal handlers... void
> checking for Cygwin environment... no
> checking for ftime... yes
> checking for gethostname... yes
> checking for gettimeofday... yes
> checking for lseek... yes
> checking for nice... yes
> checking for time... yes
> checking for uname... yes
> checking for seteuid... yes
> checking for setpriority... yes
> checking for setreuid... yes
> checking for setruid... no
> checking for drand48... yes
> checking for putenv... yes
> checking for setenv... yes
> checking for nanosleep... yes
> checking whether setpgrp takes no argument... yes
> checking for long long int... yes
> checking for W11... no
> checking for X... libraries , headers 
> checking for dnet_ntoa in -ldnet... no
> checking for dnet_ntoa in -ldnet_stub... no
> checking for gethostbyname... yes
> checking for connect... yes
> checking for remove... yes
> checking for shmat... yes
> checking for IceConnectionNumber in -lICE... yes
> checking whether to use Curses... yes
> checking for curses.h... yes
> checking curses.h WINDOW structure component... _maxy
> checking for initscr in -lncurses... yes
> checking for keypad in -lncurses... yes
> checking for gtty in -lcompat... no
> checking for gtty in -lbsd-compat... yes
> checking for library containing cuserid... none required
> checking for xdrmem_create... yes
> checking for asprintf... yes
> checking for atan... no
> checking for atan in -lm... yes
> checking for dlsym... no
> checking for dlsym in -ldl... yes
> checking for iconv... yes
> checking for socket... yes
> checking for location of zlib includes... 
> checking for zlib.h... yes
> checking for location of zlib library... 
> checking for deflate in -lz... yes
> checking for location of External PROJ.4 includes... 
> checking for proj_api.h... yes
> checking External PROJ.4 version... 470
> checking for location of External PROJ.4 library... 
> checking for pj_get_def in -lproj... yes
> checking for location of External PROJ.4 data files... /usr/share/proj
> checking for /usr/share/proj/epsg... yes
> checking for nad2bin... /usr/bin/nad2bin
> checking whether to use regex... yes
> checking for location of regex includes... 
> checking for regex.h... yes
> checking for location of regex library... 
> checking for regcomp... yes
> checking whether to use Readline... yes
> checking for location of Readline includes... 
> checking for readline/readline.h... yes
> checking for readline/history.h... yes
> checking for location of Readline library... 
> checking for readline in -lreadline... yes
> checking for add_history in -lhistory... yes
> checking whether to use JPEG... yes
> checking for location of JPEG includes... 
> checking for jpeglib.h... yes
> checking for location of JPEG library... 
> checking for jpeg_start_compress in -ljpeg... yes
> checking whether to use GDAL... yes
> checking for gdal-config... /usr/bin/gdal-config
> checking whether to use GEOS... no
> checking whether to use TIFF... yes
> checking for location of TIFF includes... 
> checking for tiffio.h... yes
> checking for location of TIFF library... 
> checking for TIFFOpen in -ltiff... yes
> checking whether to use PNG... yes
> checking for location of PNG includes... 
> checking for png.h... yes
> checking for location of PNG library... 
> checking for png_read_image in -lpng... yes
> checking whether to use PostgreSQL... yes
> checking for location of PostgreSQL includes... /usr/include/postgresql
> checking for libpq-fe.h... yes
> checking for location of PostgreSQL library... 
> checking for PQsetdbLogin in -lpq... yes
> checking for PQcmdTuples in -lpq... yes
> checking whether to use MySQL... yes
> checking for location of MySQL includes... /usr/include/mysql
> checking for mysql.h... yes
> checking for location of MySQL library... 
> checking for mysql_query in -lmysqlclient... yes
> checking for mysql_config... /usr/bin/mysql_config
> configure: warning: libmysqld not found
> checking for mysql_server_init... no
> checking whether to use SQLite... yes
> checking for location of SQLite includes... 
> checking for sqlite3.h... yes
> checking for location of SQLite library... 
> checking for sqlite3_open in -lsqlite3... yes
> checking whether to use FFMPEG... no
> checking whether to use OpenGL... yes
> checking for location of OpenGL includes... 
> checking for GL/gl.h... yes
> checking for GL/glu.h... yes
> checking for location of OpenGL library... 
> checking for glBegin in -lGL... yes
> checking for gluBeginCurve in -lGLU... yes
> checking for glXCreatePbuffer... yes
> checking for glXCreateGLXPixmap... yes
> checking whether to use Tcl/Tk... yes
> checking for location of Tcl/Tk includes... /usr/include/tcl
> checking for tcl.h... yes
> checking for tk.h... yes
> checking Tcl version... 8.5
> checking Tk version... 8.5
> checking for location of Tcl/Tk library... 
> checking for Tcl_Init in -ltcl... yes
> checking for Tk_MainWindow in -ltk... yes
> checking whether to use ODBC... yes
> checking for location of ODBC includes... 
> checking for sql.h... yes
> checking for location of ODBC library... 
> checking for SQLConnect in -lodbc... yes
> checking whether to use FFTW... yes
> checking for location of FFTW includes... 
> checking for fftw3.h... yes
> checking for location of FFTW library... 
> checking for fftw_execute in -lfftw3... yes
> checking whether to use BLAS... no
> checking whether to use LAPACK... no
> checking whether to use Motif... yes
> checking for location of Motif includes... 
> checking for Xm/Xm.h... yes
> checking for location of Motif library... 
> checking for XmStringCreate in -lXm... yes
> checking whether to use Cairo... yes
> checking for location of cairo includes... 
> checking for cairo.h... yes
> checking for location of cairo library... 
> checking for cairo linking flags... 
> checking for cairo_create... yes
> checking for cairo_xlib_surface_create_with_xrender_format... yes
> checking whether to use GLw... no
> checking whether to use FreeType... yes
> checking for location of FreeType includes... /usr/include/freetype2
> checking for ft2build.h... yes
> checking for location of FreeType library... 
> checking for FT_Init_FreeType in -lfreetype... yes
> checking whether to use NLS... yes
> checking for gettext... yes
> checking whether to use C++... yes
> checking for c++... c++
> checking whether the C++ compiler (c++   -Wl,--export-dynamic) works... yes
> checking whether the C++ compiler (c++   -Wl,--export-dynamic) is a 
> cross-compiler... no
> checking whether we are using GNU C++... yes
> checking whether c++ accepts -g... yes
> checking whether to use openDWG... no
> checking for special C compiler options needed for large files... no
> checking for _FILE_OFFSET_BITS value needed for large files... no
> checking for _LARGE_FILES value needed for large files... no
> checking for _LARGEFILE_SOURCE value needed for large files... no
> checking if system supports Large Files at all... yes
> checking whether to use Python... yes
> checking for python-config... /usr/bin/python-config
> checking for Python.h... yes
> Traceback (most recent call last):
>   File "/usr/bin/python-config", line 43, in <module>
>     flags.extend(getvar('CFLAGS').split())
> AttributeError: 'NoneType' object has no attribute 'split'
> checking whether to use wxWidgets... yes
> checking for wx-config... /usr/lib/wx/config/gtk2-unicode-release-2.8
> ./configure: 1: ./configure: /usr/lib/wx/config/gtk2-unicode-release-2.8: not 
> found
> configure: error: wxWidgets is required.
> checking wxWidgets version... not found
> make: *** [config.status] Error 1

The full build log is available from:
   http://people.debian.org/~lucas/logs/2012/01/12/grass_6.4.1-1_lsid64.buildlog

A list of current common problems and possible solutions is available at 
http://wiki.debian.org/qa.debian.org/FTBFS . You're welcome to contribute!

About the archive rebuild: The rebuild was done on about 50 AMD64 nodes
of the Grid'5000 platform, using a clean chroot.  Internet was not
accessible from the build systems.



--- End Message ---
--- Begin Message ---
Source: grass
Source-Version: 6.4.1-2

We believe that the bug you reported is fixed in the latest version of
grass, which is due to be installed in the Debian FTP archive:

grass-dev_6.4.1-2_i386.deb
  to main/g/grass/grass-dev_6.4.1-2_i386.deb
grass-doc_6.4.1-2_all.deb
  to main/g/grass/grass-doc_6.4.1-2_all.deb
grass_6.4.1-2.debian.tar.gz
  to main/g/grass/grass_6.4.1-2.debian.tar.gz
grass_6.4.1-2.dsc
  to main/g/grass/grass_6.4.1-2.dsc
grass_6.4.1-2_i386.deb
  to main/g/grass/grass_6.4.1-2_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 655...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Francesco Paolo Lovergine <fran...@debian.org> (supplier of updated grass 
package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Thu, 19 Jan 2012 14:04:52 +0100
Source: grass
Binary: grass grass-doc grass-dev
Architecture: source all i386
Version: 6.4.1-2
Distribution: unstable
Urgency: low
Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
Changed-By: Francesco Paolo Lovergine <fran...@debian.org>
Description: 
 grass      - Geographic Resources Analysis Support System
 grass-dev  - GRASS GIS development files
 grass-doc  - Geographic Resources Analysis Support System documentation
Closes: 655799
Changes: 
 grass (6.4.1-2) unstable; urgency=low
 .
   [ Hamish Bowman ]
   * Desktop icon cleanup.
   * Recommend wx; suggest gs, python-imaging, python-rpy2.
   * Remove more obsolete swig references.
   * grass-dev: further support for building add-ons.
 .
   [ Francesco Paolo Lovergine ]
   * Now reset debian/rules to use wx-config current alternative.
     (closes: #655799)
   * Now added python-support to manage compiled python modules.
     This makes lintian happy about package-installs-python-bytecode.
Checksums-Sha1: 
 4d420e32996cb0c004ada63eeabb8ff91a218d09 1852 grass_6.4.1-2.dsc
 e059f583f5a7d0bfd55f2a15f6a12ccd16613a76 21630 grass_6.4.1-2.debian.tar.gz
 d9957dba5d2ed48dce3e278f5cc83b42766f4022 14481254 grass-doc_6.4.1-2_all.deb
 5cc7d9b8b32ff68763915e2bc3884c32f15df0b9 13472146 grass_6.4.1-2_i386.deb
 9f888a92194f649367d95d24a5a10dd9780c19a1 215278 grass-dev_6.4.1-2_i386.deb
Checksums-Sha256: 
 da6127a58866d83988ffea5b2cec027bac969f28e1765136263c9be296ce30f3 1852 
grass_6.4.1-2.dsc
 10692709fa7e1d46bd673648f5886af8bae5e248c83a033cf4d0e5d7c7b3deb8 21630 
grass_6.4.1-2.debian.tar.gz
 eee23bccaf0499885c3847e974c101c74ba45794e9ae13c19e0a71ff9a88199b 14481254 
grass-doc_6.4.1-2_all.deb
 638607e21012bf00cafc5638c492d176020ea11d6e8a9f478febf79de56086ff 13472146 
grass_6.4.1-2_i386.deb
 b297be5538e7f99623acc12d234ae3529a35caa72568ca7fc28b8170a717a913 215278 
grass-dev_6.4.1-2_i386.deb
Files: 
 85b0dffdf30da9c8b555de7b71bc6515 1852 science optional grass_6.4.1-2.dsc
 bb0bf3aa70f4058b0058cdaf825d7b74 21630 science optional 
grass_6.4.1-2.debian.tar.gz
 c8ff5cd4d2f13e7ff86b1974d0e13be2 14481254 doc optional 
grass-doc_6.4.1-2_all.deb
 2ade598846e2b758d0153a28bb92d075 13472146 science optional 
grass_6.4.1-2_i386.deb
 3e53f94b9bdb670f8018eef58e390254 215278 devel optional 
grass-dev_6.4.1-2_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iEYEARECAAYFAk8ZeBAACgkQpFNRmenyx0cLagCeMvClp/O/0rfuDsJ29oBruf1n
O7QAoKNlUolbSKqVNrFvroFa5dBBXcZ0
=1jG1
-----END PGP SIGNATURE-----



--- End Message ---
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to