On Sat, Feb 04, 2012 at 11:25:29AM +0100, Giuseppe Bilotta wrote:
> Thanks for the reply. However, I do believe this is still a bug in the
> dependency specification, since if the hdf5-tools
>  package depends on the *latest* version of the libhdf5-1.8 package,
> then it should explicitly do so, to prevent installation
>  when the correct version cannot be installed because e.g. it is being
> held back automatically by some other package
> (paraview in my case).

This is an issue already raised. My own opinion is that any upgrade should
be done in a smooth way, allowing more than a version to cohexist at the same
time, until all rdepends are rebuilt. After that the old one could be dropped.
Sylvestre managed that differently by requiring explicit rebuilding and 
for a good reason, I think (but I did not have time to understand what that
reason is, and now it is anyway done, so it is quite pointless understanding
why and if a better approach was available). 

The result is what you are experiencing: all rdepends need to be rebuilt and in 
else you need to keep packages on hold until rebuilding completed for all of
them.  The dependencies specification per se is correct (and note that the 
changed in 1.8.4 -> 1.8.8)

Francesco P. Lovergine

Pkg-grass-devel mailing list

Reply via email to