The following commit has been merged in the master branch:
commit cb798830732943326fb806b73c6a62fb9136a4ae
Author: Francesco Paolo Lovergine <fran...@debian.org>
Date:   Fri Jan 20 14:49:23 2012 +0100

    Added ${python:Depends} dependency.

diff --git a/debian/control b/debian/control
index 67d82b0..00d9375 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,7 @@ Build-depends: flex, bison, libreadline-dev | libreadline6-dev, 
libncurses5-dev,
  libtiff4-dev, tcl-dev (>= 8.5), tk-dev (>= 8.5), libfftw3-dev, libxmu-dev, 
libglu1-mesa-dev | libglu1-xorg-dev, 
  libfreetype6-dev, autoconf2.13, autotools-dev, libgdal1-dev (>= 1.5.0), 
libproj-dev, proj-bin, libjpeg-dev, 
  libpng12-dev, libpq-dev, unixodbc-dev, doxygen, fakeroot, 
libmysqlclient15-dev, graphviz, libsqlite3-dev, python-wxgtk2.8,
- libcairo2-dev, libwxgtk2.8-dev, python-dev (>= 2.5), python-support (>= 0.7.1)
+ libcairo2-dev, libwxgtk2.8-dev, python-dev (>= 2.5), python-support (>= 0.90)
 Standards-Version: 3.9.2
 Build-Conflicts: wx2.6-headers
 Homepage: http://grass.osgeo.org/
@@ -17,8 +17,8 @@ Vcs-Git: git://git.debian.org/git/pkg-grass/grass.git
 Package: grass
 Section: science
 Architecture: any
-Depends: ${shlibs:Depends}, xterm | x-terminal-emulator, python (>= 2.5), 
python-numpy,
- python-opengl, python-wxgtk2.8, ${misc:Depends}
+Depends: ${shlibs:Depends}, xterm | x-terminal-emulator, python-numpy,
+ python-opengl, python-wxgtk2.8, ${misc:Depends}, ${python:Depends}
 Suggests: grass-doc, gdal-bin, proj-bin, e00compr, avce00, gpsbabel, gpstrans,
  gnuplot, xml2, wget | curl, netpbm
 Recommends: ghostscript, python-wxgtk2.8
diff --git a/debian/control.in b/debian/control.in
index 148da7c..d80a65d 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -7,7 +7,7 @@ Build-depends: flex, bison, libreadline-dev | libreadline6-dev, 
libncurses5-dev,
  libtiff4-dev, tcl-dev (>= 8.5), tk-dev (>= 8.5), libfftw3-dev, libxmu-dev, 
libglu1-mesa-dev | libglu1-xorg-dev, 
  libfreetype6-dev, autoconf2.13, autotools-dev, libgdal1-dev (>= 1.5.0), 
libproj-dev, proj-bin, libjpeg-dev, 
  libpng12-dev, libpq-dev, unixodbc-dev, doxygen, fakeroot, 
libmysqlclient15-dev, graphviz, libsqlite3-dev, python-wxgtk2.8,
- libcairo2-dev, libwxgtk2.8-dev, python-dev (>= 2.5), python-support (>= 0.7.1)
+ libcairo2-dev, libwxgtk2.8-dev, python-dev (>= 2.5), python-support (>= 0.90)
 Standards-Version: 3.9.2
 Build-Conflicts: wx2.6-headers
 Homepage: http://grass.osgeo.org/
@@ -17,8 +17,8 @@ Vcs-Git: git://git.debian.org/git/pkg-grass/grass.git
 Package: grass
 Section: science
 Architecture: any
-Depends: ${shlibs:Depends}, xterm | x-terminal-emulator, python (>= 2.5), 
python-numpy,
- python-opengl, python-wxgtk2.8, ${misc:Depends}
+Depends: ${shlibs:Depends}, xterm | x-terminal-emulator, python-numpy,
+ python-opengl, python-wxgtk2.8, ${misc:Depends}, ${python:Depends}
 Suggests: grass-doc, gdal-bin, proj-bin, e00compr, avce00, gpsbabel, gpstrans,
  gnuplot, xml2, wget | curl, netpbm
 Recommends: ghostscript, python-wxgtk2.8

-- 
Geographic Resources Analysis Support System

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to