Your message dated Wed, 7 Mar 2012 10:07:43 +0100
with message-id <>
and subject line Re: libnetcdf6 depending on libnetcdfc7 makes no sense.
has caused the Debian Bug report #662241,
regarding merkaartor: Fails to load netcdf lib
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact

Debian Bug Tracking System
Contact with problems
--- Begin Message ---
Package: merkaartor
Version: 0.17.2-5+b2
Severity: grave
Justification: renders package unusable

merkaartor: error while loading shared libraries: cannot open 
shared object file: No such file or directory

Dear Maintainer,
since upgrading libnetcdf, merkaartor fails to start.

dpkg -l libnetcdf6
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                                          Version       
ii  libnetcdf6                                                    1:4.1.3-2     
                                                An interface for scientific 
data access to large binary data (transitional package)

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (1, 
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages merkaartor depends on:
ii  libc6           2.13-27
ii  libexiv2-9      0.20-2.1
ii  libgcc1         1:4.7-20111217-2
ii  libgdal1-1.7.0  1.7.3-6+b3
ii  libgps20        3.4-2
ii  libproj0        4.7.0-1
ii  libproxy0       0.3.1-4+b3
ii  libqt4-network  4:4.8.0-1
ii  libqt4-svg      4:4.8.0-1
ii  libqt4-xml      4:4.8.0-1
ii  libqtcore4      4:4.8.0-1
ii  libqtgui4       4:4.8.0-1
ii  libqtwebkit4    2.2.0-3
ii  libspatialite3  3.0.1-1
ii  libsqlite3-0    3.7.10-1
ii  libstdc++6      4.7-20111217-2
ii  libzbar0        0.10+doc-7+b1
ii  zlib1g          1:1.2.6.dfsg-2

merkaartor recommends no packages.

Versions of packages merkaartor suggests:
pn  spatialite-bin  <none>

-- no debconf information

--- End Message ---
--- Begin Message ---
On Wed, Mar 07, 2012 at 09:50:34AM +0100, Bernd Zeimetz wrote:
> reassign 662241 libnetcdf6
> severity 662241 grave
> thanks
> Various packages depend on libnetcdf6 as various libraries were shipped
> in that package. Splitting the package and depending on the library
> packages which were merged in the old one is fine, too. But bumping the
> soname of one of the libraries *and* letting libnetcdf6 just depend on
> it breaks packages using the libraries - and I would guess it doesn't
> even show up as transition target. Please revert that change or remove
> libnetcdf6 after having a proper transition to the splitted packages.

It has been done since a few versions.

Francesco P. Lovergine

--- End Message ---
Pkg-grass-devel mailing list

Reply via email to