Your message dated Fri, 16 Mar 2012 10:32:28 +0000
with message-id <e1s8uss-0007b7...@franck.debian.org>
and subject line Bug#664129: fixed in gmt-gshhs 2.2.0-2
has caused the Debian Bug report #664129,
regarding gmt-gshhs-low and gmt-coast-low: error when trying to install together
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
664129: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=664129
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: gmt-coast-low,gmt-gshhs-low
Version: gmt-coast-low/1:2.1.1-1
Version: gmt-gshhs-low/2.2.0-1
Severity: serious
User: trei...@debian.org
Usertags: edos-file-overwrite

Date: 2012-03-15
Architecture: amd64
Distribution: sid

Hi,

automatic installation tests of packages that share a file and at the
same time do not conflict by their package dependency relationships has
detected the following problem:


WARNING: The following packages cannot be authenticated!
  libkeyutils1 libkrb5support0 libk5crypto3 libkrb5-3 libgssapi-krb5-2
  libsasl2-2 libldap-2.4-2 librtmp0 libssh2-1 libcurl3-gnutls libquadmath0
  libgfortran3 x11-common libice6 libsm6 libxau6 libxdmcp6 libxcb1 libx11-data
  libx11-6 libxext6 libxt6 libxmu6 libxpm4 libxaw7 bzip2 libhdf5-7 libnetcdfc7
  libgmt4 gmt gmt-coast-low gmt-gshhs-low

Extracting templates from packages: 93%
Extracting templates from packages: 100%
Preconfiguring packages ...
Authentication warning overridden.
Can not write log, openpty() failed (/dev/pts not mounted?)
Selecting previously unselected package libkeyutils1.
(Reading database ... 10557 files and directories currently installed.)
Unpacking libkeyutils1 (from .../libkeyutils1_1.5.2-2_amd64.deb) ...
Selecting previously unselected package libkrb5support0.
Unpacking libkrb5support0 (from 
.../libkrb5support0_1.10+dfsg~beta1-2_amd64.deb) ...
Selecting previously unselected package libk5crypto3.
Unpacking libk5crypto3 (from .../libk5crypto3_1.10+dfsg~beta1-2_amd64.deb) ...
Selecting previously unselected package libkrb5-3.
Unpacking libkrb5-3 (from .../libkrb5-3_1.10+dfsg~beta1-2_amd64.deb) ...
Selecting previously unselected package libgssapi-krb5-2.
Unpacking libgssapi-krb5-2 (from 
.../libgssapi-krb5-2_1.10+dfsg~beta1-2_amd64.deb) ...
Selecting previously unselected package libsasl2-2.
Unpacking libsasl2-2 (from .../libsasl2-2_2.1.25.dfsg1-4_amd64.deb) ...
Selecting previously unselected package libldap-2.4-2.
Unpacking libldap-2.4-2 (from .../libldap-2.4-2_2.4.28-1.1_amd64.deb) ...
Selecting previously unselected package librtmp0.
Unpacking librtmp0 (from .../librtmp0_2.4+20111222.git4e06e21-1_amd64.deb) ...
Selecting previously unselected package libssh2-1.
Unpacking libssh2-1 (from .../libssh2-1_1.2.8-2_amd64.deb) ...
Selecting previously unselected package libcurl3-gnutls.
Unpacking libcurl3-gnutls (from .../libcurl3-gnutls_7.24.0-1_amd64.deb) ...
Selecting previously unselected package libquadmath0.
Unpacking libquadmath0 (from .../libquadmath0_4.6.3-1_amd64.deb) ...
Selecting previously unselected package libgfortran3.
Unpacking libgfortran3 (from .../libgfortran3_4.6.3-1_amd64.deb) ...
Selecting previously unselected package x11-common.
Unpacking x11-common (from .../x11-common_1%3a7.6+12_all.deb) ...
Selecting previously unselected package libice6.
Unpacking libice6 (from .../libice6_2%3a1.0.7-2_amd64.deb) ...
Selecting previously unselected package libsm6.
Unpacking libsm6 (from .../libsm6_2%3a1.2.0-2_amd64.deb) ...
Selecting previously unselected package libxau6.
Unpacking libxau6 (from .../libxau6_1%3a1.0.6-4_amd64.deb) ...
Selecting previously unselected package libxdmcp6.
Unpacking libxdmcp6 (from .../libxdmcp6_1%3a1.1.0-4_amd64.deb) ...
Selecting previously unselected package libxcb1.
Unpacking libxcb1 (from .../libxcb1_1.8.1-1_amd64.deb) ...
Selecting previously unselected package libx11-data.
Unpacking libx11-data (from .../libx11-data_2%3a1.4.4-4_all.deb) ...
Selecting previously unselected package libx11-6.
Unpacking libx11-6 (from .../libx11-6_2%3a1.4.4-4_amd64.deb) ...
Selecting previously unselected package libxext6.
Unpacking libxext6 (from .../libxext6_2%3a1.3.0-3_amd64.deb) ...
Selecting previously unselected package libxt6.
Unpacking libxt6 (from .../libxt6_1%3a1.1.1-2_amd64.deb) ...
Selecting previously unselected package libxmu6.
Unpacking libxmu6 (from .../libxmu6_2%3a1.1.0-3_amd64.deb) ...
Selecting previously unselected package libxpm4.
Unpacking libxpm4 (from .../libxpm4_1%3a3.5.9-4_amd64.deb) ...
Selecting previously unselected package libxaw7.
Unpacking libxaw7 (from .../libxaw7_2%3a1.0.9-3_amd64.deb) ...
Selecting previously unselected package bzip2.
Unpacking bzip2 (from .../bzip2_1.0.6-1_amd64.deb) ...
Selecting previously unselected package libhdf5-7.
Unpacking libhdf5-7 (from .../libhdf5-7_1.8.8-9_amd64.deb) ...
Selecting previously unselected package libnetcdfc7.
Unpacking libnetcdfc7 (from .../libnetcdfc7_1%3a4.1.3-6_amd64.deb) ...
Selecting previously unselected package libgmt4.
Unpacking libgmt4 (from .../libgmt4_4.5.7-1_amd64.deb) ...
Selecting previously unselected package gmt.
Unpacking gmt (from .../archives/gmt_4.5.7-1_amd64.deb) ...
Selecting previously unselected package gmt-coast-low.
Unpacking gmt-coast-low (from .../gmt-coast-low_1%3a2.1.1-1_all.deb) ...
Selecting previously unselected package gmt-gshhs-low.
Unpacking gmt-gshhs-low (from .../gmt-gshhs-low_2.2.0-1_all.deb) ...
dpkg: error processing /var/cache/apt/archives/gmt-gshhs-low_2.2.0-1_all.deb 
(--unpack):
 trying to overwrite '/usr/share/gmt/coast/binned_border_c.cdf', which is also 
in package gmt-coast-low 1:2.1.1-1
configured to not write apport reports
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for man-db ...
Errors were encountered while processing:
 /var/cache/apt/archives/gmt-gshhs-low_2.2.0-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


This is a serious bug as it makes installation fail, and violates
sections 7.6.1 and 10.1 of the policy. An optimal solution would
consist in only one of the packages installing that file, and renaming
or removing the file in the other package. Depending on the
circumstances you might also consider Replace relations or file
diversions. If the conflicting situation cannot be resolved then, as a
last resort, the two packages have to declare a mutual
Conflict. Please take into account that Replaces, Conflicts and
diversions should only be used when packages provide different
implementations for the same functionality.

Here is a list of files that are known to be shared by both packages
(according to the Contents file for sid/amd64, which may be
slightly out of sync):

  /usr/share/gmt/coast/binned_GSHHS_c.cdf
  /usr/share/gmt/coast/binned_GSHHS_i.cdf
  /usr/share/gmt/coast/binned_GSHHS_l.cdf
  /usr/share/gmt/coast/binned_border_c.cdf
  /usr/share/gmt/coast/binned_border_i.cdf
  /usr/share/gmt/coast/binned_border_l.cdf
  /usr/share/gmt/coast/binned_river_c.cdf
  /usr/share/gmt/coast/binned_river_i.cdf
  /usr/share/gmt/coast/binned_river_l.cdf

This bug has been filed against both packages. If you, the maintainers of
the two packages in question, have agreed on which of the packages will
resolve the problem please reassign the bug to that package. You may then
also register in the BTS that the other package is affected by the bug.

-Ralf.

PS: for more information about the detection of file overwrite errors
of this kind see http://edos.debian.net/file-overwrites/.



--- End Message ---
--- Begin Message ---
Source: gmt-gshhs
Source-Version: 2.2.0-2

We believe that the bug you reported is fixed in the latest version of
gmt-gshhs, which is due to be installed in the Debian FTP archive:

gmt-gshhs-full_2.2.0-2_all.deb
  to main/g/gmt-gshhs/gmt-gshhs-full_2.2.0-2_all.deb
gmt-gshhs-high_2.2.0-2_all.deb
  to main/g/gmt-gshhs/gmt-gshhs-high_2.2.0-2_all.deb
gmt-gshhs-low_2.2.0-2_all.deb
  to main/g/gmt-gshhs/gmt-gshhs-low_2.2.0-2_all.deb
gmt-gshhs_2.2.0-2.debian.tar.gz
  to main/g/gmt-gshhs/gmt-gshhs_2.2.0-2.debian.tar.gz
gmt-gshhs_2.2.0-2.dsc
  to main/g/gmt-gshhs/gmt-gshhs_2.2.0-2.dsc



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 664...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Francesco Paolo Lovergine <fran...@debian.org> (supplier of updated gmt-gshhs 
package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Fri, 16 Mar 2012 11:11:16 +0100
Source: gmt-gshhs
Binary: gmt-gshhs-low gmt-gshhs-high gmt-gshhs-full
Architecture: source all
Version: 2.2.0-2
Distribution: unstable
Urgency: low
Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
Changed-By: Francesco Paolo Lovergine <fran...@debian.org>
Description: 
 gmt-gshhs-full - Full resolution coastlines for the Generic Mapping Tools
 gmt-gshhs-high - High resolution coastlines for the Generic Mapping Tools
 gmt-gshhs-low - Low resolution coastlines for the Generic Mapping Tools
Closes: 664129
Changes: 
 gmt-gshhs (2.2.0-2) unstable; urgency=low
 .
   * Fixed a silly typo in old the package name in debian/control.
     (closes: #664129)
Checksums-Sha1: 
 020b127f73504e66084026c7dffa925de5325b4e 1380 gmt-gshhs_2.2.0-2.dsc
 674edb16db7fc8d30dd85baa2dec477359192e13 2194 gmt-gshhs_2.2.0-2.debian.tar.gz
 325a0c34c50b1ded8e1ac2110432fc606ad9daee 5024438 gmt-gshhs-low_2.2.0-2_all.deb
 cdae399572563f0b8973b69477d416252e03b292 13000772 
gmt-gshhs-high_2.2.0-2_all.deb
 82f8a92b3e0af77bab27c70576a70122f5a85fb9 49779680 
gmt-gshhs-full_2.2.0-2_all.deb
Checksums-Sha256: 
 f5286c33e5f3e467ad289c91266a6544931cd8a4de853a5597639333d1a4b1d0 1380 
gmt-gshhs_2.2.0-2.dsc
 2bee579a79b4a4b72053cd6742e06733198cb957bf8cf4f5f2d98e57806ff9ec 2194 
gmt-gshhs_2.2.0-2.debian.tar.gz
 efb6912e4f00daedd319388b0f3ec8de153ff6776a7215cab248076d4d51a5d9 5024438 
gmt-gshhs-low_2.2.0-2_all.deb
 a9eac5a3454511e6d11396479ce029b5a7d57fff9ba61ba753049bb894654688 13000772 
gmt-gshhs-high_2.2.0-2_all.deb
 5db9b9e5bee8d61c230b2c2f5bee1022850b8846fb15246d43734988074bcbe5 49779680 
gmt-gshhs-full_2.2.0-2_all.deb
Files: 
 21c209353aa32c9db2659bf0e954911c 1380 misc extra gmt-gshhs_2.2.0-2.dsc
 281290d0c4ede85975fb285d5c79c042 2194 misc extra 
gmt-gshhs_2.2.0-2.debian.tar.gz
 6148a754e07cb6c6973d2d0d25e7d56e 5024438 misc extra 
gmt-gshhs-low_2.2.0-2_all.deb
 0b8e6f41cdd5fc32c2fb0bb00b2ba9e3 13000772 misc extra 
gmt-gshhs-high_2.2.0-2_all.deb
 74ee4569c1a0898566d1c717ebe6f0f9 49779680 misc extra 
gmt-gshhs-full_2.2.0-2_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iEYEARECAAYFAk9jE3QACgkQpFNRmenyx0enLACg1r/U3k7ruAReY8PJuVei9DSn
hIkAn2ECyy5h3XuKH8zC0HBhSa4Uf+5a
=Dy5/
-----END PGP SIGNATURE-----



--- End Message ---
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to