Package: libkml
Version: 1.3.0~r863-4
Severity: important
Tags: patch
User: debian-h...@lists.debian.org
Usertags: hurd

Hi,

currently[1], libkml does not compile on GNU/Hurd.

There are two problems (fixed by the attached hurd.diff patch):
- third_party/googletest-r108/src/gtest-filepath.cc:
  unconditional PATH_MAX usage; patched with a simple #define, since
  the code is just an (old) copy of google-test (and newer versions of
  gtest compile fine on Hurd)
- configure.ac:
  set PLATFORM=linux (as done also by kFreeBSD) to properly link to
  java and python stuff

Note the patch must be put in debian/patches/series right after
kfreebsd.diff and before automake.diff, and reautoconfiscated.diff has
to be updated (in configure).

[1] 
https://buildd.debian.org/status/fetch.php?pkg=libkml&arch=hurd-i386&ver=1.3.0%7Er863-4&stamp=1331819200

Thanks,
-- 
Pino
--- a/third_party/googletest-r108/src/gtest-filepath.cc
+++ b/third_party/googletest-r108/src/gtest-filepath.cc
@@ -52,6 +52,10 @@
 
 #include <gtest/internal/gtest-string.h>
 
+#ifndef PATH_MAX
+# define PATH_MAX 4096
+#endif
+
 namespace testing {
 namespace internal {
 
--- a/configure.ac
+++ b/configure.ac
@@ -27,7 +27,7 @@ dnl Which platform are we building on?
 PLATFORM=
 SHLIBSUFFIX=
 case "`uname -s`" in
-	Linux|GNU/kFreeBSD)	PLATFORM=linux
+	Linux|GNU/kFreeBSD|GNU)	PLATFORM=linux
 		SHLIBSUFFIX="so"
 	;;
 	Darwin)	PLATFORM=darwin
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to