Your message dated Tue, 15 May 2012 09:49:05 +0000
with message-id <e1suenn-0005vp...@franck.debian.org>
and subject line Bug#667063: fixed in h5utils 1.12.1-2
has caused the Debian Bug report #667063,
regarding h5utils: Adjust for the new octave package version 3.6.1
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
667063: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=667063
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: src:h5utils
Version: 1.12.1-1
Severity: important

The current version of h5utils build-depends on octave3.2-headers.  This
later package will be removed from unstable once the transition to the
new version of octave (currently 3.6.1) will be completed (see the wiki
page of the DOG [1]).

Simply changing the build-dependency from octave3.2-headers to
liboctave-dev fixes the issue.

Two additional comments, that are not really related to the bug reported
here but are worth mentioning (tell me if you prefer that I file
separated bug reports for the points below):

1) You might add "Suggests: octave" to h5utils.  This would give an
indication to the users that there is an Octave plugin included in the
package.

2) On my i386 system, the h5read.oct file is installed in:

    /usr/lib/i386-linux-gnu/octave/3.6.1/site/oct/i486-pc-linux-gnu/

Notice that this is a versioned path.  This means that the script will
not be in the Octave path if the octave package is upgraded upstream
(unless the user explicitly include it via addpath).  Actually, the
directory above is reserved for the pristine Octave files, not really
appropriate for plugins.

This path is obtained by the following code in configure.ac:

    OCT_INSTALL_DIR=`octave-config --oct-site-dir
    
Plugins should be installed in one of the following paths (the example
below is shown is for the i386 architeture):

    $ octave-config --print LOCALOCTFILEDIR
    /usr/lib/i386-linux-gnu/octave/site/oct/i486-pc-linux-gnu
    $ octave-config --print LOCALAPIOCTFILEDIR
    /usr/lib/i386-linux-gnu/octave/site/oct/api-v48+/i486-pc-linux-gnu
    
Note that the last one has the API number, which may be (or not) a good
thing.

Rafael

[1] http://wiki.debian.org/Teams/DebianOctaveGroup

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (700, 'testing'), (650, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 3.2.0-2-686-pae (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Rafael



--- End Message ---
--- Begin Message ---
Source: h5utils
Source-Version: 1.12.1-2

We believe that the bug you reported is fixed in the latest version of
h5utils, which is due to be installed in the Debian FTP archive:

h5utils_1.12.1-2.diff.gz
  to main/h/h5utils/h5utils_1.12.1-2.diff.gz
h5utils_1.12.1-2.dsc
  to main/h/h5utils/h5utils_1.12.1-2.dsc
h5utils_1.12.1-2_i386.deb
  to main/h/h5utils/h5utils_1.12.1-2_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 667...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Francesco Paolo Lovergine <fran...@debian.org> (supplier of updated h5utils 
package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Tue, 15 May 2012 11:13:14 +0200
Source: h5utils
Binary: h5utils
Architecture: source i386
Version: 1.12.1-2
Distribution: unstable
Urgency: low
Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
Changed-By: Francesco Paolo Lovergine <fran...@debian.org>
Description: 
 h5utils    - HDF5 files visualization tools
Closes: 612754 650488 667063
Changes: 
 h5utils (1.12.1-2) unstable; urgency=low
 .
   * Fixed a FTBS with libpng 1.5: patch png1.5.
     (closes: #650488)
   * Fixed b-d on new octave -dev package for octave transition.
     (closes: #667063)
   * Now depending on current hdf5 -dev package.
   * Dropped versioned name dep for libmatheval -dev b-d.
     (closes: #612754)
Checksums-Sha1: 
 4d0464e53250349dcad2be2d796cf0a577dcfd68 1366 h5utils_1.12.1-2.dsc
 b66c42e9a1d4bdabdd9b0ce6373f3b3717b6e868 5780 h5utils_1.12.1-2.diff.gz
 3fbb5fbb0dff2247605e2c475121380259d1d1d4 280068 h5utils_1.12.1-2_i386.deb
Checksums-Sha256: 
 748fafb023d9b8aee55f0f7a162b6421618c3b782e52695c2673edeaf673ad11 1366 
h5utils_1.12.1-2.dsc
 45b0c2b6d623ed800477a8b5fffb6c545fdb0c2d62a587129a8159e52be11748 5780 
h5utils_1.12.1-2.diff.gz
 e1c33c580a62f82dd7bdc71a246c708cc25b5f43c30507acfca00f63b82647fd 280068 
h5utils_1.12.1-2_i386.deb
Files: 
 7e1bcb2a115bb72d502d4427811d50cc 1366 science optional h5utils_1.12.1-2.dsc
 d0c7758cfb8504f4a43e363b9c57f3c1 5780 science optional h5utils_1.12.1-2.diff.gz
 97ddf4ef812d2ea5ab38bfd350c824f6 280068 science optional 
h5utils_1.12.1-2_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iEYEARECAAYFAk+yJMAACgkQpFNRmenyx0eDNACgoRucNHYtb+HrfSmb9p4blPT5
TbYAn1EcPrlX1RiqLyedrdL/M8VRjUHh
=ic6X
-----END PGP SIGNATURE-----



--- End Message ---
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to