Package: src:qgis
Version: 1.7.4+1.7.5~20120320-1
Severity: serious
Tags: sid wheezy
User: debian-...@lists.debian.org
Usertags: ftbfs-gcc-4.7
X-Debbugs-Cc: debian-...@lists.debian.org
Justification: fails to build from source (but built successfully in the
past)

Hi,

qgis fails to build on arches that now have gcc-4.7 as default (the
successful build on amd64 recently was still using gcc-4.6 at the time):

> [ 14%] Building CXX object 
> src/core/CMakeFiles/qgis_core.dir/spatialindex/tools/TemporaryFile.cc.o
> /build/buildd-qgis_1.7.4+1.7.5~20120320-1+b1-i386-O84wRU/qgis-1.7.4+1.7.5~20120320/src/core/spatialindex/tools/TemporaryFile.cc:
>  In constructor 'Tools::TemporaryFile::TemporaryFile()':
> /build/buildd-qgis_1.7.4+1.7.5~20120320-1+b1-i386-O84wRU/qgis-1.7.4+1.7.5~20120320/src/core/spatialindex/tools/TemporaryFile.cc:52:13:
>  error: 'close' was not declared in this scope
> /build/buildd-qgis_1.7.4+1.7.5~20120320-1+b1-i386-O84wRU/qgis-1.7.4+1.7.5~20120320/src/core/spatialindex/tools/TemporaryFile.cc:
>  In member function 'void Tools::TemporaryFile::storeNextObject(long unsigned 
> int, const byte*)':
> /build/buildd-qgis_1.7.4+1.7.5~20120320-1+b1-i386-O84wRU/qgis-1.7.4+1.7.5~20120320/src/core/spatialindex/tools/TemporaryFile.cc:92:15:
>  error: 'close' was not declared in this scope
> make[3]: *** 
> [src/core/CMakeFiles/qgis_core.dir/spatialindex/tools/TemporaryFile.cc.o] 
> Error 1
> make[3]: Leaving directory 
> `/build/buildd-qgis_1.7.4+1.7.5~20120320-1+b1-i386-O84wRU/qgis-1.7.4+1.7.5~20120320/debian/build'
> make[2]: *** [src/core/CMakeFiles/qgis_core.dir/all] Error 2

Regards,
-- 
Steven Chamberlain
ste...@pyro.eu.org



_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to