Your message dated Fri, 01 Jun 2012 07:18:36 +0000
with message-id <e1sam84-0006oq...@franck.debian.org>
and subject line Bug#615667: fixed in grass 6.4.2-1
has caused the Debian Bug report #615667,
regarding grass: Use xdg-open for GRASS_HTML_BROWSER when available
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
615667: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=615667
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: grass
Version: 6.4.0-2
Severity: wishlist
Tags: patch

When xdg-open is available it would be good to use it for GRASS_HTML_BROWSER
instead of x-www-browser.  The x-www-browser alternate is system-wide, while
xdg-open will use the browser the user has configured in their DE (eg: in
Preferred Applications in GNOME).

The attached git commit changes the www-browser patch to prefer xdg-open over
x-www-browser when available.


-- System Information:
Debian Release: squeeze/sid
  APT prefers natty-updates
  APT policy: (500, 'natty-updates'), (500, 'natty-security'), (500, 'natty')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.38-5-generic (SMP w/2 CPU cores)
Locale: LANG=en_AU.utf8, LC_CTYPE=en_AU.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
>From 596d2d56a70f76d5b5d43d50d722ad16677bee5c Mon Sep 17 00:00:00 2001
From: Thibault Lemaitre <thibault.lemai...@laposte.net>
Date: Mon, 28 Feb 2011 11:04:59 +1100
Subject: [PATCH] Use xdg-open for GRASS_HTML_BROWSER when available.

---
 debian/patches/www-browser |   15 ++++++++-------
 1 files changed, 8 insertions(+), 7 deletions(-)

diff --git a/debian/patches/www-browser b/debian/patches/www-browser
index e814734..06d36e6 100644
--- a/debian/patches/www-browser
+++ b/debian/patches/www-browser
@@ -1,8 +1,8 @@
 Index: grass/lib/init/init.sh
 ===================================================================
---- grass.orig/lib/init/init.sh        2011-02-14 17:15:01.000000000 +0100
-+++ grass/lib/init/init.sh     2011-02-14 17:28:01.000000000 +0100
-@@ -325,53 +325,11 @@
+--- grass.orig/lib/init/init.sh        2011-02-28 10:59:35.514747971 +1100
++++ grass/lib/init/init.sh     2011-02-28 11:00:17.216340777 +1100
+@@ -325,53 +325,13 @@
  
  # try and find a web browser if one isn't already specified
  if [ ! "$GRASS_HTML_BROWSER" ] ; then
@@ -18,7 +18,11 @@ Index: grass/lib/init/init.sh
 -      iexplore="$SYSTEMDRIVE/Program Files/Internet Explorer/iexplore.exe"
 -      if [ -f "$iexplore" ] ; then
 -          GRASS_HTML_BROWSER=$iexplore
--      else
++      if [ -x /usr/bin/xdg-open ] ; then
++              GRASS_HTML_BROWSER=xdg-open
++      elif [ -x /usr/bin/x-www-browser ] ; then
++              GRASS_HTML_BROWSER=x-www-browser
+       else
 -          GRASS_HTML_BROWSER="iexplore"
 -      fi
 -
@@ -38,9 +42,6 @@ Index: grass/lib/init/init.sh
 -      done
 -      if [ -n "$GRASS_HTML_BROWSER" ] ; then
 -         break
-+      if [ -x /usr/bin/x-www-browser ] ; then
-+              GRASS_HTML_BROWSER=x-www-browser
-+      else 
 +              GRASS_HTML_BROWSER=true
        fi
 -      done
-- 
1.7.4.1


--- End Message ---
--- Begin Message ---
Source: grass
Source-Version: 6.4.2-1

We believe that the bug you reported is fixed in the latest version of
grass, which is due to be installed in the Debian FTP archive:

grass-core_6.4.2-1_i386.deb
  to main/g/grass/grass-core_6.4.2-1_i386.deb
grass-dev-doc_6.4.2-1_all.deb
  to main/g/grass/grass-dev-doc_6.4.2-1_all.deb
grass-dev_6.4.2-1_i386.deb
  to main/g/grass/grass-dev_6.4.2-1_i386.deb
grass-doc_6.4.2-1_all.deb
  to main/g/grass/grass-doc_6.4.2-1_all.deb
grass-gui_6.4.2-1_i386.deb
  to main/g/grass/grass-gui_6.4.2-1_i386.deb
grass_6.4.2-1.debian.tar.gz
  to main/g/grass/grass_6.4.2-1.debian.tar.gz
grass_6.4.2-1.dsc
  to main/g/grass/grass_6.4.2-1.dsc
grass_6.4.2-1_all.deb
  to main/g/grass/grass_6.4.2-1_all.deb
grass_6.4.2.orig.tar.gz
  to main/g/grass/grass_6.4.2.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 615...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Francesco Paolo Lovergine <fran...@debian.org> (supplier of updated grass 
package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Tue, 29 May 2012 17:23:07 +0200
Source: grass
Binary: grass grass-core grass-gui grass-doc grass-dev-doc grass-dev
Architecture: source all i386
Version: 6.4.2-1
Distribution: unstable
Urgency: low
Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
Changed-By: Francesco Paolo Lovergine <fran...@debian.org>
Description: 
 grass      - Geographic Resources Analysis Support System (GRASS GIS)
 grass-core - GRASS GIS core components
 grass-dev  - GRASS GIS development files
 grass-dev-doc - GRASS GIS Programmers' Manual
 grass-doc  - GRASS GIS user documentation
 grass-gui  - GRASS GIS graphical user interfaces
Closes: 615667 650361 671991
Changes: 
 grass (6.4.2-1) unstable; urgency=low
 .
   [ Hamish Bowman ]
   * Packaged new upstream version.
   * Reorganize binary packages, new: grass-core, grass-gui, grass-dev-doc.
   * Patch g.extension.sh to check for the needed grass-dev package.
   * Remove outdated cruft from debian/fixscripts.sh and debian/rules.
   * Install the full Programmers' Manual.
   * Use system's copy of jquery.js in the Programmers' Manual.
   * libmysqlclient-dev replaces libmysqlclient15-dev.
     (closes: #650361)
   * Use xdg-open for GRASS_HTML_BROWSER when available.
     (closes: #615667)
   * Policy bumped to 3.9.3, using metapackages archive section for 'grass'.
   * Fix g.extension.sh test for the grass-dev package.
   * Add patch to fix C++ FTBFS for gcc 4.7.0.
     (closes: #671991)
   * Support for dh_python2, byte-compile .py at postinst.
   * Clean up TODO list.
 .
   [ Francesco Paolo Lovergine ]
   * Moved to use TIFF 4.0.1 instead of the legacy flavor.
   * Moved to use libgdal-dev (introduced in 1.9+) b-d.
Checksums-Sha1: 
 dbc401b92f2467a8ae3c9f640ee372177c5895c6 2029 grass_6.4.2-1.dsc
 abe8ddf5eabb7a1d79db75d5f838b7ba2a2e3bb2 23652330 grass_6.4.2.orig.tar.gz
 78bc4efd3314d25deacd43935a851c7f0d97069f 26472 grass_6.4.2-1.debian.tar.gz
 c70b30599891d9537a1d1519f7562cb9623aedb7 14292 grass_6.4.2-1_all.deb
 a973ae90abdef08e4610e83f2d58fbc79c6d4518 6489062 grass-doc_6.4.2-1_all.deb
 74fac9c1326ef314a77394e121851127c0a574db 27093184 grass-dev-doc_6.4.2-1_all.deb
 c6a5e9a035fcc3aaeaf83b1cead19f8b4f16eafb 11194220 grass-core_6.4.2-1_i386.deb
 24c55c6c0f83f4e70805f20202ddba8be579b0d8 2366494 grass-gui_6.4.2-1_i386.deb
 f19baa3c62cae63ab8afaed3a4e7b8ed7e13bced 218022 grass-dev_6.4.2-1_i386.deb
Checksums-Sha256: 
 6c112c085c9082ce1bf55ffd0be4ebfcacc3dd6a0c908741e0a94a562b529ed8 2029 
grass_6.4.2-1.dsc
 a5cee9c95bebb25e66fd0383d4b34154b277513dde122e1d34610d3d0e3ff3f2 23652330 
grass_6.4.2.orig.tar.gz
 f113802d0b8e3631cd0b2a36a81ff1d22ced1de80abfd0eba6d0cb6ad999b7bb 26472 
grass_6.4.2-1.debian.tar.gz
 552e3666b6f484c06dd07ceb26d27b449ce6e4a4b5552343d79d0810cbdcc125 14292 
grass_6.4.2-1_all.deb
 ce6f361a9cc6d513bc140ce9d46a8320d26f38db811e3403130c27ffefd12bc7 6489062 
grass-doc_6.4.2-1_all.deb
 5c8b44b81122232cacd6471c37185e1478a08716f46e2d20c40a7cc2fc7338da 27093184 
grass-dev-doc_6.4.2-1_all.deb
 b4efd281eb0e5cbe647770030a006150a3e9b85dfd81c4ca3cddb5ba58e378aa 11194220 
grass-core_6.4.2-1_i386.deb
 28b5232745a099a85a38f3a670fd393f5a272e722f3ac453fea21b7b6b995944 2366494 
grass-gui_6.4.2-1_i386.deb
 98f9d96b509c62703aea0a2b3c61ce417f9c82de2a401dd1850f9b4cb798994b 218022 
grass-dev_6.4.2-1_i386.deb
Files: 
 f114aef8d12903f84856d47911efd942 2029 science optional grass_6.4.2-1.dsc
 38071bd3dd0fffa70152507e4f3a900e 23652330 science optional 
grass_6.4.2.orig.tar.gz
 f45517780d5997df1245ac585b25b921 26472 science optional 
grass_6.4.2-1.debian.tar.gz
 50fd428cda9db0c0b6fa4115cf4c5f1c 14292 metapackages optional 
grass_6.4.2-1_all.deb
 e8200cbb423f65f320797dd769dde08d 6489062 doc optional grass-doc_6.4.2-1_all.deb
 0b93c77b7f86c35e77bb650d958c873f 27093184 doc optional 
grass-dev-doc_6.4.2-1_all.deb
 39fe8fe720c394f4a9ac2ef232cf669d 11194220 science optional 
grass-core_6.4.2-1_i386.deb
 de3366f0ec7ea459c0659a0233854eda 2366494 science optional 
grass-gui_6.4.2-1_i386.deb
 c0f4c255222c0633ce7437c153d2a262 218022 devel optional 
grass-dev_6.4.2-1_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iEYEARECAAYFAk/GDIEACgkQpFNRmenyx0cfSwCgy26EWOXagdUqqSaQom4VePMk
O0cAn0hnwkSdbfz1J2NORDeUvGwJeIcN
=vXOT
-----END PGP SIGNATURE-----



--- End Message ---
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to