Volker Grabsch schrieb:
> Volker Grabsch schrieb:
> > I just succeeded in producing working Debian packages
> > for PostGIS 2.0.0 on Debian/Wheezy.
> [...]
> I also produced Debian Packages for PostgreSQL 9.2.

One more update: I simplified my work and enabled
support for topology stuff by using GEOS >= 3.3.2.

So this does no longer work with Debian/Wheezy but
needs Debian/Sid. (unless libgeos-3.3.3 from Debain/Sid
is installed manually into Debian/Wheezy)

Attached is my new set of patches. Build instructions
for Debian/Unstable:

----------------------------------------------------------
# Download packages
wget 
http://ftp.de.debian.org/debian/pool/main/p/postgis/postgis_1.5.3-2.debian.tar.gz
wget http://postgis.org/download/postgis-2.0.0.tar.gz

# Rename source tarball
mv postgis-2.0.0.tar.gz postgis_2.0.0.orig.tar.gz

# Unpack sources
tar xf postgis_2.0.0.orig.tar.gz
cd postgis-2.0.0
tar xf ../postgis_1.5.3-2.debian.tar.gz

# Apply patches
zcat ../debian-postgis-2.0.0-stable.patch.gz | patch -p1
zcat ../debian-postgis-2.0.0-hacks.patch.gz | patch -p1

# Switch to PostgreSQL 9.2beta (optional)
#zcat ../debian-postgis-2.0.0-pg-9.2.patch.gz | patch -p1

# Run build as root, because fakeroot doesn't work yet :-(
sudo dpkg-buildpackage
----------------------------------------------------------


There are still open issues, but it works quite well.
Any feedback would be great.


Regards,
Volker

-- 
Volker Grabsch
---<<(())>>---

Attachment: debian-postgis-2.0.0-stable.patch.gz
Description: Binary data

Attachment: debian-postgis-2.0.0-hacks.patch.gz
Description: Binary data

Attachment: debian-postgis-2.0.0-pg-9.2.patch.gz
Description: Binary data

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to