tags 684808 +patch
thanks

Lucas Nussbaum <lu...@lucas-nussbaum.net> writes:

> Source: mapserver
> Version: 6.0.1-3.1
> Severity: serious
> Tags: wheezy sid
> User: debian...@lists.debian.org
> Usertags: qa-ftbfs-20120814 qa-ftbfs
> Justification: FTBFS in wheezy on amd64
>
> Hi,
>
> During a rebuild of all packages in *wheezy*, your package failed to
> build on amd64.
>
> Relevant part:
>> gcc-4.6  -shared -o mapscript.so mapscript_wrap.o -L. -L/usr/lib -L. 
>> -Wl,-z,relro -rdynamic -Wl,-export-dynamic -fPIC   -L../.. -L. -lmapserver 
>> -L/usr/lib/x86_64-linux-gnu -lfreetype -lz -lgd -ljpeg 
>> -L/usr/lib/x86_64-linux-gnu -lfreetype -lz -lpng -lz -lXpm -lX11 -lexpat 
>> -lproj -ljpeg -lpng -lgif -L/usr/lib -lgdal -L/usr/lib -lpq 
>> -L/usr/lib/x86_64-linux-gnu -lcurl -L/usr/lib -lgeos_c -lpthread -lc -lfcgi 
>> -lz -L/usr/lib -lxml2 -lfribidi -lm -lstdc++ -lfreetype -lz -lcairo -lpng12  
>> -lruby1.8  -lpthread -lrt -ldl -lcrypt -lm   -lc
>> /usr/bin/ld: cannot find -lstdc++
>> collect2: ld returned 1 exit status
>
> The full build log is available from:
>    
> http://people.debian.org/~lucas/logs/2012/08/14/mapserver_6.0.1-3.1_wheezy.log
>
> A list of current common problems and possible solutions is available at 
> http://wiki.debian.org/qa.debian.org/FTBFS . You're welcome to contribute!
>
> About the archive rebuild: The rebuild was done on EC2 VM instances from
> Amazon Web Services, using a clean, minimal and up-to-date chroot. Every
> failed build was retried once to eliminate random failures.

This is caused by ruby1.8 forcing the use of gcc-4.6 and linking against
a C++ library. Adding a build-dep on libstdc++6-4.6-dev (or g++-4.6)
fixes the problem.

I was thinking of fixing this directly in the git repo, but apparently
that is messed up and doesn't contain the commits leading to 6.0.3-1. A
(trivial) patch is attached anyhow.

-- 
Arto Jantunen>

diff --git a/debian/control b/debian/control
index 73679f0..91ffced 100644
--- a/debian/control
+++ b/debian/control
@@ -10,7 +10,8 @@ Build-Depends: debhelper (>= 9), libcurl4-gnutls-dev, libpng-dev, zlib1g-dev (>=
  ruby1.8, ruby1.8-dev, ruby1.9.1, ruby1.9.1-dev,
  sharutils, libsdl1.2-dev, libfreetype6-dev, libx11-dev,
  libfcgi-dev, libxml2-dev, libogdi3.2-dev, libxslt1-dev, libpam0g-dev, libreadline-dev, 
- libfribidi-dev, libming-dev, libedit-dev, libepsilon-dev, libcairo2-dev
+ libfribidi-dev, libming-dev, libedit-dev, libepsilon-dev, libcairo2-dev,
+ libstdc++6-4.6-dev
 Build-Conflicts: libcurl3-openssl-dev
 Homepage: http://www.mapserver.org
 Vcs-Browser: http://git.debian.org/?p=pkg-grass/mapserver.git
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to