Your message dated Thu, 20 Sep 2012 16:19:41 +0000
with message-id <e1tejtz-0003tr...@franck.debian.org>
and subject line Bug#684433: fixed in gdal 1.9.0-3.1
has caused the Debian Bug report #684433,
regarding gdal-bin: FTBFS when ruby1.9.1 installed
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
684433: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=684433
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: gdal-bin
Version: 1.9.0-3+b1
Severity: serious
Justification: fails to build from source (but built successfully in the past)

Dear Maintainer,

gdal-bin fails to build if ruby1.9.1 is installed and /usr/bin/ruby
refers to /usr/bin/ruby1.9.1 (via alternatives).

Error is:
/usr/bin/make -f RubyMakefile.mk build
-e:1: Use RbConfig instead of obsolete and deprecated Config.
-e:1: Use RbConfig instead of obsolete and deprecated Config.
-e:1: Use RbConfig instead of obsolete and deprecated Config.
-e:1: Use RbConfig instead of obsolete and deprecated Config.
-e:1: Use RbConfig instead of obsolete and deprecated Config.
make[2]: entrant dans le répertoire « /tmp/gdal-1.9.0/swig/ruby »
/bin/bash /tmp/gdal-1.9.0/libtool --mode=compile --tag=CXX g++ -g -O2
-Wall  -fPIC -DPIC -I/tmp/gdal-1.9.0/port -I/tmp/gdal-1.9.0/gcore
-I/tmp/gdal-1.9.0/alg -I/tmp/gdal-1.9.0/ogr
-I/tmp/gdal-1.9.0/ogr/ogrsf_frmts -I/usr/include/ruby-1.9.1
-I/usr/include/ruby-1.9.1/x86_64-linux  -c gdal_wrap.cpp
libtool: compile:  g++ -g -O2 -Wall -fPIC -DPIC -I/tmp/gdal-1.9.0/port
-I/tmp/gdal-1.9.0/gcore -I/tmp/gdal-1.9.0/alg -I/tmp/gdal-1.9.0/ogr
-I/tmp/gdal-1.9.0/ogr/ogrsf_frmts -I/usr/include/ruby-1.9.1
-I/usr/include/ruby-1.9.1/x86_64-linux -c gdal_wrap.cpp  -fPIC -DPIC -o
.libs/gdal_wrap.o
gdal_wrap.cpp:856:18: fatal error: ruby.h: No such file or directory
compilation terminated.


If "ruby" is replaced with "ruby1.8" in debian/control and
swig/ruby/RubyMakefile.mk then the error disappears.


-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (700, 'unstable'), (600, 'testing'), (500, 'stable'), (1, 
'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-3-amd64 (SMP w/8 CPU cores)
Locale: LANG=fr_FR.utf8, LC_CTYPE=fr_FR.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages gdal-bin depends on:
ii  libarmadillo3          1:3.2.3+dfsg-1
ii  libc6                  2.13-35
ii  libcurl3-gnutls        7.27.0-1
ii  libdap11               3.11.1-11
ii  libdapclient3          3.11.1-11
ii  libdapserver7          3.11.1-11
ii  libepsilon0            0.9.1-2
ii  libexpat1              2.1.0-1
ii  libfreexl1             1.0.0b-1
ii  libgcc1                1:4.7.1-6
ii  libgdal1               1.9.0-3+b1
ii  libgeos-c1             3.3.3-1.1
ii  libgif4                4.1.6-9.1
ii  libhdf4-0-alt          4.2r4-13
ii  libhdf5-7 [libhdf5-7]  1.8.8-9
ii  libjasper1             1.900.1-13
ii  libjpeg8               8d-1
ii  libkml0                1.3.0~r863-4.1
ii  liblzma5               5.1.1alpha+20120614-1
ii  libmysqlclient18       5.5.24+dfsg-6
ii  libnetcdfc7            1:4.1.3-6
ii  libodbc1               2.2.14p2-5
ii  libogdi3.2             3.2.0~beta2-7
ii  libpng12-0             1.2.49-2
ii  libpoppler19           0.18.4-3
ii  libpq5                 9.1.4-3
ii  libproj0               4.7.0-2
ii  libspatialite3         3.1.0~rc2-1
ii  libsqlite3-0           3.7.13-1
ii  libstdc++6             4.7.1-6
ii  liburiparser1          0.7.5-1
ii  libxerces-c28          2.8.0+deb1-3
ii  odbcinst1debian2       2.2.14p2-5
ii  unixodbc               2.2.14p2-5
ii  zlib1g                 1:1.2.7.dfsg-13

gdal-bin recommends no packages.

Versions of packages gdal-bin suggests:
ii  python-gdal  1.9.0-3+b1

-- no debconf information

--- End Message ---
--- Begin Message ---
Source: gdal
Source-Version: 1.9.0-3.1

We believe that the bug you reported is fixed in the latest version of
gdal, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 684...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
gregor herrmann <gre...@debian.org> (supplier of updated gdal package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Tue, 18 Sep 2012 17:25:11 +0200
Source: gdal
Binary: libgdal1 libgdal1-dev libgdal-dev libgdal-doc gdal-bin python-gdal 
libgdal-perl libgdal-ruby1.8 libgdal-ruby
Architecture: source amd64 all
Version: 1.9.0-3.1
Distribution: unstable
Urgency: low
Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
Changed-By: gregor herrmann <gre...@debian.org>
Description: 
 gdal-bin   - Geospatial Data Abstraction Library - Utility programs
 libgdal-dev - Geospatial Data Abstraction Library - Development files
 libgdal-doc - Documentation for the Geospatial Data Abstraction Library
 libgdal-perl - Perl bindings to the Geospatial Data Abstraction Library
 libgdal-ruby - Ruby bindings to the Geospatial Data Abstraction Library
 libgdal-ruby1.8 - Ruby 1.8 bindings to the Geospatial Data Abstraction Library
 libgdal1   - Geospatial Data Abstraction Library
 libgdal1-dev - Geospatial Data Abstraction Library - Development files
 python-gdal - Python bindings to the Geospatial Data Abstraction Library
Closes: 684433
Changes: 
 gdal (1.9.0-3.1) unstable; urgency=low
 .
   * Non-maintainer upload.
   * Fix "FTBFS when ruby1.9.1 installed": force building with ruby1.8:
     set variables in debian/rules and new patch force-ruby1.8 to ruby1.8.
     Thanks to Cédric Boutillier for reviewing and testing this patch.
     (Closes: #684433)
Checksums-Sha1: 
 b98f3017623f85c9717d83e464fb54fc695e66f4 2913 gdal_1.9.0-3.1.dsc
 ca45f56ae6e58f8292533a0bd83a3a3304ddf077 1252503 gdal_1.9.0-3.1.debian.tar.gz
 397c623ed7c6075323cf7fe90791ddd61d634095 4924756 libgdal1_1.9.0-3.1_amd64.deb
 cca2ae857aac836cf65227e34510d918fb6cd268 6276550 
libgdal-dev_1.9.0-3.1_amd64.deb
 9b3408844ff8cb4f3afa5f8417f201b1c99bd77a 337194 gdal-bin_1.9.0-3.1_amd64.deb
 5501613b7e5b269762fa4281e8fc66e53d69fe6d 765996 python-gdal_1.9.0-3.1_amd64.deb
 87f28ce2fe40f1b6e67a188a0895d2a60af3d210 418560 
libgdal-perl_1.9.0-3.1_amd64.deb
 b09e0bdaa9c20fe95a91fc73901877af3e7d9f80 279138 
libgdal-ruby1.8_1.9.0-3.1_amd64.deb
 57e52edaafc53c82417f29e1aa24e583e811c979 103220 
libgdal-ruby_1.9.0-3.1_amd64.deb
 2288b3028724409f4883c310688551c8bc598269 103676 libgdal1-dev_1.9.0-3.1_all.deb
 c420090d1f17bb06869131c90519604d8d6163ba 2879106 libgdal-doc_1.9.0-3.1_all.deb
Checksums-Sha256: 
 a499bf13a41a641f467f0332813308c24bec88ffd90cbe2bde7fd9ff83925351 2913 
gdal_1.9.0-3.1.dsc
 26d3cab1d1d376798d5ef6dffe571742a2b759b57ea82e213467e8737a655ec9 1252503 
gdal_1.9.0-3.1.debian.tar.gz
 ea3f6a49c2a04385da691c31569851bd7a03d1ffedc6e4e0ad3d118e9273b87c 4924756 
libgdal1_1.9.0-3.1_amd64.deb
 cb8b90ca83ce535315eb3b0eb361e98b529e1588cd2002cce84726abcc54260f 6276550 
libgdal-dev_1.9.0-3.1_amd64.deb
 211a876064e9248f54406754488dfa54b7119d415523eebec1889f0f73c1aa95 337194 
gdal-bin_1.9.0-3.1_amd64.deb
 d370066862d57c46dbc9028acef443912d8dc644b03b166c95922786d5b9d7c9 765996 
python-gdal_1.9.0-3.1_amd64.deb
 75744424837073ee049b9847cbd0f9af884bac0b18c832cae857fe7bd72c3849 418560 
libgdal-perl_1.9.0-3.1_amd64.deb
 e38848cfd0c981e9fc4ec43d92594e421dd10bbfd7f29a8a54bcc9c5cd47cb46 279138 
libgdal-ruby1.8_1.9.0-3.1_amd64.deb
 d3c64dccb91ee07d39485592e5939fc5567d0f0d096357c06e7dcb8154411fda 103220 
libgdal-ruby_1.9.0-3.1_amd64.deb
 0d09e2d7692f652080e115050af2f46c180bdf9a37919b5049c22d985a7a5044 103676 
libgdal1-dev_1.9.0-3.1_all.deb
 b970f2cdd8f50f1a97565acb86383a5a8a231f969517965fcbcf822649c17a71 2879106 
libgdal-doc_1.9.0-3.1_all.deb
Files: 
 43218b9b8292616983e38b5404dd0a40 2913 science extra gdal_1.9.0-3.1.dsc
 c93b32df593911e152d0d84a0e7b9e5d 1252503 science extra 
gdal_1.9.0-3.1.debian.tar.gz
 9a335ebda3106f73cf1152f2c4a49a4d 4924756 libs extra 
libgdal1_1.9.0-3.1_amd64.deb
 0ab5dd355b917f25c6d33051be6d1d63 6276550 libdevel extra 
libgdal-dev_1.9.0-3.1_amd64.deb
 704855bb2ef44da72126a5c9018ebe58 337194 science extra 
gdal-bin_1.9.0-3.1_amd64.deb
 486c6c4b3afe52b21f7579c51713ac71 765996 python extra 
python-gdal_1.9.0-3.1_amd64.deb
 431356fe72775f79fd4bfa3b2c32b107 418560 perl extra 
libgdal-perl_1.9.0-3.1_amd64.deb
 11ccd6021bed84275e2292dd4edd64cf 279138 ruby extra 
libgdal-ruby1.8_1.9.0-3.1_amd64.deb
 e741302337a16945d377c59cd3865bae 103220 ruby extra 
libgdal-ruby_1.9.0-3.1_amd64.deb
 267384a6a82f0e8307339e9bfda2c935 103676 libdevel extra 
libgdal1-dev_1.9.0-3.1_all.deb
 4b587bb0a7de7a518943cb948ded6c5b 2879106 doc extra 
libgdal-doc_1.9.0-3.1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBCAAGBQJQWJcCAAoJELs6aAGGSaoGRnQP/1UxZOvUsZtxEL3vr/h+gnQP
Fqu+ZjFz3ZkwibpDKF2HFoH886luvGEmQDkrtyV5wxlTzUrTqLJaODoDV+z/0i+g
I37oxXS/+d9KNAKU6WykNKdYAj2Yfuy2lSLxZ8LvVWnKEXZRS6e8fkVeSvg/vcvK
7KQZvEZgRNE61MQJIsTypXcbnU2P1BYWuZuz1LlSSHMwhjyiCeu2Apd9SD1b2BxU
0RXUp4qObCOG7DILvAu9Mcg3z71+nuzuyyIbLMBuR1XrH/KY/xWkqnpgY/vtwB1m
8cG5SoIex6baf/JBSKYp9VnBt+rDca7RfhEgGAwsLBPIWlNMnRhj2YPWqdY1vuRg
YKU4cQ8bk+ICLSs72l/2k8+y/LuDzydb0HiatTiYAF3U9uzl6gbI/FBrsXJVEiqI
wveKv1m1tv0Co60VmimngZCJ6d/9UF6t/6ByG76LClfl4ZeSyXiGxUJ1z8B78fa/
s9dyR+vjtGKBQBsXXt8I5F1AlbXlTqFit0tcJRGga6jPHN6kNSoaEZS6+jhSF6RZ
xjS8Xrut+3gfwKdZFIAvks9P8udywhdORsIa3vY4M7dRt7u2DRyJZl3lNk2nft/H
CkBA4JOYNKxOjpp+WiwkxWW1dKKoUko85rW+IZi3GPFtlGpTczfViZB/KWUVNwJO
AzbgqYdCkBQ4SUc0dIUb
=p7tH
-----END PGP SIGNATURE-----

--- End Message ---
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to