Your message dated Sun, 6 Jan 2013 16:17:07 +0000
with message-id 
<CAPQ4b8m_FnqLmnhppa9=fpdhmnpfxx7mzyyoejvfbr7quss...@mail.gmail.com>
and subject line Re: [osgearth] Viewer does not work at all -- missing 
dependency on shared library?
has caused the Debian Bug report #640129,
regarding [osgearth] Viewer does not work at all -- missing dependency on 
shared library?
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
640129: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=640129
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: osgearth
Version: 2.0+dfsg-4
Severity: normal

--- Please enter the report below this line. ---

$ osgearth_viewer
osgearth_viewer: error while loading shared libraries: libdapserver.so.7: 
cannot open shared object file: No such file or directory

[...installing by hand...
Unpacking libdapserver7 (from .../libdapserver7_3.11.1-5_i386.deb) ...
Setting up libdapserver7 (3.11.1-5) ...]

$ osgearth_viewer 
osgearth_viewer: error while loading shared libraries: libdapclient.so.3: 
cannot open shared object file: No such file or directory

[...installing by hand...
Unpacking libdapserver7 (from .../libdapserver7_3.11.1-5_i386.deb) ...
Setting up libdapserver7 (3.11.1-5) ...]

After that and pointing to a model in osgdata example files, it works.

So I think that it's missing those dependencies, maybe in the Build-Depends 
already?


--- System information. ---
Architecture: i386
Kernel:       Linux 3.0.0-1-686-pae

Debian Release: wheezy/sid
  900 unstable        www.debian-multimedia.org 
  900 unstable        ftp.uk.debian.org 

--- Package information. ---
Depends                    (Version) | Installed
====================================-+-=============
libosgearth1              (>= 1.4-2) | 2.0+dfsg-4
ttf-liberation                       | 1.07.0-1
libc6                     (>= 2.1.3) | 2.13-18
libgcc1                 (>= 1:4.1.1) | 1:4.6.1-8
libopenscenegraph80                  | 3.0.0-2
libopenthreads14                     | 3.0.0-2
libstdc++6                  (>= 4.6) | 4.6.1-8


Package's Recommends field is empty.

Suggests           (Version) | Installed
============================-+-===========
osgearth-data                | 2.0+dfsg-4


-- 
Manuel A. Fernandez Montecelo <manuel.montez...@gmail.com>



--- End Message ---
--- Begin Message ---
Hi Aron,

2012/11/30 Aron Xu <happyaron...@gmail.com>:
> The missing library could be libdapclient3, can you try to install the
> package and see if it works?

I see that nobody uploaded a new version of osgearth since my report.

The problem was probably some other intermediate library not depending
on libdap{server7,client3} as appropriate, which has been fixed since
(now installing osgearth pulls those libraries fine).

Closing the bug now.


Cheers.
-- 
Manuel A. Fernandez Montecelo <manuel.montez...@gmail.com>

--- End Message ---
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to