The following commit has been merged in the ubuntu/lucid branch:
commit 20912a793e9df86830a0b469ff6c3dab940eff2a
Merge: f7794577c05c24adee4b524dc56132aaf78b8373 
4786692c6d524db24b558febed0bd77898786361
Author: Jerome Villeneuve Larouche <jlarou...@mapgears.com>
Date:   Thu Aug 23 17:37:21 2012 +0000

    Upstream 2.0.1 update
    Downgraded PostgreSQL to 8.4

diff --combined debian/changelog
index 5547504,88afb7e..0571fc7
--- a/debian/changelog
+++ b/debian/changelog
@@@ -1,8 -1,10 +1,18 @@@
- postgis (1.5.3-3~lucid1) lucid; urgency=low
++postgis (2.0.1-2~lucid1) lucid; urgency=low
 +
-   * Launchpad build for lucid
++  * Launchpad build for Lucid
++  * Downgraded PostgreSQL to 8.4
++  * Removed libpostgis-java
 +
-  -- Jerome Villeneuve Larouche <jlarou...@mapgears.com>  Fri, 08 Jun 2012 
18:07:34 +0000
++ -- Jerome Villeneuve Larouche <jlarou...@mapgears.com>  Thu, 23 Aug 2012 
17:31:12 +0000
++
+ postgis (2.0.1-1) unstable; urgency=low
+ 
+   * New upstream release, 2.0.1
+   * Removed old patches
+   * Added Makefile.comments patch
+ 
+  -- Jerome Villeneuve Larouche <jlarou...@mapgears.com>  Fri, 17 Aug 2012 
14:56:22 +0000
  
  postgis (1.5.3-2) unstable; urgency=low
  
diff --combined debian/control
index f18a869,ffc56a7..bced2cb
--- a/debian/control
+++ b/debian/control
@@@ -6,27 -6,28 +6,28 @@@ Uploaders: Stephen Frost <sfrost@debian
  Build-Depends: debhelper (>= 8), autotools-dev, flex, bison, libgeos-dev (>= 
3.1.1),
   libproj-dev (>= 4.5.0), libssl-dev, xsltproc, docbook, docbook-xsl,
   default-jdk, libpg-java, fastjar, libjts-java (>= 1.7), imagemagick,
-  libcunit1-dev, dblatex, libxml2-dev, libgtk2.0-dev, postgresql-server-dev-9.1
 - libcunit1-dev, dblatex, libxml2-dev, libgtk2.0-dev, 
postgresql-server-dev-9.1,
 - ant, libgdal-dev, postgresql-9.1
++ libcunit1-dev, dblatex, libxml2-dev, libgtk2.0-dev, 
postgresql-server-dev-8.4,
++ ant, libgdal-dev, postgresql-8.4
  Standards-Version: 3.9.2
  Homepage: http://postgis.refractions.net/
  Vcs-Browser: http://git.debian.org/?p=pkg-grass/postgis.git
  Vcs-Git: git://git.debian.org/git/pkg-grass/postgis.git
  
--Package: postgresql-9.1-postgis
++Package: postgresql-8.4-postgis
  Architecture: any
--Depends: ${shlibs:Depends}, postgis, postgresql-9.1, ${misc:Depends}
++Depends: ${shlibs:Depends}, postgis, postgresql-8.4, ${misc:Depends}
  Conflicts: postgis (<< 1.2.1)
--Description: Geographic objects support for PostgreSQL 9.1
++Description: Geographic objects support for PostgreSQL 8.4
   PostGIS adds support for geographic objects to the PostgreSQL 
object-relational
   database. In effect, PostGIS "spatially enables" the PostgreSQL server, 
   allowing it to be used as a backend spatial database for geographic 
information
   systems (GIS), much like ESRI's SDE or Oracle's Spatial extension. PostGIS
   follows the OpenGIS "Simple Features Specification for SQL".
   .
-- This package supports PostgreSQL 9.1.
++ This package supports PostgreSQL 8.4.
  
  Package: postgis
--Suggests: postgresql-9.1-postgis
++Suggests: postgresql-8.4-postgis
  Depends: ${shlibs:Depends}, ${misc:Depends}
  Architecture: any
  Description: Geographic objects support for PostgreSQL -- common files
@@@ -38,19 -39,19 +39,3 @@@
   .
   This package contains the PostGIS userland binaries, common files and
   documentation.
--
--Package: libpostgis-java
--Architecture: all
--Section: java
--Depends: libpg-java
--Suggests: postgresql-9.1-postgis, ${misc:Depends}
--Conflicts: libpostgis-jdbc, libpostgisjava, postgresql-postgis-java
--Replaces: libpostgis-jdbc, libpostgisjava, postgresql-postgis-java
--Description: Geographic objects support for PostgreSQL -- JDBC support
-- PostGIS adds support for geographic objects to the PostgreSQL 
object-relational
-- database. In effect, PostGIS "spatially enables" the PostgreSQL server, 
-- allowing it to be used as a backend spatial database for geographic 
information
-- systems (GIS), much like ESRI's SDE or Oracle's Spatial extension. PostGIS
-- follows the OpenGIS "Simple Features Specification for SQL".
-- .
-- This package contains JDBC support for PostGIS.
diff --combined debian/rules
index b133eb2,6673d08..c22aca4
--- a/debian/rules
+++ b/debian/rules
@@@ -51,7 -51,7 +51,7 @@@ clean
        dh_testroot
        [ -f doc/html/postgis.html.prev ] && mv doc/html/postgis.html.prev 
doc/html/postgis.html || true
        [ ! -f GNUmakefile ] || $(MAKE) distclean || true
-       [ ! -f java/jdbc/Makefile ] || $(MAKE) -C java/jdbc clean
+       $(MAKE) -C doc images-clean
        rm -f $(CURDIR)/debian/*.postinst $(CURDIR)/debian/*.postrm
        dh_clean 
  
@@@ -66,11 -66,7 +66,7 @@@ install-indep: build-inde
                --docdir=\$${prefix}/share/doc/postgis \
                --mandir=\$${prefix}/share/man \
                --infodir=\$${prefix}/share/info \
-               --with-pgconfig=/usr/lib/postgresql/9.1/bin/pg_config
-       # PostGIS JDBC (with debug support)
-       $(MAKE) -C java/jdbc clean
-       DEBUGJAR=postgis_debug.fastjar JAR=fastjar JAVAC=javac $(MAKE) -C 
java/jdbc jar
-       DEBUGJAR=postgis_debug.fastjar JAR=fastjar JAVAC=javac $(MAKE) -C 
java/jdbc install 
DESTDIR=$(CURDIR)/debian/libpostgis-java/usr/share/java/$(JAVA_PATH)
 -              --with-pgconfig=/usr/lib/postgresql/9.1/bin/pg_config \
++              --with-pgconfig=/usr/lib/postgresql/8.4/bin/pg_config \
        # regress target uses pushd/popd
        $(MAKE) SHELL=/bin/bash distclean
        dh_install -i
@@@ -83,48 -79,48 +79,48 @@@ install-arch: build-arc
        # Documentation and common files for PostGIS
        [ ! -f doc/html/postgis.html.prev ] && cp doc/html/postgis.html 
doc/html/postgis.html.prev || true
        
--      # PostGIS for PostgreSQL 9.1
++      # PostGIS for PostgreSQL 8.4
        ./configure \
                --host=$(DEB_HOST_GNU_TYPE) \
                --build=$(DEB_BUILD_GNU_TYPE) \
                --prefix=/usr \
                --with-docdir=$(CURDIR)/debian/postgis/usr/share/doc \
--              --exec-prefix=\$${prefix}/lib/postgresql/9.1 \
--              --datadir=\$${prefix}/share/postgresql-9.1-postgis \
++              --exec-prefix=\$${prefix}/lib/postgresql/8.4 \
++              --datadir=\$${prefix}/share/postgresql-8.4-postgis \
                --mandir=\$${prefix}/share/man \
                --infodir=\$${prefix}/share/info \
--              --with-pgconfig=/usr/lib/postgresql/9.1/bin/pg_config \
++              --with-pgconfig=/usr/lib/postgresql/8.4/bin/pg_config \
                --with-gui
        $(MAKE)
        $(MAKE) -C doc
--      $(MAKE) install DESTDIR=$(CURDIR)/debian/postgresql-9.1-postgis
-       $(MAKE) -C doc install \
-                       
PGSQL_DOCDIR=$(CURDIR)/debian/postgis/usr/share/doc/postgis \
-                       PGSQL_MANDIR=$(CURDIR)/debian/postgis/usr/share/man \
-                       
PGSQL_SHAREDIR=$(CURDIR)/debian/postgis/usr/share/postgresql/9.1
-       install -o root -g root doc/postgis_comments.sql \
-               
$(CURDIR)/debian/postgresql-9.1-postgis/usr/share/postgresql/9.1/contrib/.
-       install -o root -g root -d 
$(CURDIR)/debian/postgresql-9.1-postgis/usr/lib/postgis/$(VERSION)/postgres/9.1/lib
-       mv 
$(CURDIR)/debian/postgresql-9.1-postgis/usr/lib/postgresql/9.1/lib/postgis-$(MAJOR_VERSION).$(MINOR_VERSION).so
 \
-          
$(CURDIR)/debian/postgresql-9.1-postgis/usr/lib/postgis/$(VERSION)/postgres/9.1/lib/.
-       mv $(CURDIR)/debian/postgresql-9.1-postgis/usr/lib/postgresql/9.1/bin 
$(CURDIR)/debian/postgis/usr
++      $(MAKE) install DESTDIR=$(CURDIR)/debian/postgresql-8.4-postgis
+       $(MAKE) -C doc man-install \
+                       PGSQL_MANDIR=$(CURDIR)/debian/postgis/usr/share/man
+       $(MAKE) -C doc docs-install \
+                       
PGSQL_DOCDIR=$(CURDIR)/debian/postgis/usr/share/doc/postgis
+       install -m644 doc/postgis_comments.sql \
 -              
$(CURDIR)/debian/postgresql-9.1-postgis/usr/share/postgresql/9.1/contrib/.
 -      install -o root -g root -d 
$(CURDIR)/debian/postgresql-9.1-postgis/usr/lib/postgis/$(VERSION)/postgres/9.1/lib
 -      mv 
$(CURDIR)/debian/postgresql-9.1-postgis/usr/lib/postgresql/9.1/lib/postgis-$(MAJOR_VERSION).$(MINOR_VERSION).so
 \
 -         
$(CURDIR)/debian/postgresql-9.1-postgis/usr/lib/postgis/$(VERSION)/postgres/9.1/lib/.
 -      mv $(CURDIR)/debian/postgresql-9.1-postgis/usr/lib/postgresql/9.1/bin 
$(CURDIR)/debian/postgis/usr
++              
$(CURDIR)/debian/postgresql-8.4-postgis/usr/share/postgresql/8.4/contrib/.
++      install -o root -g root -d 
$(CURDIR)/debian/postgresql-8.4-postgis/usr/lib/postgis/$(VERSION)/postgres/8.4/lib
++      mv 
$(CURDIR)/debian/postgresql-8.4-postgis/usr/lib/postgresql/8.4/lib/postgis-$(MAJOR_VERSION).$(MINOR_VERSION).so
 \
++         
$(CURDIR)/debian/postgresql-8.4-postgis/usr/lib/postgis/$(VERSION)/postgres/8.4/lib/.
++      mv $(CURDIR)/debian/postgresql-8.4-postgis/usr/lib/postgresql/8.4/bin 
$(CURDIR)/debian/postgis/usr
        
--      # Create custom maint scripts: 9.1
++      # Create custom maint scripts: 8.4
        
        sed -e 's/@POSTGIS_VERSION@/$(VERSION)/' \
--          -e 's/@POSTGRES_VERSION@/9.1/' \
++          -e 's/@POSTGRES_VERSION@/8.4/' \
            -e 's/@SOVERSION@/$(MAJOR_VERSION).$(MINOR_VERSION)/' \
--          $(CURDIR)/debian/postgis-postgresql-generic.postinst.in 
>$(CURDIR)/debian/postgresql-9.1-postgis.postinst
++          $(CURDIR)/debian/postgis-postgresql-generic.postinst.in 
>$(CURDIR)/debian/postgresql-8.4-postgis.postinst
        
--      sed -e 's/@POSTGRES_VERSIONS@/9.1/' \
++      sed -e 's/@POSTGRES_VERSIONS@/8.4/' \
            -e 's/@SOVERSION@/$(MAJOR_VERSION).$(MINOR_VERSION)/' \
--          $(CURDIR)/debian/postgis-generic.postrm.in 
>$(CURDIR)/debian/postgresql-9.1-postgis.postrm
-       
++          $(CURDIR)/debian/postgis-generic.postrm.in 
>$(CURDIR)/debian/postgresql-8.4-postgis.postrm
+ 
        dh_install -s
        
--      # copy utils for 9.1
--      mkdir -p 
$(CURDIR)/debian/postgresql-9.1-postgis/usr/share/postgresql-9.1-postgis/utils
--      cp utils/*.pl utils/README 
$(CURDIR)/debian/postgresql-9.1-postgis/usr/share/postgresql-9.1-postgis/utils
++      # copy utils for 8.4
++      mkdir -p 
$(CURDIR)/debian/postgresql-8.4-postgis/usr/share/postgresql-8.4-postgis/utils
++      cp utils/*.pl utils/README 
$(CURDIR)/debian/postgresql-8.4-postgis/usr/share/postgresql-8.4-postgis/utils
  
  check: install-arch
        $(MAKE) check
@@@ -144,6 -140,7 +140,7 @@@ binary-common
        dh_compress 
        dh_fixperms
        dh_installdeb
+       dh_makeshlibs
        dh_shlibdeps
        dh_gencontrol
        dh_md5sums

-- 
PostGIS for PostgreSQL

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to