Hi Julien,

On Fri, Jan 18, 2013 at 11:10:13PM +0100, Julien Cristau wrote:
> Andreas, we can't remove packages that have rdeps.  Stable needs to be
> self-contained.

Sorry for this beginners mistake and the extra work to check for you.

I tried to give this package another shot but stumbled way earlier about
a FTBFS problem.  I created a fresh wheezy chroot and tried

$ debuild
dh build
   debian/rules override_dh_auto_configure
make[1]: Entering directory 
dh_auto_configure -Dlibspatialite -- \
                --enable-geos \
                --enable-proj \
checking for a BSD-compatible install... /usr/bin/install -c
checking geos_c.h usability... yes
checking geos_c.h presence... yes
checking for geos_c.h... yes
checking for library containing GEOSTopologyPreserveSimplify... no
configure: error: 'libgeos_c' is required but it doesn't seems to be installed 
on this system.
dh_auto_configure: ./configure --build=x86_64-linux-gnu --prefix=/usr 
--includedir=${prefix}/include --mandir=${prefix}/share/man 
--infodir=${prefix}/share/info --sysconfdir=/etc --localstatedir=/var 
--libexecdir=${prefix}/lib/spatialite --disable-maintainer-mode 
--disable-dependency-tracking --enable-geos --enable-proj 
--disable-geosadvanced returned exit code 1
make[1]: *** [override_dh_auto_configure] Error 2
make[1]: Leaving directory 
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2

So it seems that libgeos-dev is somehow broken but when I try

$ strings /usr/lib/libgeos_c.a | grep GEOSTopologyPreserveSimplify

it seems that the symbol that is missed by the configure script is
available in the library in question.  Before I might create more noise
and because I know there are frequent auto-build tests and so the
problem should have been detected earlier:  Am I missing something or
should I file another bug report against src:spatialite ?

Kind regards



Pkg-grass-devel mailing list

Reply via email to