The following commit has been merged in the master branch:
commit 4c3c12ad6b97437d12c3ce1c0d1092e89c33673d
Merge: 1ca4c51e16daf17b6dd9feaca39ebd271a8820b5 
67463fe45c7636386fa8a217701ae8b0c0dd506d
Author: Francesco P. Lovergine <france...@lovergine.com>
Date:   Fri Mar 29 19:48:18 2013 +0100

    Merge branch 'master' of ssh://git.debian.org/git/pkg-grass/gdal
    
    Conflicts:
        debian/changelog
        debian/control
        debian/rules

diff --combined debian/changelog
index 9112fde,524db0a..d95cb37
--- a/debian/changelog
+++ b/debian/changelog
@@@ -1,10 -1,45 +1,52 @@@
- gdal (1.9.0-1~exp4) experimental; urgency=low
++gdal (1.9.2-1~exp2) experimental; urgency=low
 +
 +  * Moved to new LIBKML driver instead of the old KML one. It has a much
 +    better support for complex KML files.
 +
 + -- Francesco Paolo Lovergine <fran...@debian.org>  Sun, 04 Mar 2012 11:39:57 
+0100
 +
+ gdal (1.9.2-1~exp1) experimental; urgency=low
+ 
+   [ Jerome Villeneuve Larouche ]
+   * New upstream release
+ 
+   [ Francesco Paolo Lovergine ]
+   * Reintroducing libgdal1-dev as a transitional package to allow r-deps
+     to build in any environment.
+   * Removed old dependency on libcurl3-dev for libgdal-dev and added a 
+     preferred dep on libcurl4-gnutls-dev to make lintian happy.
+   * Added build-{arch|indep} targets in debian/rules.
+   * Fixed a bit debian/changelog for latest changes. 
+   * Now using libxerces-c-dev as dependency for current library version.
+   * Policy bumped to 3.9.4. No special changes required.
+ 
+  -- Francesco Paolo Lovergine <fran...@debian.org>  Fri, 29 Mar 2013 10:38:40 
+0100
+ 
+ gdal (1.9.0-1) unstable; urgency=low
+ 
+   * Ready for sid, starting transition.
+   * All symfiles updated to latest builds.
+   * Added dh_numpy call in debian/rules to depend on numpy ABI.
+   * Policy bumped to 3.9.3, no changes required.
+ 
+  -- Francesco Paolo Lovergine <fran...@debian.org>  Mon, 07 May 2012 15:04:42 
+0200
+ 
+ gdal (1.9.0-1~exp5) experimental; urgency=low
+ 
+   * Added a build-dep on liburiparser-dev to satisfy configure test. Without
+     that GDAL reverts to the old KML support anyway :-(.
+   * Explicitly enabled Armadillo and LZMA supports.
+   * OpenJPEG is enabled in debian/rules, but still unsupported because current
+     library is obsolete. GDAL requires at least 1.4.
+ 
+  -- Francesco Paolo Lovergine <fran...@debian.org>  Mon, 05 Mar 2012 17:44:59 
+0100
+ 
+ gdal (1.9.0-1~exp4) experimental; urgency=low
+ 
+   * Moving from old KML to new libkml based.
+ 
+  -- Francesco Paolo Lovergine <fran...@debian.org>  Fri, 02 Mar 2012 14:44:23 
+0100
+ 
  gdal (1.9.0-1~exp3) experimental; urgency=low
  
    * Added b-deps and enabled a few new supports: 
diff --combined debian/control
index 8a7b502,2b6815a..8975b90
--- a/debian/control
+++ b/debian/control
@@@ -5,16 -5,18 +5,17 @@@ Maintainer: Debian GIS Project <pkg-gra
  Uploaders: Francesco Paolo Lovergine <fran...@debian.org>
  Build-Depends: debhelper (>= 8), zlib1g-dev, libnetcdf-dev (>= 1:4.0.0),
   libjasper-dev, libpng-dev, libjpeg-dev, libgif-dev,
-  libhdf4-alt-dev, libhdf5-serial-dev (>= 1.6.6), libpq-dev, libxerces-c2-dev, 
unixodbc-dev (>= 2.2.11),
-  python-numpy, doxygen, d-shlibs, libgeos-dev, libmysqlclient-dev, 
python-all-dev (>= 2.6.6-3~), 
+  libhdf4-alt-dev, libhdf5-serial-dev (>= 1.6.6), libpq-dev, libxerces-c-dev, 
unixodbc-dev (>= 2.2.11),
+  python-numpy, doxygen, d-shlibs, libgeos-dev, libmysqlclient-dev, 
python-all-dev (>= 2.6.6-3~),
   libcurl4-gnutls-dev, libsqlite3-dev, libogdi3.2-dev,
-  ruby, ruby1.8-dev, chrpath, swig, patch, libexpat1-dev, libproj-dev,
+  ruby1.8, ruby1.8-dev, chrpath, swig, patch, libexpat1-dev, libproj-dev,
   libdap-dev, libxml2-dev, libspatialite-dev (>= 2.4.0~rc2-4), libepsilon-dev 
(>= 0.9.1),
-  libpoppler-dev, liblzma-dev, libopenjpeg-dev, libarmadillo-dev, 
libfreexl-dev (>= 1.0.0),
-  libkml-dev (>= 1.3.0~)
+  libpoppler-private-dev, liblzma-dev, libopenjpeg-dev, libarmadillo-dev, 
libfreexl-dev (>= 1.0.0),
 - libkml-dev, liburiparser-dev,
 - python3-all-dev, python3-numpy
++ libkml-dev (>= 1.3.0~), liburiparser-dev, python3-all-dev, python3-numpy
  Build-Conflicts: python-setuptools
- Standards-Version: 3.9.2
+ Standards-Version: 3.9.3
  XS-Python-Version: all
+ X-Python3-Version: >= 3.2
  Homepage: http://www.gdal.org/
  Vcs-Browser: http://git.debian.org/?p=pkg-grass/gdal.git
  Vcs-Git: git://git.debian.org/git/pkg-grass/gdal.git
@@@ -43,18 -45,42 +44,42 @@@ Description: Geospatial Data Abstractio
   .
   This package contains the shared library.
  
+ Package: libgdal1-dev
+ Section: libdevel
+ Architecture: all
+ Depends: libgdal-dev 
+ Description: Geospatial Data Abstraction Library - Development files
+  GDAL is a translator library for raster geospatial data formats.
+  As a library, it presents a single abstract data model to the
+  calling application for all supported formats. The related OGR
+  library (which lives within the GDAL source tree) provides
+  a similar capability for simple features vector data.
+  .
+  GDAL supports many popular data formats, including commonly used
+  ones (GeoTIFF, JPEG, PNG and more) as well as the ones used in
+  GIS and remote sensing software packages (ERDAS Imagine,
+  ESRI Arc/Info, ENVI, PCI Geomatics). Also supported many remote
+  sensing and scientific data distribution formats such as HDF,
+  EOS FAST, NOAA L1B, NetCDF, FITS.
+  .
+  OGR library supports popular vector formats like ESRI Shapefile,
+  TIGER data, S57, MapInfo File, DGN, GML and more.
+  .
+  This is a transitional dummy package that depends on libgdal-dev 
+  and is used to allow versioned build dependencies to work in 
+  any build environment.
+ 
  Package: libgdal-dev
  Section: libdevel
  Architecture: any
  Depends: libgdal1 (=${binary:Version}), libc6-dev, libnetcdf-dev, 
   libjasper-dev|libjasper-1.701-dev, libpng-dev, libjpeg-dev, libgif-dev, 
libhdf4-alt-dev, 
-  libpq-dev, libxerces-c2-dev, unixodbc-dev, libsqlite3-dev, libgeos-dev,
-  libmysqlclient-dev, libhdf5-serial-dev, libltdl3-dev, 
libcurl4-dev|libcurl3-dev,
+  libpq-dev, libxerces-c-dev, unixodbc-dev, libsqlite3-dev, libgeos-dev,
+  libmysqlclient-dev, libhdf5-serial-dev, libltdl3-dev, 
libcurl4-gnutls-dev|libcurl4-dev,
   libspatialite-dev, libdap-dev, ${misc:Depends}
  Suggests: libgdal-doc
- Provides: libgdal1-dev
- Replaces: libgdal1-dev
- Conflicts: libgdal1-dev
+ Conflicts: libgdal1-dev (<< 1.9.0-1~)
+ Replaces: libgdal1-dev (<< 1.9.0-1~)
  Description: Geospatial Data Abstraction Library - Development files
   GDAL is a translator library for raster geospatial data formats.
   As a library, it presents a single abstract data model to the
@@@ -79,7 -105,7 +104,7 @@@ Package: libgdal-do
  Section: doc
  Architecture: all
  Suggests: libgdal1
- Depends: ${misc:Depends} 
+ Depends: ${misc:Depends}
  Homepage: http://www.gdal.org/#index_userdocs
  Description: Documentation for the Geospatial Data Abstraction Library
   GDAL is a translator library for raster geospatial data formats.
@@@ -154,6 -180,33 +179,33 @@@ Description: Python bindings to the Geo
   This package contains Python bindings for GDAL/OGR library and
   a set of additional command line tools.
  
+ Package: python3-gdal
+ Section: python
+ Architecture: any
+ Depends: ${shlibs:Depends}, ${python3:Depends}, python3-numpy, ${misc:Depends}
+ Provides: ${python3:Provides}
+ Homepage: http://trac.osgeo.org/gdal/wiki/GdalOgrInPython
+ XB-Python-Version: ${python3:Versions}
+ Description: Python 3 bindings to the Geospatial Data Abstraction Library
+  GDAL is a translator library for raster geospatial data formats.
+  As a library, it presents a single abstract data model to the
+  calling application for all supported formats. The related OGR
+  library (which lives within the GDAL source tree) provides
+  a similar capability for simple features vector data.
+  .
+  GDAL supports 40+ popular data formats, including commonly used
+  ones (GeoTIFF, JPEG, PNG and more) as well as the ones used in
+  GIS and remote sensing software packages (ERDAS Imagine,
+  ESRI Arc/Info, ENVI, PCI Geomatics). Also supported many remote
+  sensing and scientific data distribution formats such as HDF,
+  EOS FAST, NOAA L1B, NetCDF, FITS.
+  .
+  OGR library supports popular vector formats like ESRI Shapefile,
+  TIGER data, S57, MapInfo File, DGN, GML and more.
+  .
+  This package contains Python 3 bindings for GDAL/OGR library and
+  a set of additional command line tools.
+ 
  Package: libgdal-perl
  Section: perl
  Architecture: any

-- 
GDAL/OGR library and tools

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to