Package: libkml-dev,libvxl1-dev
Version: libkml-dev/1.3.0~r863-4.1
Version: libvxl1-dev/1.17.0-2
Severity: serious
User: trei...@debian.org
Usertags: edos-file-overwrite

Date: 2013-05-17
Architecture: amd64
Distribution: sid

Hi,

automatic installation tests of packages that share a file and at the
same time do not conflict by their package dependency relationships has
detected the following problem:


WARNING: The following packages cannot be authenticated!
  libcap2 libpcre3 libwrap0 libdrm2 libglapi-mesa libxau6 libxdmcp6 libxcb1
  libx11-data libx11-6 libx11-xcb1 libxcb-glx0 libxfixes3 libxdamage1 libxext6
  libxxf86vm1 libgl1-mesa-glx libxi6 freeglut3 libasound2-data libasound2
  libasyncns0 x11-common libice6 libsm6 libxt6 libaudio2 libavutil51
  libdirac-encoder0 libgsm1 libmp3lame0 libopenjpeg2 liborc-0.4-0
  libschroedinger-1.0-0 libspeex1 libogg0 libtheora0 libva1 libvorbis0a
  libvorbisenc2 libvpx1 libx264-123 libxvidcore4 libavcodec53 librtmp0
  libavformat53 libavifile-0.7-common libexpat1 libfreetype6 ucf
  fonts-dejavu-core ttf-dejavu-core fontconfig-config libfontconfig1 libjpeg8
  libcaca0 tsconf libts-0.0-0 libdirectfb-1.2-9 libdbus-1-3 libjson0 libflac8
  libsndfile1 libxtst6 libpulse0 libsdl1.2debian libxrender1 libxft2
  libxxf86dga1 libavifile-0.7c2 libffi6 libglib2.0-0 libglu1-mesa liblcms1
  libmng1 libpng12-0 libqtcore4 fontconfig libjbig0 libtiff4 libqtgui4
  libqt4-opengl libraw1394-11 libswscale2 libtiff5 libusb-1.0-0 libdc1394-22
  liburiparser1 liburiparser-dev proj-data libproj0 libgeotiff2 libvxl1.17
  libvxl1-dev libkml0 libkml-dev

Extracting templates from packages: 31%
Extracting templates from packages: 62%
Extracting templates from packages: 93%
Extracting templates from packages: 100%
Preconfiguring packages ...
Authentication warning overridden.
Can not write log, openpty() failed (/dev/pts not mounted?)
Selecting previously unselected package libcap2:amd64.
(Reading database ... 10795 files and directories currently installed.)
Unpacking libcap2:amd64 (from .../libcap2_1%3a2.22-1.2_amd64.deb) ...
Selecting previously unselected package libpcre3:amd64.
Unpacking libpcre3:amd64 (from .../libpcre3_1%3a8.31-2_amd64.deb) ...
Selecting previously unselected package libwrap0:amd64.
Unpacking libwrap0:amd64 (from .../libwrap0_7.6.q-24_amd64.deb) ...
Selecting previously unselected package libdrm2:amd64.
Unpacking libdrm2:amd64 (from .../libdrm2_2.4.40-1~deb7u2_amd64.deb) ...
Selecting previously unselected package libglapi-mesa:amd64.
Unpacking libglapi-mesa:amd64 (from .../libglapi-mesa_8.0.5-4+b1_amd64.deb) ...
Selecting previously unselected package libxau6:amd64.
Unpacking libxau6:amd64 (from .../libxau6_1%3a1.0.7-1_amd64.deb) ...
Selecting previously unselected package libxdmcp6:amd64.
Unpacking libxdmcp6:amd64 (from .../libxdmcp6_1%3a1.1.1-1_amd64.deb) ...
Selecting previously unselected package libxcb1:amd64.
Unpacking libxcb1:amd64 (from .../libxcb1_1.8.1-2_amd64.deb) ...
Selecting previously unselected package libx11-data.
Unpacking libx11-data (from .../libx11-data_2%3a1.5.0-1_all.deb) ...
Selecting previously unselected package libx11-6:amd64.
Unpacking libx11-6:amd64 (from .../libx11-6_2%3a1.5.0-1_amd64.deb) ...
Selecting previously unselected package libx11-xcb1:amd64.
Unpacking libx11-xcb1:amd64 (from .../libx11-xcb1_2%3a1.5.0-1_amd64.deb) ...
Selecting previously unselected package libxcb-glx0:amd64.
Unpacking libxcb-glx0:amd64 (from .../libxcb-glx0_1.8.1-2_amd64.deb) ...
Selecting previously unselected package libxfixes3:amd64.
Unpacking libxfixes3:amd64 (from .../libxfixes3_1%3a5.0-4_amd64.deb) ...
Selecting previously unselected package libxdamage1:amd64.
Unpacking libxdamage1:amd64 (from .../libxdamage1_1%3a1.1.3-2_amd64.deb) ...
Selecting previously unselected package libxext6:amd64.
Unpacking libxext6:amd64 (from .../libxext6_2%3a1.3.1-2_amd64.deb) ...
Selecting previously unselected package libxxf86vm1:amd64.
Unpacking libxxf86vm1:amd64 (from .../libxxf86vm1_1%3a1.1.2-1_amd64.deb) ...
Selecting previously unselected package libgl1-mesa-glx:amd64.
Unpacking libgl1-mesa-glx:amd64 (from .../libgl1-mesa-glx_8.0.5-4+b1_amd64.deb) 
...
Selecting previously unselected package libxi6:amd64.
Unpacking libxi6:amd64 (from .../libxi6_2%3a1.6.1-1_amd64.deb) ...
Selecting previously unselected package freeglut3:amd64.
Unpacking freeglut3:amd64 (from .../freeglut3_2.8.1-1_amd64.deb) ...
Selecting previously unselected package libasound2-data.
Unpacking libasound2-data (from .../libasound2-data_1.0.27-4_all.deb) ...
Selecting previously unselected package libasound2:amd64.
Unpacking libasound2:amd64 (from .../libasound2_1.0.27-4_amd64.deb) ...
Selecting previously unselected package libasyncns0:amd64.
Unpacking libasyncns0:amd64 (from .../libasyncns0_0.8-4_amd64.deb) ...
Selecting previously unselected package x11-common.
Unpacking x11-common (from .../x11-common_1%3a7.7+3_all.deb) ...
Selecting previously unselected package libice6:amd64.
Unpacking libice6:amd64 (from .../libice6_2%3a1.0.8-2_amd64.deb) ...
Selecting previously unselected package libsm6:amd64.
Unpacking libsm6:amd64 (from .../libsm6_2%3a1.2.1-2_amd64.deb) ...
Selecting previously unselected package libxt6:amd64.
Unpacking libxt6:amd64 (from .../libxt6_1%3a1.1.3-1_amd64.deb) ...
Selecting previously unselected package libaudio2:amd64.
Unpacking libaudio2:amd64 (from .../libaudio2_1.9.3-5_amd64.deb) ...
Selecting previously unselected package libavutil51:amd64.
Unpacking libavutil51:amd64 (from .../libavutil51_6%3a0.8.6-1_amd64.deb) ...
Selecting previously unselected package libdirac-encoder0:amd64.
Unpacking libdirac-encoder0:amd64 (from 
.../libdirac-encoder0_1.0.2-6_amd64.deb) ...
Selecting previously unselected package libgsm1:amd64.
Unpacking libgsm1:amd64 (from .../libgsm1_1.0.13-4_amd64.deb) ...
Selecting previously unselected package libmp3lame0:amd64.
Unpacking libmp3lame0:amd64 (from .../libmp3lame0_3.99.5+repack1-3_amd64.deb) 
...
Selecting previously unselected package libopenjpeg2:amd64.
Unpacking libopenjpeg2:amd64 (from .../libopenjpeg2_1.3+dfsg-4.6_amd64.deb) ...
Selecting previously unselected package liborc-0.4-0:amd64.
Unpacking liborc-0.4-0:amd64 (from .../liborc-0.4-0_1%3a0.4.17-2_amd64.deb) ...
Selecting previously unselected package libschroedinger-1.0-0:amd64.
Unpacking libschroedinger-1.0-0:amd64 (from 
.../libschroedinger-1.0-0_1.0.11-2_amd64.deb) ...
Selecting previously unselected package libspeex1:amd64.
Unpacking libspeex1:amd64 (from .../libspeex1_1.2~rc1-7_amd64.deb) ...
Selecting previously unselected package libogg0:amd64.
Unpacking libogg0:amd64 (from .../libogg0_1.3.1-1_amd64.deb) ...
Selecting previously unselected package libtheora0:amd64.
Unpacking libtheora0:amd64 (from .../libtheora0_1.1.1+dfsg.1-3.1_amd64.deb) ...
Selecting previously unselected package libva1:amd64.
Unpacking libva1:amd64 (from .../libva1_1.0.15-4_amd64.deb) ...
Selecting previously unselected package libvorbis0a:amd64.
Unpacking libvorbis0a:amd64 (from .../libvorbis0a_1.3.2-1.3_amd64.deb) ...
Selecting previously unselected package libvorbisenc2:amd64.
Unpacking libvorbisenc2:amd64 (from .../libvorbisenc2_1.3.2-1.3_amd64.deb) ...
Selecting previously unselected package libvpx1:amd64.
Unpacking libvpx1:amd64 (from .../libvpx1_1.1.0-1_amd64.deb) ...
Selecting previously unselected package libx264-123:amd64.
Unpacking libx264-123:amd64 (from 
.../libx264-123_2%3a0.123.2189+git35cf912-1_amd64.deb) ...
Selecting previously unselected package libxvidcore4:amd64.
Unpacking libxvidcore4:amd64 (from .../libxvidcore4_2%3a1.3.2-9_amd64.deb) ...
Selecting previously unselected package libavcodec53:amd64.
Unpacking libavcodec53:amd64 (from .../libavcodec53_6%3a0.8.6-1_amd64.deb) ...
Selecting previously unselected package librtmp0:amd64.
Unpacking librtmp0:amd64 (from 
.../librtmp0_2.4+20121230.gitdf6c518-1_amd64.deb) ...
Selecting previously unselected package libavformat53:amd64.
Unpacking libavformat53:amd64 (from .../libavformat53_6%3a0.8.6-1_amd64.deb) ...
Selecting previously unselected package libavifile-0.7-common.
Unpacking libavifile-0.7-common (from 
.../libavifile-0.7-common_1%3a0.7.48~20090503.ds-13_all.deb) ...
Selecting previously unselected package libexpat1:amd64.
Unpacking libexpat1:amd64 (from .../libexpat1_2.1.0-3_amd64.deb) ...
Selecting previously unselected package libfreetype6:amd64.
Unpacking libfreetype6:amd64 (from .../libfreetype6_2.4.9-1.1_amd64.deb) ...
Selecting previously unselected package ucf.
Unpacking ucf (from .../ucf_3.0025+nmu3_all.deb) ...
Moving old data out of the way
Selecting previously unselected package fonts-dejavu-core.
Unpacking fonts-dejavu-core (from .../fonts-dejavu-core_2.33+svn2514-3_all.deb) 
...
Selecting previously unselected package ttf-dejavu-core.
Unpacking ttf-dejavu-core (from .../ttf-dejavu-core_2.33+svn2514-3_all.deb) ...
Selecting previously unselected package fontconfig-config.
Unpacking fontconfig-config (from .../fontconfig-config_2.9.0-7.1_all.deb) ...
Selecting previously unselected package libfontconfig1:amd64.
Unpacking libfontconfig1:amd64 (from .../libfontconfig1_2.9.0-7.1_amd64.deb) ...
Selecting previously unselected package libjpeg8:amd64.
Unpacking libjpeg8:amd64 (from .../libjpeg8_8d-1_amd64.deb) ...
Selecting previously unselected package libcaca0:amd64.
Unpacking libcaca0:amd64 (from .../libcaca0_0.99.beta18-1_amd64.deb) ...
Selecting previously unselected package tsconf.
Unpacking tsconf (from .../archives/tsconf_1.0-11_all.deb) ...
Selecting previously unselected package libts-0.0-0:amd64.
Unpacking libts-0.0-0:amd64 (from .../libts-0.0-0_1.0-11_amd64.deb) ...
Selecting previously unselected package libdirectfb-1.2-9:amd64.
Unpacking libdirectfb-1.2-9:amd64 (from 
.../libdirectfb-1.2-9_1.2.10.0-5_amd64.deb) ...
Selecting previously unselected package libdbus-1-3:amd64.
Unpacking libdbus-1-3:amd64 (from .../libdbus-1-3_1.6.10-1_amd64.deb) ...
Selecting previously unselected package libjson0:amd64.
Unpacking libjson0:amd64 (from .../libjson0_0.10-1.2_amd64.deb) ...
Selecting previously unselected package libflac8:amd64.
Unpacking libflac8:amd64 (from .../libflac8_1.2.1-6_amd64.deb) ...
Selecting previously unselected package libsndfile1:amd64.
Unpacking libsndfile1:amd64 (from .../libsndfile1_1.0.25-5_amd64.deb) ...
Selecting previously unselected package libxtst6:amd64.
Unpacking libxtst6:amd64 (from .../libxtst6_2%3a1.2.1-1_amd64.deb) ...
Selecting previously unselected package libpulse0:amd64.
Unpacking libpulse0:amd64 (from .../libpulse0_2.0-6.1_amd64.deb) ...
Selecting previously unselected package libsdl1.2debian:amd64.
Unpacking libsdl1.2debian:amd64 (from .../libsdl1.2debian_1.2.15-5_amd64.deb) 
...
Selecting previously unselected package libxrender1:amd64.
Unpacking libxrender1:amd64 (from .../libxrender1_1%3a0.9.7-1_amd64.deb) ...
Selecting previously unselected package libxft2:amd64.
Unpacking libxft2:amd64 (from .../libxft2_2.3.1-1_amd64.deb) ...
Selecting previously unselected package libxxf86dga1:amd64.
Unpacking libxxf86dga1:amd64 (from .../libxxf86dga1_2%3a1.1.3-2_amd64.deb) ...
Selecting previously unselected package libavifile-0.7c2:amd64.
Unpacking libavifile-0.7c2:amd64 (from 
.../libavifile-0.7c2_1%3a0.7.48~20090503.ds-13_amd64.deb) ...
Selecting previously unselected package libffi6:amd64.
Unpacking libffi6:amd64 (from .../libffi6_3.0.13-4_amd64.deb) ...
Selecting previously unselected package libglib2.0-0:amd64.
Unpacking libglib2.0-0:amd64 (from .../libglib2.0-0_2.36.1-2build1_amd64.deb) 
...
Selecting previously unselected package libglu1-mesa:amd64.
Unpacking libglu1-mesa:amd64 (from .../libglu1-mesa_8.0.5-4+b1_amd64.deb) ...
Selecting previously unselected package liblcms1:amd64.
Unpacking liblcms1:amd64 (from .../liblcms1_1.19.dfsg-1.2_amd64.deb) ...
Selecting previously unselected package libmng1:amd64.
Unpacking libmng1:amd64 (from .../libmng1_1.0.10-3_amd64.deb) ...
Selecting previously unselected package libpng12-0:amd64.
Unpacking libpng12-0:amd64 (from .../libpng12-0_1.2.49-4_amd64.deb) ...
Selecting previously unselected package libqtcore4:amd64.
Unpacking libqtcore4:amd64 (from .../libqtcore4_4%3a4.8.2+dfsg-11_amd64.deb) ...
Selecting previously unselected package fontconfig.
Unpacking fontconfig (from .../fontconfig_2.9.0-7.1_amd64.deb) ...
Selecting previously unselected package libjbig0:amd64.
Unpacking libjbig0:amd64 (from .../libjbig0_2.0-2_amd64.deb) ...
Selecting previously unselected package libtiff4:amd64.
Unpacking libtiff4:amd64 (from .../libtiff4_3.9.6-11_amd64.deb) ...
Selecting previously unselected package libqtgui4:amd64.
Unpacking libqtgui4:amd64 (from .../libqtgui4_4%3a4.8.2+dfsg-11_amd64.deb) ...
Selecting previously unselected package libqt4-opengl:amd64.
Unpacking libqt4-opengl:amd64 (from 
.../libqt4-opengl_4%3a4.8.2+dfsg-11_amd64.deb) ...
Selecting previously unselected package libraw1394-11:amd64.
Unpacking libraw1394-11:amd64 (from .../libraw1394-11_2.1.0-1_amd64.deb) ...
Selecting previously unselected package libswscale2:amd64.
Unpacking libswscale2:amd64 (from .../libswscale2_6%3a0.8.6-1_amd64.deb) ...
Selecting previously unselected package libtiff5:amd64.
Unpacking libtiff5:amd64 (from .../libtiff5_4.0.2-6_amd64.deb) ...
Selecting previously unselected package libusb-1.0-0:amd64.
Unpacking libusb-1.0-0:amd64 (from .../libusb-1.0-0_2%3a1.0.15-1_amd64.deb) ...
Selecting previously unselected package libdc1394-22:amd64.
Unpacking libdc1394-22:amd64 (from .../libdc1394-22_2.2.1-1_amd64.deb) ...
Selecting previously unselected package liburiparser1.
Unpacking liburiparser1 (from .../liburiparser1_0.7.5-1_amd64.deb) ...
Selecting previously unselected package liburiparser-dev.
Unpacking liburiparser-dev (from .../liburiparser-dev_0.7.5-1_amd64.deb) ...
Selecting previously unselected package proj-data.
Unpacking proj-data (from .../proj-data_4.7.0-2_amd64.deb) ...
Selecting previously unselected package libproj0.
Unpacking libproj0 (from .../libproj0_4.7.0-2_amd64.deb) ...
Selecting previously unselected package libgeotiff2.
Unpacking libgeotiff2 (from .../libgeotiff2_1.3.0+dfsg-3_amd64.deb) ...
Selecting previously unselected package libvxl1.17.
Unpacking libvxl1.17 (from .../libvxl1.17_1.17.0-2_amd64.deb) ...
Selecting previously unselected package libvxl1-dev.
Unpacking libvxl1-dev (from .../libvxl1-dev_1.17.0-2_amd64.deb) ...
Selecting previously unselected package libkml0.
Unpacking libkml0 (from .../libkml0_1.3.0~r863-4.1_amd64.deb) ...
Selecting previously unselected package libkml-dev.
Unpacking libkml-dev (from .../libkml-dev_1.3.0~r863-4.1_amd64.deb) ...
dpkg: error processing 
/var/cache/apt/archives/libkml-dev_1.3.0~r863-4.1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/libminizip.so', which is also in package 
libvxl1-dev 1.17.0-2
Processing triggers for man-db ...
Errors were encountered while processing:
 /var/cache/apt/archives/libkml-dev_1.3.0~r863-4.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
cow-shell unlink .ilist: No such file or directory


This is a serious bug as it makes installation fail, and violates
sections 7.6.1 and 10.1 of the policy. An optimal solution would
consist in only one of the packages installing that file, and renaming
or removing the file in the other package. Depending on the
circumstances you might also consider Replace relations or file
diversions. If the conflicting situation cannot be resolved then, as a
last resort, the two packages have to declare a mutual
Conflict. Please take into account that Replaces, Conflicts and
diversions should only be used when packages provide different
implementations for the same functionality.

Here is a list of files that are known to be shared by both packages
(according to the Contents file for sid/amd64, which may be
slightly out of sync):

  /usr/lib/libminizip.so

This bug has been filed against both packages. If you, the maintainers of
the two packages in question, have agreed on which of the packages will
resolve the problem please reassign the bug to that package. You may then
also register in the BTS that the other package is affected by the bug.

-Ralf.

PS: for more information about the detection of file overwrite errors
of this kind see http://edos.debian.net/file-overwrites/.

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to