Package: src:grads
Followup-For: Bug #711789

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Dear maintainer,

please apply attached patch to use libtiff5-alt-dev instead of
libtiff5-dev.  The libtiff5-dev & libtiff4-dev conflicts makes
downstream packages (namely grads) unbuildable and it's blocking the
libgd2 transition.

I plan to NMU the package if I don't hear from you soon (it's RC
severity bug).

The changes I did are minimal - the other option would be to make
upstream configure.ac to use pkg-config (which would be more elegant,
but also more intrusive).

Thanks,
O.

- -- System Information:
Debian Release: 7.1
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-4-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iEYEARECAAYFAlHL/GkACgkQ9OZqfMIN8nPcogCfSd/WByakSLYRqY4MJhHPOdKU
ajoAn2bNUscvb0F06wYhsd3qVhJhwpfg
=hw+h
-----END PGP SIGNATURE-----
diff --git a/debian/changelog b/debian/changelog
index 534f8b4..e6cfbd7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+libgeotiff-dfsg (1.3.0+dfsg-3.1) unstable; urgency=low
+
+  * Non-maintainer upload.
+  * Depend just on libtiff-dev, to allow smooth tiff transition
+    (Closes: #711789)
+
+ -- Ondřej Surý <ond...@debian.org>  Thu, 27 Jun 2013 10:24:57 +0200
+
 libgeotiff-dfsg (1.3.0+dfsg-3) unstable; urgency=high
 
   * Fixed wrong libgeotiff-dev dependency on old libtiff-dev version. 
diff --git a/debian/control b/debian/control
index 1a2c205..1d74109 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Priority: extra
 Section: science
 Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
 Uploaders: Francesco Paolo Lovergine <fran...@debian.org>, Alan Boudreault <aboudrea...@mapgears.com>
-Build-Depends: debhelper (>= 8), autotools-dev, libproj-dev, zlib1g-dev, libjpeg-dev, libtiff5-dev
+Build-Depends: debhelper (>= 8), autotools-dev, libproj-dev, zlib1g-dev, libjpeg-dev, libtiff5-alt-dev
 Standards-Version: 3.9.3
 Homepage: http://geotiff.osgeo.org/
 Vcs-Browser: http://git.debian.org/?p=pkg-grass/libgeotiff-dfsg.git
@@ -12,7 +12,7 @@ Vcs-Git: git://git.debian.org/git/pkg-grass/libgeotiff-dfsg.git
 Package: libgeotiff-dev
 Section: libdevel
 Architecture: any
-Depends: libgeotiff2 (= ${binary:Version}), libtiff5-dev
+Depends: libgeotiff2 (= ${binary:Version}), libtiff5-alt-dev
 Suggests: libgeotiff-epsg
 Description: the GeoTIFF library -- development files
  This C library supports TIFF 6.0 based interchange format for georeferenced 
diff --git a/debian/rules b/debian/rules
index 1e9dce0..c4dada9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,9 +8,9 @@
 # from having to guess our platform (since we know it already)
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_HOST_MULTIARHC  ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
 
-
-CFLAGS = -Wall -g
+CFLAGS = -Wall -g -L/usr/lib/$(DEB_HOST_MULTIARCH)/libtiff5-alt/ -I/usr/include/libtiff5-alt
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
 	CFLAGS += -O0
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to